]> git.pld-linux.org Git - packages/PackageKit.git/blame - PackageKit.spec
- updated to 1.2.6
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
574f2e60
JB
4# - setup dnf vendor properly? (see meson command)
5# - daemon user (see meson command)
d05d9108
MB
6#
7# Conditional build:
658d6c88 8%bcond_without apidocs # API documentation
53810c7c 9%bcond_without introspection # gobject introspection, time to time broken
aa278a7b
JB
10%bcond_without static_libs # static library
11%bcond_without python # Python binding (used by entropy and portage backends)
12%bcond_without vala # Vala binding
13# backends
d06070b1 14%bcond_with alpm # ALPM (Arch Linux package manager) backend
04e18045 15%bcond_with apt # APT (Debian/Ubuntu) backend using C++ API
574f2e60 16%bcond_without dnf # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
04e18045 17%bcond_with entropy # Entropy (Sabayon) backend (Python)
574f2e60 18%bcond_with nix # Nix (NixOS) backend [broken as of 1.2.0-1.2.5]
04e18045
JB
19%bcond_without poldek # Poldek (PLD) backend
20%bcond_with portage # portage (Gentoo) backend (Python)
49ea0764 21%bcond_with slack # Slack (Slackware) backend
574f2e60 22%bcond_with zypp # ZYPP (openSUSE/SLE) backend
0e84469f 23
aa278a7b
JB
24%if %{without python}
25%undefine with_entropy
26%undefine with_portage
04e18045 27%endif
0e84469f 28
85d27e4f
JB
29Summary: System daemon that is a D-Bus abstraction layer for package management
30Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 31Name: PackageKit
5ece0444 32Version: 1.2.6
783c79a3 33Release: 1
a2d83637 34License: GPL v2+
85d27e4f 35Group: Applications/System
90405068 36Source0: https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
5ece0444 37# Source0-md5: 71f855b4ac809b642ec911ce12dd8010
02b3d2d3 38Patch0: %{name}-poldek.patch
aa278a7b 39Patch2: %{name}-meson.patch
bcd7526e 40Patch3: consolekit-fallback.patch
90405068 41URL: https://www.freedesktop.org/software/PackageKit/
ea58ad5c 42%{?with_apt:BuildRequires: AppStream-devel >= 0.12}
a2d83637 43BuildRequires: NetworkManager-devel >= 0.6.5
574f2e60
JB
44# pkgconfig(libalpm) >= 13.0.0
45%{?with_alpm:BuildRequires: alpm-devel >= 6.0}
49ea0764 46%{?with_dnf:BuildRequires: appstream-glib-devel}
ea58ad5c 47%{?with_apt:BuildRequires: apt-devel >= 1.9.2}
e0e35018 48BuildRequires: bash-completion-devel >= 2.0
577193a4 49BuildRequires: connman-devel
49ea0764 50%{?with_slack:BuildRequires: curl-devel}
6808f644 51BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 52BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 53BuildRequires: docbook-dtd412-xml
54BuildRequires: docbook-dtd42-xml
dac2b5e1 55BuildRequires: fontconfig-devel
a0f1aeda 56BuildRequires: gettext-tools
574f2e60 57BuildRequires: glib2-devel >= 1:2.62
53810c7c 58%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
59BuildRequires: gstreamer-devel >= 1.0.0
60BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
dac2b5e1 61BuildRequires: gtk+3-devel >= 3.0.0
658d6c88 62%{?with_apidocs:BuildRequires: gtk-doc >= 1.11}
78293e06 63BuildRequires: libarchive-devel
aa278a7b 64%{?with_dnf:BuildRequires: libdnf-devel >= 0.43.1}
49ea0764
JB
65%if %{with apt} || %{with nix}
66BuildRequires: libstdc++-devel >= 6:4.7
67%endif
68%{?with_slack:BuildRequires: libstdc++-devel >= 6:5}
dac2b5e1 69BuildRequires: libxslt-progs
5ece0444 70%{?with_zypp:BuildRequires: libzypp-devel >= 17.31.0}
e0e35018 71BuildRequires: meson >= 0.50
aa278a7b 72BuildRequires: ninja >= 1.5
49ea0764 73# nix-expr nix-main nix-store
5ece0444 74%{?with_nix:BuildRequires: nix-devel >= 2.9}
dac2b5e1 75BuildRequires: pango-devel
a2d83637 76BuildRequires: pkgconfig
e0e35018 77# just to detect which reboot modes to use (library not linked)
49ea0764 78#BuildRequires: plymouth-devel >= 0.9.5
7cd3cbcf 79%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
49ea0764
JB
80BuildRequires: polkit-devel >= 0.114
81# or 1:3.2
02b3d2d3 82%{?with_python:BuildRequires: python-devel >= 1:2.7}
827cd5e7 83BuildRequires: readline-devel
e0e35018 84BuildRequires: rpm-build >= 4.6
ea58ad5c 85%{?with_dnf:BuildRequires: rpm-devel >= 1:4.6}
a2d83637 86BuildRequires: rpm-pythonprov
aa278a7b
JB
87BuildRequires: rpmbuild(macros) >= 1.736
88BuildRequires: sed >= 4.0
577193a4 89BuildRequires: sqlite3-devel >= 3
574f2e60 90# or elogind >= 229.4
49ea0764 91BuildRequires: systemd-devel >= 1:213
e216f3d9 92BuildRequires: tar >= 1:1.22
9ed4ca79 93BuildRequires: udev-glib-devel
8ad97aee 94%{?with_vala:BuildRequires: vala >= 2:0.16}
e216f3d9 95BuildRequires: xz
fcd0bc5c 96Requires(post,postun): shared-mime-info
0d5f415c 97Requires: %{name}-backend
a2d83637 98Requires: %{name}-libs = %{version}-%{release}
8d48627e 99Requires: crondaemon
49ea0764 100Requires: polkit >= 0.114
48178e4e 101Suggests: ConsoleKit-x11
e0e35018
JB
102Obsoletes: PackageKit-backend-pisi < 1.2
103Obsoletes: PackageKit-backend-ports < 1.2
104Obsoletes: PackageKit-backend-smart < 1.0
105Obsoletes: PackageKit-backend-urpmi < 1.2
106Obsoletes: PackageKit-backend-yum < 1.2
7cd3cbcf 107Obsoletes: PackageKit-docs < 0.8.4
e0e35018 108Obsoletes: pm-utils-packagekit < 0.8.15
a2d83637
MB
109BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111%description
112PackageKit is a D-Bus abstraction layer that allows the session user
113to manage packages in a secure way using a cross-distro,
114cross-architecture API.
115
85d27e4f
JB
116%description -l pl.UTF-8
117PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
118sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
119zgodnego z wieloma dystrybucjami i architekturami.
120
a2d83637 121%package libs
d05d9108
MB
122Summary: packagekit-glib library
123Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 124Group: Libraries
574f2e60 125Requires: glib2 >= 1:2.62
49ea0764 126Obsoletes: browser-plugin-packagekit < 1.1.0
a2d83637
MB
127
128%description libs
d05d9108 129packagekit-glib library.
a2d83637
MB
130
131%description libs -l pl.UTF-8
d05d9108 132Biblioteka packagekit-glib.
a2d83637
MB
133
134%package devel
d05d9108
MB
135Summary: Header files for packagekit-glib library
136Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
137Group: Development/Libraries
138Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 139Requires: dbus-devel >= 1.2.0
574f2e60 140Requires: glib2-devel >= 1:2.62
9ed4ca79 141Requires: sqlite3-devel
a2d83637
MB
142
143%description devel
d05d9108 144Header files for packagekit-glib library.
a2d83637
MB
145
146%description devel -l pl.UTF-8
d05d9108 147Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
148
149%package static
d05d9108
MB
150Summary: Static packagekit-glib library
151Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
152Group: Development/Libraries
153Requires: %{name}-devel = %{version}-%{release}
154
155%description static
d05d9108 156Static packagekit-glib library.
a2d83637
MB
157
158%description static -l pl.UTF-8
d05d9108
MB
159Statyczna biblioteka packagekit-glib.
160
8ad97aee
JB
161%package -n vala-packagekit
162Summary: Vala API for PackageKit library
163Summary(pl.UTF-8): API języka Vala do biblioteki PackageKitu
164Group: Development/Libraries
165Requires: %{name}-devel = %{version}-%{release}
166Requires: vala >= 2:0.16
0e84469f 167BuildArch: noarch
8ad97aee
JB
168
169%description -n vala-packagekit
170Vala API for PackageKit library.
171
172%description -n vala-packagekit -l pl.UTF-8
173API języka Vala do biblioteki PackageKitu.
174
16acf8d5
JB
175%package apidocs
176Summary: PackageKit library API documentation
177Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
178Group: Documentation
179Requires: gtk-doc-common
2aa4ef3d 180BuildArch: noarch
16acf8d5
JB
181
182%description apidocs
183PackageKit library API documentation.
184
185%description apidocs -l pl.UTF-8
186Dokumentacja API biblioteki PackageKit.
187
d06070b1
JB
188%package backend-alpm
189Summary: PackageKit ALPM backend
190Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece ALPM
191Group: Libraries
192Requires: %{name} = %{version}-%{release}
193Provides: %{name}-backend = %{version}-%{release}
d06070b1
JB
194
195%description backend-alpm
196A backend for PackageKit to enable Arch Linux packages via ALPM
197library.
198
199%description backend-alpm -l pl.UTF-8
200Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
201bibliotekę ALPM.
202
04e18045
JB
203%package backend-aptcc
204Summary: PackageKit APTcc backend
205Summary(pl.UTF-8): Backend PackageKit APTcc
206Group: Libraries
207Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
208Requires: AppStream >= 0.12
209Requires: apt >= 1.9.2
04e18045
JB
210Provides: %{name}-backend = %{version}-%{release}
211
212%description backend-aptcc
213A backend for PackageKit to enable APT support via C++ API.
214
215%description backend-aptcc -l pl.UTF-8
216Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
217C++.
218
49ea0764
JB
219%package backend-dnf
220Summary: PackageKit dnf backend
221Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece dnfhif
222Group: Libraries
223Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
224Requires: libdnf >= 0.43.1
225Requires: rpm >= 1:4.6
49ea0764 226Provides: %{name}-backend = %{version}-%{release}
e0e35018
JB
227Obsoletes: PackageKit-backend-hawkey < 1.0
228Obsoletes: PackageKit-backend-hif < 1.2
49ea0764
JB
229
230%description backend-dnf
231A backend for PackageKit to enable RPM packages support via dnf
232library (used in Fedora).
233
234%description backend-dnf -l pl.UTF-8
235Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
236dnf (używaną w dystrybucji Fedora).
237
04e18045
JB
238%package backend-entropy
239Summary: PackageKit Entropy backend
240Summary(pl.UTF-8): Backend PackageKit Entropy
241Group: Libraries
242Requires: %{name} = %{version}-%{release}
243Requires: python-packagekit = %{version}-%{release}
244#Requires: python-entropy
245Provides: %{name}-backend = %{version}-%{release}
246
247%description backend-entropy
248A backend for PackageKit to enable Sabayon packages support through
249Entropy package manager.
250
251%description backend-entropy -l pl.UTF-8
252Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
253użyciu zarządcy pakietów Entropy.
254
49ea0764
JB
255%package backend-nix
256Summary: PackageKit Nix backend
257Summary(pl.UTF-8): Backend PackageKit oparty na zarządcy pakietów Nix
04e18045
JB
258Group: Libraries
259Requires: %{name} = %{version}-%{release}
5ece0444 260Requires: nix >= 2.9
04e18045
JB
261Provides: %{name}-backend = %{version}-%{release}
262
49ea0764
JB
263%description backend-nix
264A backend for PackageKit to enable Nix packages support (used in
265NixOS).
04e18045 266
49ea0764
JB
267%description backend-nix -l pl.UTF-8
268Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
04e18045 269
0d5f415c
ER
270%package backend-poldek
271Summary: PackageKit Poldek backend
16acf8d5 272Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
273Group: Libraries
274Requires: %{name} = %{version}-%{release}
7cd3cbcf 275Requires: poldek >= 0.30-1.rc6.4
16acf8d5 276Provides: %{name}-backend = %{version}-%{release}
0d5f415c
ER
277
278%description backend-poldek
04e18045
JB
279A backend for PackageKit to enable RPM packages support through Poldek
280- native PLD package manager.
0d5f415c 281
16acf8d5 282%description backend-poldek -l pl.UTF-8
04e18045
JB
283Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
284natywnego zarządcę pakietów dystrybucji PLD.
285
286%package backend-portage
287Summary: PackageKit Portage backend
288Summary(pl.UTF-8): Backend PackageKit Portage
289Group: Libraries
290Requires: %{name} = %{version}-%{release}
291Requires: python-packagekit = %{version}-%{release}
292#Requires: python-portage
293Provides: %{name}-backend = %{version}-%{release}
294
295%description backend-portage
296A backend for PackageKit to enable Gentoo Portage support.
297
298%description backend-portage -l pl.UTF-8
299Backend PackageKit dodający obsługę systemu Portage dystrybucji
300Gentoo.
301
49ea0764
JB
302%package backend-slack
303Summary: PackageKit Slack backend
304Summary(pl.UTF-8): Backend PackageKit Slack
305Group: Libraries
306Requires: %{name} = %{version}-%{release}
307Provides: %{name}-backend = %{version}-%{release}
e0e35018 308Obsoletes: PackageKit-backend-katja < 1.2
49ea0764
JB
309
310%description backend-slack
311Slack backend for PackageKit to enable Slackware repositories support.
312
313%description backend-slack -l pl.UTF-8
314Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
315
04e18045
JB
316%package backend-zypp
317Summary: PackageKit Zypp backend
318Summary(pl.UTF-8): Backend PackageKit Zypp
319Group: Libraries
320Requires: %{name} = %{version}-%{release}
5ece0444 321Requires: libzypp >= 17.31.0
04e18045
JB
322Provides: %{name}-backend = %{version}-%{release}
323
324%description backend-zypp
325A backend for PackageKit to enable RPM packages support through Zypp
326library (originated in openSUSE/SLE).
327
328%description backend-zypp -l pl.UTF-8
329Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
330Zypp (pochodzącą z dystrybucji openSUSE/SLE).
16acf8d5 331
d05d9108
MB
332%package gstreamer-plugin
333Summary: GStreamer codecs installer
334Summary(pl.UTF-8): Instalator kodeków GStreamera
335Group: Applications
336Requires: %{name} = %{version}-%{release}
aa278a7b 337Requires: %{name}-gtk3-module = %{version}-%{release}
d05d9108
MB
338
339%description gstreamer-plugin
340The PackageKit GStreamer plugin allows any GStreamer application to
341install codecs from configured repositories using PackageKit.
342
343%description gstreamer-plugin -l pl.UTF-8
344Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
345zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
346
dac2b5e1
AF
347%package gtk3-module
348Summary: GTK+ 3.x module to detect and install missing fonts
349Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
350Group: X11/Libraries
aa278a7b 351Obsoletes: PackageKit-gtk-module < 1.2.0
dac2b5e1
AF
352
353%description gtk3-module
354The PackageKit GTK+ 3.x module allows any pango application to install
355missing fonts from configured repositories using PackageKit.
356
357%description gtk3-module -l pl.UTF-8
358Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
359brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
360
a2d83637 361%package -n bash-completion-packagekit
16acf8d5
JB
362Summary: Bash completion for PackageKit console commands
363Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 364Group: Applications/Shells
577193a4
JB
365Requires: %{name} = %{version}-%{release}
366Requires: bash-completion >= 2
ead2d2f6 367BuildArch: noarch
a2d83637
MB
368
369%description -n bash-completion-packagekit
16acf8d5 370This package provides bash-completion for PackageKit console commands.
a2d83637
MB
371
372%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
373Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
374konsolowych PackageKit.
a2d83637 375
a2d83637
MB
376%package -n python-packagekit
377Summary: PackageKit Python bindings
378Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
379Group: Development/Languages/Python
380Requires: python-dbus
381Requires: python-pygobject
382
383%description -n python-packagekit
384PackageKit Python bindings.
385
86086d14 386%description -n python-packagekit -l pl.UTF-8
a2d83637
MB
387Wiązania PackageKit dla Pythona.
388
389%prep
390%setup -q
d113818a 391%patch0 -p1
aa278a7b 392%patch2 -p1
bcd7526e 393%patch3 -p1
a2d83637 394
aa278a7b
JB
395%if %{with static_libs}
396%{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
d5617342 397%endif
aa278a7b
JB
398
399%build
aa278a7b
JB
400%meson build \
401 -Dbash_command_not_found=false \
aa278a7b 402 %{!?with_introspection:-Dgobject_introspection=false} \
658d6c88 403 %{?with_apidocs:-Dgtk_doc=true} \
aa278a7b
JB
404 -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
405 %{!?with_python:-Dpython_backend=false} \
406 -Dpythonpackagedir=%{py_sitescriptdir} \
407 -Dsystemdsystemunitdir=%{systemdunitdir}
408
409# TODO:
410# -Ddnf_vendor=
411# -Dpackagekit_user=
412
413%ninja_build -C build
a2d83637
MB
414
415%install
416rm -rf $RPM_BUILD_ROOT
aa278a7b 417install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
a2d83637 418
aa278a7b
JB
419%ninja_install -C build
420
421%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
e0e35018 422%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
5059111f 423
d05d9108 424# use pk-gstreamer-install as codec installer
aa278a7b 425ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
d05d9108 426
aa278a7b
JB
427install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
428ln -sf ../packagekit-offline-update.service \
429 $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
430
431%if %{with python}
432%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
433%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
dac2b5e1 434
a2d83637 435%py_postclean
aa278a7b 436%endif
a2d83637 437
6808f644
MB
438%find_lang %{name}
439
a2d83637
MB
440%clean
441rm -rf $RPM_BUILD_ROOT
442
fcd0bc5c
MB
443%post
444%update_mime_database
445
446%postun
447%update_mime_database
448
85d27e4f 449%post libs -p /sbin/ldconfig
a2d83637
MB
450%postun libs -p /sbin/ldconfig
451
6808f644 452%files -f %{name}.lang
a2d83637 453%defattr(644,root,root,755)
02b3d2d3 454%doc AUTHORS HACKING MAINTAINERS NEWS README
a2d83637
MB
455%attr(755,root,root) %{_bindir}/pkcon
456%attr(755,root,root) %{_bindir}/pkmon
50832223 457%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
02b3d2d3
JB
458%attr(755,root,root) %{_libexecdir}/packagekit-direct
459%attr(755,root,root) %{_libexecdir}/packagekitd
460%attr(755,root,root) %{_libexecdir}/pk-offline-update
a2d83637 461%dir %{_libdir}/packagekit-backend
aa278a7b 462%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
a2d83637
MB
463%dir %{_sysconfdir}/PackageKit
464%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 465%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
5baab3aa
ER
466%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
467/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
d05d9108 468%dir %{_datadir}/PackageKit
6e66a3a4 469%dir %{_datadir}/PackageKit/helpers
d05d9108 470%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 471%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 472%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 473%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
a2d83637 474%{_mandir}/man1/pkcon.1*
78293e06 475%{_mandir}/man1/pkmon.1*
53810c7c 476%{systemdunitdir}/packagekit.service
7cd3cbcf 477%{systemdunitdir}/packagekit-offline-update.service
02b3d2d3 478%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
78293e06
MB
479%dir /var/cache/PackageKit
480%dir /var/cache/PackageKit/downloads
a2d83637 481%dir /var/lib/PackageKit
d05d9108 482%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
483
484%files libs
485%defattr(644,root,root,755)
74872af2 486%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
02b3d2d3 487%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
dac2b5e1 488%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
2ab9cd42
JB
489# NOTE: dbus interface xmls are commonly used:
490# - at runtime by packagekitd
491# - for development of applications using PK dbus interface
492%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
493%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 494
a2d83637
MB
495%files devel
496%defattr(644,root,root,755)
74872af2 497%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 498%{_pkgconfigdir}/packagekit-glib2.pc
d05d9108 499%dir %{_includedir}/PackageKit
74872af2 500%{_includedir}/PackageKit/packagekit-glib2
dac2b5e1 501%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
08c67dac 502
0e57d6d1 503%if %{with static_libs}
a2d83637
MB
504%files static
505%defattr(644,root,root,755)
74872af2 506%{_libdir}/libpackagekit-glib2.a
0e57d6d1 507%endif
d05d9108 508
8ad97aee
JB
509%if %{with vala}
510%files -n vala-packagekit
511%defattr(644,root,root,755)
aa278a7b 512%{_datadir}/vala/vapi/packagekit-glib2.deps
8ad97aee
JB
513%{_datadir}/vala/vapi/packagekit-glib2.vapi
514%endif
515
0e57d6d1 516%if %{with apidocs}
16acf8d5
JB
517%files apidocs
518%defattr(644,root,root,755)
519%{_gtkdocdir}/PackageKit
0e57d6d1 520%endif
16acf8d5 521
d06070b1
JB
522%if %{with alpm}
523%files backend-alpm
0d5f415c 524%defattr(644,root,root,755)
d06070b1
JB
525%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
526%dir %{_sysconfdir}/PackageKit/alpm.d
527%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
528%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
529%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
574f2e60
JB
530# FIXME: dirs should be owned by alpm?
531%dir %{_datadir}/libalpm
532%dir %{_datadir}/libalpm/hooks
533%{_datadir}/libalpm/hooks/90-packagekit-refresh.hook
0d5f415c
ER
534%endif
535
04e18045
JB
536%if %{with apt}
537%files backend-aptcc
538%defattr(644,root,root,755)
539%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
540%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
541%dir %{_datadir}/PackageKit/helpers/aptcc
542%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
543%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
544%{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
545%endif
546
49ea0764
JB
547%if %{with dnf}
548%files backend-dnf
549%defattr(644,root,root,755)
550%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
551%endif
552
04e18045
JB
553%if %{with entropy}
554%files backend-entropy
555%defattr(644,root,root,755)
556%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
557%dir %{_datadir}/PackageKit/helpers/entropy
558%attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
559%endif
560
49ea0764
JB
561%if %{with nix}
562%files backend-nix
ee375c30 563%defattr(644,root,root,755)
49ea0764 564%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
04e18045
JB
565%endif
566
d06070b1
JB
567%if %{with poldek}
568%files backend-poldek
569%defattr(644,root,root,755)
570%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
571%endif
572
04e18045
JB
573%if %{with portage}
574%files backend-portage
575%defattr(644,root,root,755)
576%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
577%dir %{_datadir}/PackageKit/helpers/portage
578%attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
579%endif
580
49ea0764
JB
581%if %{with slack}
582%files backend-slack
583%defattr(644,root,root,755)
584%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
585%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
586%dir /var/cache/PackageKit/metadata
587%ghost /var/cache/PackageKit/metadata/metadata.db
588%endif
589
04e18045
JB
590%if %{with zypp}
591%files backend-zypp
592%defattr(644,root,root,755)
593%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
594%endif
595
d05d9108
MB
596%files gstreamer-plugin
597%defattr(644,root,root,755)
598%doc contrib/gstreamer-plugin/README
aa278a7b 599%attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
02b3d2d3 600%attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
d05d9108 601
dac2b5e1
AF
602%files gtk3-module
603%defattr(644,root,root,755)
aa278a7b 604%doc contrib/gtk-module/{GLASS.txt,README}
dac2b5e1 605%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 606%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 607
a2d83637
MB
608%files -n bash-completion-packagekit
609%defattr(644,root,root,755)
577193a4 610%{bash_compdir}/pkcon
a2d83637 611
02b3d2d3 612%if %{with python}
a2d83637
MB
613%files -n python-packagekit
614%defattr(644,root,root,755)
615%dir %{py_sitescriptdir}/packagekit
616%{py_sitescriptdir}/packagekit/*.py[co]
02b3d2d3 617%endif
This page took 0.238059 seconds and 4 git commands to generate.