]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
up to 1.22.1
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
f2c99d8a 3%bcond_without alsa # ALSA backend
b5f2479e 4%bcond_without jack # JACK backend
4899bbd7 5%bcond_without pipewire # PipeWire backend
f2c99d8a
JB
6%bcond_without portaudio # PortAudio backend
7%bcond_without pulseaudio # PulseAudio backend
4899bbd7 8%bcond_without rtkit # RTKit support
bd9b58be 9%bcond_with sdl # SDL2 backend
bd9b58be 10%bcond_with sse2 # force use of SSE2 instructions (x86)
f2c99d8a 11%bcond_without gui # alsoft-config GUI
99cf5ae3 12%bcond_with qt4 # Qt 4 instead of Qt 5 for GUI
73ba13c5 13
b90768b3 14%ifarch pentium4 x32 %{x8664}
bd9b58be
JB
15%define with_sse2 1
16%endif
d451b59a 17Summary: Open Audio Library
8be14136 18Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 19Name: OpenAL
e1ae1dac
JP
20Version: 1.22.1
21Release: 1
65437b48 22License: LGPL v2+
68071dbf 23Group: Libraries
73ba13c5 24Source0: https://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
e1ae1dac
JP
25# Source0-md5: fc745c9cd8b12e4f1702ca3c2ddfe813
26Patch0: %{name}-nosse.patch
827050d4 27URL: http://www.openal.org/
bd9b58be 28%{?with_sdl:BuildRequires: SDL2-devel >= 2}
e62907a5 29%{?with_alsa:BuildRequires: alsa-lib-devel}
99cf5ae3 30BuildRequires: cmake >= 3.0.2
4899bbd7 31%{?with_rtkit:BuildRequires: dbus-devel}
b5f2479e 32%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
2b67cb40 33BuildRequires: libmysofa-devel
94a1f148 34BuildRequires: libstdc++-devel >= 6:5
e1ae1dac 35%{?with_pipewire:BuildRequires: pipewire-devel >= 0.3.23}
89d1fa49 36BuildRequires: pkgconfig
7e80d8dd 37%{?with_portaudio:BuildRequires: portaudio-devel}
f953b352 38%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
4899bbd7 39BuildRequires: rpmbuild(macros) >= 1.742
f2c99d8a 40%if %{with gui}
99cf5ae3 41%if %{with qt4}
f2c99d8a
JB
42BuildRequires: QtCore-devel >= 4.8.0
43BuildRequires: QtGui-devel >= 4.8.0
44BuildRequires: qt4-build >= 4.8.0
99cf5ae3
JB
45%else
46BuildRequires: Qt5Core-devel >= 5
47BuildRequires: Qt5Gui-devel >= 5
48BuildRequires: Qt5Widgets-devel >= 5
49BuildRequires: qt5-build >= 5
50%endif
f2c99d8a 51%endif
b90768b3 52%{?with_sse2:Requires: cpuinfo(sse2)}
6a3db3d8 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
6a3db3d8 55%description
56OpenAL, the Open Audio Library, is a joint effort to create an open,
57vendor-neutral, cross-platform API for interactive, primarily
58spatialized audio. OpenAL's primary audience are application
59developers and desktop users that rely on portable standards like
60OpenGL, for games and other multimedia applications. OpenAL is already
61supported by a number of hardware vendors and developers.
62
a4959810
JR
63%description -l pl.UTF-8
64OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
65stworzenia otwartego, niezależnego od producentów, międzyplatformowego
66interfejsu projektowania aplikacji w części obsługi dźwięku.
67Biblioteka adresowana jest do twórców aplikacji i użytkowników,
68którzy wybierają przenośne standardy, jak OpenGL, w grach i
69aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
70dostarczycieli sprzętu i programistów.
d451b59a 71
6a3db3d8 72%package devel
d451b59a 73Summary: Headers for OpenAL
8be14136 74Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 75Group: Development/Libraries
e62907a5 76Requires: %{name} = %{version}-%{release}
6a3db3d8 77
78%description devel
d451b59a 79Header files for OpenAL-based programs.
6a3db3d8 80
a4959810
JR
81%description devel -l pl.UTF-8
82Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 83OpenAL.
84
f2c99d8a
JB
85%package gui
86Summary: OpenAL configuration GUI
87Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
88Group: X11/Applications/Sound
89Requires: %{name} = %{version}-%{release}
a517dbfd 90%if %{with qt4}
f2c99d8a
JB
91Requires: QtCore >= 4.8.0
92Requires: QtGui >= 4.8.0
a517dbfd
JP
93%else
94Requires: Qt5Core >= 5
95Requires: Qt5Gui >= 5
96Requires: Qt5Widgets >= 5
97%endif
f2c99d8a
JB
98
99%description gui
100OpenAL configuration GUI.
101
102%description gui -l pl.UTF-8
103Graficzny interfejs do konfiguracji biblioteki OpenAL.
104
6a3db3d8 105%prep
7e80d8dd 106%setup -q -n openal-soft-%{version}
60781cc7 107%patch0 -p1
68071dbf 108
6a3db3d8 109%build
99cf5ae3
JB
110cd build
111%cmake .. \
b5f2479e
JB
112 %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
113 %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
4899bbd7 114 %{cmake_on_off pipewire ALSOFT_BACKEND_PIPEWIRE} \
b5f2479e 115 %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
99cf5ae3 116 %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
4899bbd7 117 %{cmake_on_off rtkit ALSOFT_RTKIT} \
bd9b58be 118 %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
b90768b3 119 %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
99cf5ae3
JB
120 -DALSOFT_EXAMPLES=OFF \
121 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
122 %{?with_qt4:-DALSOFT_NO_QT5=ON} \
65437b48 123
7e80d8dd 124%{__make}
6a3db3d8 125
126%install
127rm -rf $RPM_BUILD_ROOT
6ce9e958 128install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
d451b59a 129
99cf5ae3 130%{__make} -C build install \
68071dbf 131 DESTDIR=$RPM_BUILD_ROOT
d451b59a 132
c06f4ed0 133install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
6ce9e958 134
6a3db3d8 135%clean
136rm -rf $RPM_BUILD_ROOT
137
404a1bc6
JB
138%post -p /sbin/ldconfig
139%postun -p /sbin/ldconfig
140
6a3db3d8 141%files
3f81b215 142%defattr(644,root,root,755)
6ce9e958 143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
996f154d 144%attr(755,root,root) %{_bindir}/makemhr
65437b48 145%attr(755,root,root) %{_bindir}/openal-info
a26f1dac 146%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
65437b48 147%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
f2c99d8a 148%{_datadir}/openal
6a3db3d8 149
150%files devel
151%defattr(644,root,root,755)
a26f1dac 152%attr(755,root,root) %{_libdir}/libopenal.so
68071dbf 153%{_includedir}/AL
a26f1dac 154%{_pkgconfigdir}/openal.pc
99cf5ae3 155%{_libdir}/cmake/OpenAL
f2c99d8a
JB
156
157%if %{with gui}
158%files gui
159%defattr(644,root,root,755)
160%attr(755,root,root) %{_bindir}/alsoft-config
161%endif
This page took 0.125705 seconds and 4 git commands to generate.