]> git.pld-linux.org Git - packages/LeakTracer.git/blame - LeakTracer.spec
- BR: libstdc++-devel
[packages/LeakTracer.git] / LeakTracer.spec
CommitLineData
96e48a11
PS
1Summary: A tool for trace and analyze memory leaks in C++ programs
2Name: LeakTracer
3Version: 2.3
4Release: 1
5License: Public Domain
6Group: Applications
e23bdcbe 7Source0: http://www.andreasen.org/LeakTracer/LeakTracer.tar.gz
96e48a11
PS
8# Source0-md5: e1cf9d03c12a45d39f253e558d231438
9Patch0: %{name}-Makefile.patch
10URL: http://www.andreasen.org/LeakTracer/
e23bdcbe 11BuildRequires: libstdc++-devel
96e48a11
PS
12BuildRequires: sed >= 4.0
13Requires: gdb
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17LeakTracer is a small tool for checking a C++ program for memory
18leaks. To use LeakTracer, run your program using the provided
19LeakCheck script. It uses the LD_PRELOAD feature to "overlay" some
20functions on top of your functions (no recompile needed). leak-anlyze
21uses gdb to print out the exact line where the memory was allocated
22and not freed - this of course means you have to free all dynamically
23allocated data. LeakTracer also overrides the global operator new and
24operator delete - this will give problems if you override them as
25well. LeakTracer traces only new/new[] and delete calls - it does not
26look at malloc/free/realloc.
27
28%prep
29%setup -q -n %{name}
30%patch0 -p1
31
32%build
33sed -i "s:SHLIB=.*:SHLIB=%{_libdir}/LeakTracer.so:" LeakCheck
34
35%{__make} \
36 CXX="%{__cxx}" \
37 CXXFLAGS="%{rpmcflags}"
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}}
42
43install leak-analyze $RPM_BUILD_ROOT%{_bindir}
44install LeakCheck $RPM_BUILD_ROOT%{_bindir}
45install LeakTracer.so $RPM_BUILD_ROOT%{_libdir}
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%post -p /sbin/ldconfig
51%postun -p /sbin/ldconfig
52
53%files
54%defattr(644,root,root,755)
55%doc README
56%attr(755,root,root) %{_bindir}/*
57%attr(755,root,root) %{_libdir}/*.so
This page took 0.094012 seconds and 4 git commands to generate.