]> git.pld-linux.org Git - packages/brltty.git/blobdiff - brltty.spec
- files cleanup, strict internal deps, BR: automake
[packages/brltty.git] / brltty.spec
index f2f1aa04813b0b06a63da14eef898c4f20a40f05..fbba2ad68ab93cad6860b923169402212c4639c6 100644 (file)
@@ -1,23 +1,23 @@
 Summary:       Braille display driver for Linux/Unix
 Summary(pl):   Sterownik do wy¶wietlaczy Braille'a
 Name:          brltty
-Version:       3.3.1 
-Release:       1
+Version:       3.7.2
+Release:       3
 Group:         Daemons
 License:       GPL
 URL:           http://mielke.cc/brltty/
 Source0:       http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
-# Source0-md5  b322afdc69c5661d97931f12497ca371
+# Source0-md5: 0ae3da8252783a4d20e1ed4e55cede5b
 BuildRequires: autoconf >= 2.53
+BuildRequires: automake
 BuildRequires: bison
-BuildRequires: glibc-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BRLTTY is a background process (daemon) which provides access to the
 Linux/Unix console (when in text mode) for a blind person using a
-refreshable Braille display.  It drives the Braille display, and
-provides complete screen review functionality.  Some speech capability
+refreshable Braille display. It drives the Braille display, and
+provides complete screen review functionality. Some speech capability
 has also been incorporated.
 
 %description -l pl
@@ -31,7 +31,7 @@ mowy.
 %package -n brlapi
 Summary:       Application Programming Interface for BRLTTY
 Summary(pl):   API do BRLTTY
-Group: Applications/System
+Group:         Applications/System
 
 %description -n brlapi
 This package provides the run-time support for the Application
@@ -50,20 +50,20 @@ wy
 %package -n brlapi-devel
 Summary:       Headers and documentation for BrlAPI
 Summary(pl):   Pliki nag³ówkowe i dokumentacja do BrlAPI
-Group: Development/Libraries
-Requires:      brlapi = %{version}
+Group:         Development/Libraries
+Requires:      brlapi = %{version}-%{release}
 
 %description -n brlapi-devel
 This package provides the header files, shared object linker
 reference, and reference documentation for BrlAPI (the Application
-Programming Interface to BRLTTY).  It enables the implementation of
+Programming Interface to BRLTTY). It enables the implementation of
 applications which take direct advantage of a refreshable Braille
 display in order to present information in ways which are more
 appropriate for blind users and/or to provide user interfaces which
 are more specifically atuned to their needs.
 
-Install this package if you're developing or maintaining an application
-which directly accesses a refreshable Braille display.
+Install this package if you're developing or maintaining an
+application which directly accesses a refreshable Braille display.
 
 %description -n brlapi-devel -l pl
 Ten pakiet zawiera pliki nag³ówkowe oraz dokumentacjê do BrlAPI (API
@@ -72,25 +72,29 @@ korzystaj
 bardziej przystosowany dla osób niewidomych.
 
 Zainstaluj ten pakiet, je¶li tworzysz lub nadzorujesz aplikacjê
-korzystaj±c± bezpo¶rednio z od¶wierzalnych wy¶wietlaczy Braille'a.
+korzystaj±c± bezpo¶rednio z od¶wie¿alnych wy¶wietlaczy Braille'a.
 
 %package -n brlapi-static
 Summary:       Static BrlAPI library
 Summary(pl):   Statyczna biblioteka BrlAPI
-Group: Development/Libraries
-Requires:      brlapi-devel = %{version}
+Group:         Development/Libraries
+Requires:      brlapi-devel = %{version}-%{release}
 
 %description -n brlapi-static
 This is package with static BrlAPI library.
 
 %description -n brlapi-static -l pl
-Ten pakiet zawier± statyczn± wersjê biblioteki BrlAPI.
+Ten pakiet zawiera statyczn± wersjê biblioteki BrlAPI.
 
 %prep
 %setup -q
 
 %build
-%configure --with-install-root="$RPM_BUILD_ROOT" \
+%{__aclocal}
+%{__autoconf}
+cp -f /usr/share/automake/config.sub acdir
+%configure \
+       --with-install-root="$RPM_BUILD_ROOT" \
        --disable-tainted-components \
        --enable-api
 %{__make}
@@ -106,7 +110,7 @@ done
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} install
-install -m 644 Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
+install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -120,7 +124,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # There's no explicit way to tell if a configuration file has been installed
 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
-# erasing the .rpmnew file now so that we can see if it gets created later. 
+# erasing the .rpmnew file now so that we can see if it gets created later.
 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
 
 %post
@@ -303,7 +307,7 @@ translateDevice_devfs()
 }
 translateDevice_old()
 {
-   major="${device%%/*}" 
+   major="${device%%/*}"
    if [ "${major}" != "${device}" ]
    then
       minor="${device#*/}"
@@ -409,18 +413,17 @@ exit 0
 
 %files
 %defattr(644,root,root,755)
+%doc Documents/{Manual.sgml,Manual.txt,Manual-HTML,ChangeLog,TODO} doc/*
 %attr(755,root,root) %{_bindir}/brltty
 %attr(755,root,root) %{_bindir}/brltty-*
+%attr(755,root,root) %{_bindir}/xbrlapi
 %dir %{_libdir}/brltty
 %dir %{_sysconfdir}/brltty
 %attr(755,root,root) %{_libdir}/brltty/*.so
-%{_libdir}/brltty
+%dir %{_libdir}/brltty
 %{_sysconfdir}/brltty
-%doc %{_mandir}/man1/*
-%doc Documents/Manual.sgml Documents/Manual.txt Documents/Manual-HTML
-%doc Documents/ChangeLog Documents/TODO
-%doc doc/*
-%config(noreplace) %verify(not size md5 mtime) %{_sysconfdir}/brltty.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
+%{_mandir}/man1/*
 
 %files -n brlapi
 %defattr(644,root,root,755)
@@ -429,11 +432,10 @@ exit 0
 
 %files -n brlapi-devel
 %defattr(644,root,root,755)
-%{_libdir}/libbrlapi.so
+%doc Documents/BrlAPIref-HTML Documents/README.Gnopernicus
+%attr(755,root,root) %{_libdir}/libbrlapi.so
 %{_includedir}/brltty
-%doc %{_mandir}/man3/*
-%doc Documents/BrlAPIref-HTML
-%doc Documents/README.Gnopernicus
+%{_mandir}/man3/*
 
 %files -n brlapi-static
 %defattr(644,root,root,755)
This page took 0.114771 seconds and 4 git commands to generate.