]> git.pld-linux.org Git - packages/bluez-utils.git/blobdiff - bluez-utils.spec
- chkconfig must be run in preun, rel 2; STBR
[packages/bluez-utils.git] / bluez-utils.spec
index 9f42f1b02997425580b1a97e31dd02b6aa84b832..9fa29b8f198000e3bb050fa122a64c382eb31cac 100644 (file)
@@ -1,23 +1,40 @@
+# TODO:
+# - check init script, add support for rfcomm bind on startup
 Summary:       Bluetooth utilities
 Summary(pl):   Narzêdzia Bluetooth
 Name:          bluez-utils
-Version:       2.3
-Release:       1
+Version:       2.25
+Release:       2
+Epoch:         0
 License:       GPL v2
 Group:         Applications/System
 Source0:       http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
+# Source0-md5: ae3729ab5592be06ed01b973d4b3e9fe
+Source1:       %{name}.init
+Source2:       %{name}.sysconfig
 Patch0:                %{name}-etc_dir.patch
 URL:           http://bluez.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: bluez-libs-devel >= 2.0
+BuildRequires: bison
+BuildRequires: bluez-libs-devel >= 2.25
+BuildRequires: dbus-devel >= 0.33
 BuildRequires: libtool
-Requires(post,preun):  /sbin/chkconfig
+BuildRequires: libusb-devel
+# alsa-lib-devel, openobex-devel - currently only checked for, not used
+Requires:      bluez-libs >= 2.21
+Requires:      rc-scripts
+Obsoletes:     bluez-pan
+Obsoletes:     bluez-sdp
+Conflicts:     bluez-bluefw
 ExcludeArch:   s390 s390x
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# currently lib, not %{_lib} (see cups.spec)
+%define                cupsdir         /usr/lib/cups/backend
+
 %description
-Bluetooth utilities (bluez-utils):
+Bluetooth utilities:
  - hcitool
  - hciattach
  - hciconfig
@@ -29,7 +46,7 @@ Bluetooth utilities (bluez-utils):
 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
 
 %description -l pl
-Narzêdzia Bluetooth (bluez-utils):
+Narzêdzia Bluetooth:
  - hcitool
  - hciattach
  - hciconfig
@@ -37,7 +54,33 @@ Narz
  - l2ping
  - skrypty startowe (PLD)
  - pliki konfiguracji PCMCIA
+
+%package -n cups-backend-bluetooth
+Summary:       Bluetooth backend for CUPS
+Summary(pl):   Backend Bluetooth dla CUPS-a
+Group:         Applications/Printing
+Requires:      bluez-libs >= 2.21
+Requires:      cups
+
+%description -n cups-backend-bluetooth
+Bluetooth backend for CUPS.
+
+%description -n cups-backend-bluetooth -l pl
+Backend Bluetooth dla CUPS-a.
+
+%package init
+Summary:       Init script for Bluetooth subsystem
+Summary(pl):   Skrypt init dla podsystemu Bluetooth
+Group:         Applications/System
+Requires(post,preun):  /sbin/chkconfig
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description init
+Init script for Bluetooth subsystem.
+
+%description init -l pl
+Skrypt init dla podsystemu Bluetooth.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -45,27 +88,31 @@ Narz
 %build
 %{__libtoolize}
 %{__aclocal}
-%{__automake}
 %{__autoconf}
+%{__automake}
 %configure \
-       --enable-pcmcia
-%{__make}
+       --enable-bcm203x \
+       --enable-cups \
+       --enable-pcmcia \
+       --with-cups=/usr
+%{__make} \
+       cupsdir=%{cupsdir}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       confdir=%{_sysconfdir}/bluetooth \
-       mandir=%{_mandir}
+       cupsdir=%{cupsdir}
 
-%{__make} -C scripts \
-       DESTDIR=$RPM_BUILD_ROOT \
-       redhat
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
+%post init
 /sbin/chkconfig --add bluetooth
 if [ -f /var/lock/subsys/bluetooth ]; then
        /etc/rc.d/init.d/bluetooth restart >&2
@@ -73,7 +120,7 @@ else
        echo "Run \"/etc/rc.d/init.d/bluetooth\" to start bluetooth." >&2
 fi
 
-%postun
+%preun init
 if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/bluetooth ]; then
                /etc/rc.d/init.d/bluetooth stop 1>&2
@@ -84,11 +131,21 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
-%attr(754,root,root) /etc/rc.d/init.d/bluetooth
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/*
 %{_mandir}/man*/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
 %dir %{_sysconfdir}/bluetooth
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/bluetooth/*
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pcmcia/bluetooth.conf
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pcmcia/bluetooth
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/*
+%attr(755,root,root) %{_sysconfdir}/hotplug/usb/bcm203x
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hotplug/usb/bcm203x.usermap
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth
+
+%files -n cups-backend-bluetooth
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
+
+%files init
+%defattr(644,root,root,755)
+%attr(754,root,root) /etc/rc.d/init.d/bluetooth
This page took 0.034563 seconds and 4 git commands to generate.