]> git.pld-linux.org Git - packages/binutils.git/blobdiff - binutils.spec
- release 2
[packages/binutils.git] / binutils.spec
index f6d49b92939c8adcc3e1289b805f56ceb7b48a0e..3ffd519731df996af5da873cbbb59a17b21d1deb 100644 (file)
@@ -7,7 +7,7 @@
 %bcond_with    pax             # without PaX flags (for upstream bugreports)
 %bcond_without gold            # don't build gold (no C++ dependencies)
 %bcond_without default_bfd     # default ld.bfd instead of gold
-%bcond_with    gasp            # gasp
+%bcond_without debuginfod      # debuginfo lokups with debuginfod
 %bcond_without gprofng         # gprofng
 %bcond_without jansson         # Package Metadata embedding support
 %bcond_without msgpack         # msgpack support
@@ -16,9 +16,6 @@
 %ifnarch %{ix86} %{x8664} x32 aarch64 %{arm}
 %undefine      with_gold
 %endif
-%ifarch %{arm}
-%undefine      with_gasp
-%endif
 %ifnarch %{ix86} %{x8664} aarch64
 %undefine      with_gprofng    1
 %endif
@@ -33,16 +30,15 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.39
-Release:       1
+Version:       2.40
+Release:       2
 Epoch:         4
 License:       GPL v3+
 Group:         Development/Tools
 Source0:       https://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
-# Source0-md5: 061a1460a09cc71e51886c008be55d44
+# Source0-md5: be3411283c27eb0984104a2fda12e102
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
-Patch0:                %{name}-gasp.patch
 Patch1:                %{name}-info.patch
 Patch2:                %{name}-libtool-relink.patch
 Patch3:                %{name}-pt_pax_flags.patch
@@ -55,6 +51,7 @@ URL:          http://www.sourceware.org/binutils/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake >= 1:1.11
 BuildRequires: bison
+%{?with_debuginfod:BuildRequires:      elfutils-debuginfod-devel >= 0.179}
 BuildRequires: flex
 BuildRequires: gettext-tools
 %{?with_jansson:BuildRequires: jansson-devel}
@@ -69,13 +66,15 @@ BuildRequires:      rpmbuild(macros) >= 1.527
 BuildRequires: sparc32
 %endif
 BuildRequires: tar >= 1:1.22
-BuildRequires: texinfo >= 4.2
+BuildRequires: texinfo >= 6.3
 BuildRequires: zlib-devel
 %{?with_tests:BuildRequires:   zlib-static}
+BuildRequires: zstd-devel
+%{?with_debuginfod:Requires:   elfutils-debuginfod-libs >= 0.179}
 Conflicts:     gcc-c++ < 5:3.3
 Conflicts:     modutils < 2.4.17
 Conflicts:     rpmbuild(macros) < 1.660
-Obsoletes:     binutils-gold
+Obsoletes:     binutils-gold < 3:2.21.51.0.7-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -155,24 +154,8 @@ Static GNU binutils libraries (libbfd, libopcodes).
 %description static -l pl.UTF-8
 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
 
-%package gasp
-Summary:       GASP - old preprocessor for assembly programs
-Summary(pl.UTF-8):     GASP - stary preprocesor dla programów w asemblerze
-Group:         Development/Tools
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description gasp
-GASP - old preprocessor for assembly programs. It's officially
-obsoleted, but it's still needed to build some packages.
-
-%description gasp -l pl.UTF-8
-GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
-uznany za przestarzały, ale jest nadal potrzebny do zbudowania
-niektórych pakietów.
-
 %prep
 %setup -q
-%{?with_gasp:%patch0 -p1}
 %patch1 -p1
 %patch2 -p1
 %{?with_pax:%patch3 -p1}
@@ -191,7 +174,7 @@ niektórych pakietów.
 %{__aclocal}
 %{__autoconf}
 
-# non-standard regeneration (needed because of gasp patch)
+# non-standard regeneration
 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
 for dir in gas bfd; do
        cd $dir || exit 1
@@ -201,6 +184,12 @@ for dir in gas bfd; do
        %{__autoconf}
        cd ..
 done
+cd libctf
+%{__aclocal} -I.. -I../config -I../bfd
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd ..
 
 # More targets
 TARGETS=
@@ -252,12 +241,13 @@ sparc32 \
        %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
        %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
        --with-tooldir=%{_prefix} \
-       --with-zlib \
+       --with-system-zlib \
 %if %{with gold}
        --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
 %endif
-       %{__enable_disable msgpack} \
-       %{__enable_disable jansson}
+       %{__with_without msgpack} \
+       %{__enable_disable jansson} \
+       %{__with_without debuginfod}
 
 %{__make}
 
@@ -322,12 +312,6 @@ rm -rf $RPM_BUILD_ROOT
 %postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post  gasp -p /sbin/postshell
--/usr/sbin/fix-info-dir -c %{_infodir}
-
-%postun        gasp -p /sbin/postshell
--/usr/sbin/fix-info-dir -c %{_infodir}
-
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README
@@ -378,6 +362,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_infodir}/gprof.info*
 %{?with_gprofng:%{_infodir}/gprofng.info*}
 %{_infodir}/ld.info*
+%{_infodir}/sframe-spec.info*
 %{_mandir}/man1/addr2line.1*
 %{_mandir}/man1/ar.1*
 %{_mandir}/man1/as.1*
@@ -418,6 +403,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libctf-nobfd.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libctf-nobfd.so.0
 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
+%attr(755,root,root) %{_libdir}/libsframe.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsframe.so.0
 %dir %{_libdir}/bfd-plugins
 %attr(755,root,root) %{_libdir}/bfd-plugins/libdep.so
 
@@ -427,12 +414,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libctf.so
 %attr(755,root,root) %{_libdir}/libctf-nobfd.so
 %attr(755,root,root) %{_libdir}/libopcodes.so
+%attr(755,root,root) %{_libdir}/libsframe.so
 %{?with_gprofng:%attr(755,root,root) %{_libdir}/gprofng/libgprofng.so}
 %{_libdir}/libbfd.la
 %{_libdir}/libctf.la
 %{_libdir}/libctf-nobfd.la
 %{_libdir}/libopcodes.la
 %{_libdir}/libiberty.a
+%{_libdir}/libsframe.la
 %{_includedir}/ansidecl.h
 %{_includedir}/bfd.h
 %{_includedir}/bfdlink.h
@@ -441,6 +430,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/diagnostics.h
 %{_includedir}/dis-asm.h
 %{_includedir}/plugin-api.h
+%{_includedir}/sframe-api.h
+%{_includedir}/sframe.h
 %{_includedir}/symcat.h
 %{_includedir}/libiberty
 %if %{with gprofng}
@@ -456,10 +447,4 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libctf.a
 %{_libdir}/libctf-nobfd.a
 %{_libdir}/libopcodes.a
-
-%if %{with gasp}
-%files gasp
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/gasp
-%{_infodir}/gasp.info*
-%endif
+%{_libdir}/libsframe.a
This page took 0.04995 seconds and 4 git commands to generate.