]> git.pld-linux.org Git - packages/apache-mod_whatkilledus.git/blobdiff - apache-mod_whatkilledus.spec
- HTTP group
[packages/apache-mod_whatkilledus.git] / apache-mod_whatkilledus.spec
index db90510ea8c16140c7c15bc8dc0d73b7847e2590..5896ad8dae041f6db4f3d2939334a0427fa10f3c 100644 (file)
@@ -1,11 +1,12 @@
 %define                mod_name        whatkilledus
 %define        apxs            /usr/sbin/apxs
-Summary:       Apache module: logs request when child process crashes
+Summary:       Apache module: knows what a thread was handling in case the thread segfaults
+Summary(pl.UTF-8):     Moduł apache wiedzący, co obsługiwał wątek w przypadku naruszenia ochrony pamięci
 Name:          apache-mod_%{mod_name}
-Version:       0.1
-Release:       0.20040323.1
+Version:       1.0
+Release:       1.20040323.2
 License:       Apache v2.0
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Source0:       http://people.apache.org/~trawick/mod_whatkilledus.c
 # Source0-md5: e59c5d56e294a31e5b158ad5e4553001
 Source1:       http://mirrors.ludost.net/gentoo-portage/www-apache/mod_whatkilledus/files/gen_test_char.c
@@ -16,33 +17,35 @@ BuildRequires:      rpmbuild(macros) >= 1.268
 Requires:      apache(modules-api) = %apache_modules_api
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
-%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
-%define                _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
 
 %description
-mod_whatkilledus is an experimental module for Apache httpd 2.x which
-tracks the current request and logs a report of the active request
-when a child process crashes. You should verify that it works
-reasonably on your system before putting it in production.
+Keeps a little bit of state on each active connection, which allows it
+to know what a thread was handling in case the thread segfaults.
+
+%description -l pl.UTF-8
+Moduł przechowujący wybrane informacje o stanie każdego aktywnego
+połączenia, pozwalające dowiedzieć się, co obsługiwał wątek w
+sytuacji, kiedy spowodował naruszenie ochrony pamięci.
 
 %prep
 %setup -q -c -T
 install %{SOURCE0} .
 
 %build
-%{__cc} `%{_bindir}/apr-1-config --includes --cppflags` %{SOURCE1} -o gen_test_char
+%{__cc} $(%{_bindir}/apr-1-config --includes --cppflags) %{SOURCE1} -o gen_test_char
 ./gen_test_char > test_char.h
 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf,/var/log/httpd}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},/var/log/httpd}
 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
 touch $RPM_BUILD_ROOT/var/log/httpd/whatkilledus_log
 
-cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf << 'EOF'
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/68_mod_%{mod_name}.conf << 'EOF'
 LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
 EnableExceptionHook On
 WhatKilledUsLog /var/log/httpd/whatkilledus_log
@@ -62,7 +65,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*.so
 # append by webserver
 %attr(620,root,http) %ghost /var/log/httpd/whatkilledus_log
This page took 0.033524 seconds and 4 git commands to generate.