]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blobdiff - apache-mod_pagespeed.spec
Merge branch 'dev-1.8': up to 1.8.31.6
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
index 65f02b3d97b5d5ec30d99495695d51def3e9c970..602668edaca18bac2a3ae7918489a416f68effcc 100644 (file)
@@ -7,41 +7,75 @@
 # - http://code.google.com/p/modpagespeed/wiki/HowToBuild
 # - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
 # TODO
-# - add unit tests running
-# - possible sysdeps (uses release tags)
-#  "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
-#  "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
-#  "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
-#  protobuf_lite
+# - run unit tests
+# third_party libraries:
+# - apr - using system apr package
+# - aprutil - using system apr-util, but from this repo modified apr_memcache2.c
+# - gflags - system package may work
+# - giflib - 4.1.6, no local modifications
+# - google-sparsehash
+# - httpd, httpd24 - using system apache-devel
+# - icu - using system icu
+# - jsoncpp - no local changes
+# - libjpeg_turbo - 1.2.80 with chromium changes (but system lib should be fine)
+# - libpng - no local changes
+# - libwebp - 0.4.0, irrelevant local changes
+# - optipng - 0.7.4, local changes: only the opngreduc component of optipng is included.
+# - protobuf - should be possible to use full protobuf (not lite) to gain same functionality
+# - re2 - should be possible to use system re2
+# - serf - 0.7.2 bunch of google fixes
+# - zlib - 1.2.5, no local changes
+#
+# third_party/chromium/src/base/third_party:
+# - nspr - should be possible to use system lib
+# - dmg_fp
+# - dynamic_annotations
+# - icu - not icu lib, but two files only
+# - valgrind
+#
+# could be possible to use system libs, not packaged in pld:
+# - base64
+# - chromium
+# - chromium_deps
+# - css_parser
+# - domain_registry_provider
+# - instaweb
+# - mod_spdy
+# - modp_b64
+# - rdestl
 
 %define                mod_name        pagespeed
 %define                apxs            %{_sbindir}/apxs
 Summary:       Apache module for rewriting web pages to reduce latency and bandwidth
 Name:          apache-mod_%{mod_name}
-Version:       1.5.27.2
-Release:       3
+# beta: 1.9.32.x-beta
+# stable: 1.8.31.x
+Version:       1.8.31.6
+Release:       1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       modpagespeed-%{version}.tar.xz
-# Source0-md5: fa8d6a80fc4ca7f929910fa4eeb4a941
+# Source0-md5: ab144d1d524ce60db44c4dfd6f3f8ef3
 Source1:       get-source.sh
 Source2:       gclient.conf
 Patch0:                system-libs.patch
-Patch1:                gcc-headers.patch
 Patch2:                bug-632.patch
-Patch3:                opencv.patch
 Patch4:                no-dev-stdout.patch
+Patch5:                apache24-config.patch
 URL:           https://developers.google.com/speed/pagespeed/module
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.2
+BuildRequires: bash
 BuildRequires: glib2-devel
 BuildRequires: gperf
+BuildRequires: libicu-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
 BuildRequires: opencv-devel >= 2.3.1
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
+BuildRequires: yasm
 # This version of gyp is new enough that it knows to use make for Linux 3.x
 # and FreeBSD, but old enough that 'type': 'settings' works and
 # LINKER_SUPPORTS_ICF hasn't been removed yet.
@@ -63,6 +97,9 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                htdocsdir       %(%{apxs} -q htdocsdir 2>/dev/null)
 %define                cachedir        %(%{apxs} -q proxycachedir 2>/dev/null)/mod_%{mod_name}
 
+# disable strip examples, http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2015-January/024223.html
+%define                _noautostrip    .*%{_examplesdir}/.*
+
 %description
 mod_pagespeed automates the application of those rules in an Apache
 server. HTML, CSS, JavaScript, and images are changed dynamically
@@ -73,10 +110,15 @@ site is maintained.
 %prep
 %setup -q -n modpagespeed-%{version}
 %patch0 -p2
-%patch1 -p2
 %patch2 -p1
-%patch3 -p3
 %patch4 -p1
+%patch5 -p1
+
+rm -r third_party/icu/source
+rm -r third_party/icu/genfiles
+install -d third_party/icu/source/{common,i18n}
+ln -s %{_includedir}/unicode third_party/icu/source/i18n/unicode
+ln -s %{_includedir}/unicode third_party/icu/source/common/unicode
 
 %build
 # re-gen makefiles
@@ -88,9 +130,12 @@ CXX="%{__cxx}" \
        build/all.gyp \
        -Duse_openssl=1 \
        -Duse_system_apache_dev=1 \
+       -Duse_system_icu=1 \
        -Duse_system_libjpeg=1 \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
+       -Duse_system_openssl=1 \
+       -Duse_system_yasm=1 \
        -Duse_system_zlib=1 \
        -Dsystem_include_path_apr=%{_includedir}/apr \
        -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
This page took 0.076107 seconds and 4 git commands to generate.