]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blobdiff - apache-mod_auth_any.spec
fixed a small typo
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
index b75931a9e33a769efeb7da8478347147bb95243c..3b6b4f389daec9a655b3bdad8bddd0c61eb5290a 100644 (file)
@@ -1,36 +1,79 @@
 %define                mod_name        auth_any
-Summary:       This is the any authentication module for Apache
-Summary(pl):   To jest modu³ dowolnej autentykacji dla Apache
+%define        apxs            /usr/sbin/apxs
+Summary:       Basic authentication for the Apache Web server using arbitrary shell commands
+Summary(cs):   Základní autentizace pro WWW server Apache pomocí shellových pøíkazù
+Summary(da):   En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
+Summary(de):   Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
+Summary(fr):   Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
+Summary(it):   Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
+Summary(no):   En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
+Summary(pl):   Podstawowy modu³ autentykacji dla Apache, u¿ywaj±cy poleceñ pow³oki
+Summary(pt):   Um módulo de autenticação de LDAP para o servidor Web Apache
+Summary(sl):   Osnovna avtentikacija za spletni stre¾nik Apache, z uporabo poljubnih lupinskih ukazov
+Summary(sv):   Grundläggande autentisering för webbservern Apache med valfria skalkommandon
 Name:          apache-mod_%{mod_name}
-Version:       1.2
-Release:       1
-License:       GPL
+Version:       1.2.1
+Release:       3
+License:       BSD
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
 Source0:       ftp://ftp.itlab.musc.edu/pub/toolbox/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
 URL:           http://www.itlab.musc.edu/~nafees/mod_%{mod_name}.html
-Prereq:                /usr/sbin/apxs
+Prereq:                %{_sbindir}/apxs
 Requires:      apache(EAPI)
-BuildRequires: /usr/sbin/apxs
+BuildRequires: %{apxs}
 BuildRequires: apache(EAPI)-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 This module allows you to use any command line program (such as
 webNIS) to authenticate a user.
 
+%description -l cs
+Balíèek mod_auth_any slou¾í pro omezení pøístupu k dokumentùm, které
+poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
+jakéhokoliv pøíkazu (jeho návratovým kódem).
+
+%description -l de
+Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
+Server bediente Dokumente zu beschränken, indem es den Rückcode eines
+gegebenen arbiträren Befehls prüft.
+
+%description -l es
+Mod_auth_any puede usarse para limitar el acceso a documentos servidos
+desde un servidor web verificando el código de retorno de un comando
+arbitrario especificado.
+
+%description -l fr
+Mod_auth_any peut être utilisé pour limiter l'accès à des documents
+servis par un serveur Web en vérifiant le code de retour d'une
+commande spécifiée arbitraire.
+
+%description -l it
+Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
+serviti da un server Web controllando il codice di ritorno di un dato
+comando arbitrario.
+
+%description -l ja
+Mod_auth_any ¤ÏǤ°Õ¤Ë»ØÄꤵ¤ì¤¿¥³¥Þ¥ó¥É¤ÎÌá¤ê¥³¡¼¥É¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
+¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
+¤¬¤Ç¤­¤Þ¤¹¡£
+
 %description -l pl
 Ten modu³ pozwala na u¿ycie dowolnego programu dzia³aj±cego z linii
 poleceñ (jak np. webNIS) do autentykacji u¿ytkownika.
 
-%prep 
-%setup -q -n mod_%{mod_name}
+%description -l sv
+Mod_auth_any kan användas för att begränsa åtkomsten till dokument
+servade av en webbserver genom att kontrollera returkoden från ett
+godtyckligt angivet kommando.
+
+%prep
+%setup -q -n mod_%{mod_name}-%{version}
 
 %build
-/usr/sbin/apxs -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
+%{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -44,14 +87,14 @@ gzip -9nf docs/*
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
This page took 0.08961 seconds and 4 git commands to generate.