]> git.pld-linux.org Git - packages/alsa-lib.git/blobdiff - alsa-lib.spec
fix build with python 3.10
[packages/alsa-lib.git] / alsa-lib.spec
index bc9d7995ae5cf3217edf3e36082da773cb1c5157..5680a6f649040e4dfffe75fede824f049c572d6a 100644 (file)
@@ -13,16 +13,24 @@ Summary(pt_BR.UTF-8):       Biblioteca para o ALSA (Advanced Linux Sound Architecture)
 Summary(ru.UTF-8):     Библиотека API для работы с драйвером ALSA
 Summary(uk.UTF-8):     Бібліотека API для роботи з драйвером ALSA
 Name:          alsa-lib
-Version:       1.1.9
-Release:       2
+Version:       1.2.6.1
+# alsa-*-conf tarballs are not released for each patch version
+%define        topology_confver        1.2.5.1
+%define        ucm_confver             1.2.6.3
+Release:       4
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.bz2
-# Source0-md5: e6d429dbdcfaa0f034d907fa6dc3735e
+# Source0-md5: 039aae4a55e4a33f4c39b274fcc1dc5e
 Source1:       %{name}-modprobe.conf
 Source2:       %{name}-asound.conf
 Source3:       smixer.conf
-URL:           http://www.alsa-project.org/
+Source4:       ftp://ftp.alsa-project.org/pub/lib/alsa-topology-conf-%{topology_confver}.tar.bz2
+# Source4-md5: 066d6a980e09a2fa44b4cc1d06ecc0ea
+Source5:       ftp://ftp.alsa-project.org/pub/lib/alsa-ucm-conf-%{ucm_confver}.tar.bz2
+# Source5-md5: 8b23fb19430b9e6ef47776de4b55c420
+Patch0:                python3.10.patch
+URL:           https://www.alsa-project.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: doxygen
@@ -37,6 +45,8 @@ BuildRequires:        python3-modules >= 1:3.2
 %endif
 %endif
 %{?with_resmgr:BuildRequires:  resmgr-devel}
+BuildRequires: rpm-build >= 4.6
+BuildRequires: tar >= 1:1.15
 BuildConflicts:        alsa-lib <= 0.4.0
 Obsoletes:     alsa-libs
 Conflicts:     alsa-utils < 1.0.20-3
@@ -171,9 +181,7 @@ Bibliotecas estáticas para desenvolvimento com a alsa-lib
 Summary:       ALSA Library API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki ALSA
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 API and internal documentation for ALSA Library.
@@ -195,6 +203,7 @@ Moduł wiązania Pythona dla interfejsu miksera architektury ALSA.
 
 %prep
 %setup -q
+%patch0 -p1
 cp -p %{SOURCE3} src/conf
 
 %build
@@ -249,6 +258,9 @@ install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/alsa/conf.d,%{_datadir}/alsa/
 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libasound.so.*.*) \
        $RPM_BUILD_ROOT%{_libdir}/libasound.so
 
+tar xf %{SOURCE4} --strip-components=1 -C $RPM_BUILD_ROOT%{_datadir}/alsa alsa-topology-conf-%{topology_confver}/topology
+tar xf %{SOURCE5} --strip-components=1 -C $RPM_BUILD_ROOT%{_datadir}/alsa alsa-ucm-conf-%{ucm_confver}/ucm alsa-ucm-conf-%{ucm_confver}/ucm2
+
 install -D utils/alsa.m4 $RPM_BUILD_ROOT%{_aclocaldir}/alsa.m4
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/modprobe.d/alsa-base.conf
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/asound.conf
@@ -267,6 +279,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/aserver
 %attr(755,root,root) /%{_lib}/libasound.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libasound.so.2
+%attr(755,root,root) /%{_libdir}/libatopology.so.*.*.*
+%attr(755,root,root) %ghost /%{_libdir}/libatopology.so.2
 %dir %{_libdir}/alsa-lib
 %dir %{_libdir}/alsa-lib/smixer
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-ac97.so
@@ -274,9 +288,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-sbase.so
 %dir %{_datadir}/alsa
 %{_datadir}/alsa/cards
+%{_datadir}/alsa/ctl
 %{_datadir}/alsa/pcm
 %{_datadir}/alsa/topology
 %{_datadir}/alsa/ucm
+%{_datadir}/alsa/ucm2
 %{_datadir}/alsa/alsa.conf
 # directory for "global" config files (not accessed directly, but through symlinks in %{_sysconfdir}/alsa/conf.d)
 %dir %{_datadir}/alsa/alsa.conf.d
@@ -290,12 +306,15 @@ rm -rf $RPM_BUILD_ROOT
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libasound.so
+%attr(755,root,root) %{_libdir}/libatopology.so
 %{_libdir}/libasound.la
+%{_libdir}/libatopology.la
 %{_includedir}/sys/asoundlib.h
 %{_includedir}/alsa
 %{_includedir}/asoundlib.h
 %{_aclocaldir}/alsa.m4
 %{_pkgconfigdir}/alsa.pc
+%{_pkgconfigdir}/alsa-topology.pc
 
 %if %{with static_libs}
 %files static
This page took 0.033676 seconds and 4 git commands to generate.