]> git.pld-linux.org Git - packages/alsa-lib.git/blobdiff - alsa-lib.spec
fix build with python 3.10
[packages/alsa-lib.git] / alsa-lib.spec
index 5c515fdfa3e2c5b3f0877e335ae3c9df2602cafb..5680a6f649040e4dfffe75fede824f049c572d6a 100644 (file)
@@ -3,6 +3,7 @@
 %bcond_without static_libs     # don't build static library
 %bcond_without apidocs         # do not build and package API docs
 %bcond_without python          # smixer-python binding
+%bcond_with    python2         # python 2.x instead of python 3.x for smixer pymodules
 %bcond_with    resmgr          # Resource Manager support
 
 Summary:       Advanced Linux Sound Architecture (ALSA) - Library
@@ -12,24 +13,40 @@ Summary(pt_BR.UTF-8):       Biblioteca para o ALSA (Advanced Linux Sound Architecture)
 Summary(ru.UTF-8):     Библиотека API для работы с драйвером ALSA
 Summary(uk.UTF-8):     Бібліотека API для роботи з драйвером ALSA
 Name:          alsa-lib
-Version:       1.1.0
-Release:       1
+Version:       1.2.6.1
+# alsa-*-conf tarballs are not released for each patch version
+%define        topology_confver        1.2.5.1
+%define        ucm_confver             1.2.6.3
+Release:       4
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.bz2
-# Source0-md5: 69515ca73c3c4a212ef45160dea846c1
+# Source0-md5: 039aae4a55e4a33f4c39b274fcc1dc5e
 Source1:       %{name}-modprobe.conf
 Source2:       %{name}-asound.conf
-URL:           http://www.alsa-project.org/
+Source3:       smixer.conf
+Source4:       ftp://ftp.alsa-project.org/pub/lib/alsa-topology-conf-%{topology_confver}.tar.bz2
+# Source4-md5: 066d6a980e09a2fa44b4cc1d06ecc0ea
+Source5:       ftp://ftp.alsa-project.org/pub/lib/alsa-ucm-conf-%{ucm_confver}.tar.bz2
+# Source5-md5: 8b23fb19430b9e6ef47776de4b55c420
+Patch0:                python3.10.patch
+URL:           https://www.alsa-project.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: doxygen
 BuildRequires: libtool >= 1.4
 %if %{with python}
+%if %{with python2}
 BuildRequires: python-devel >= 1:2.4
-BuildRequires: python-modules
+BuildRequires: python-modules >= 1:2.4
+%else
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-modules >= 1:3.2
+%endif
 %endif
 %{?with_resmgr:BuildRequires:  resmgr-devel}
+BuildRequires: rpm-build >= 4.6
+BuildRequires: tar >= 1:1.15
 BuildConflicts:        alsa-lib <= 0.4.0
 Obsoletes:     alsa-libs
 Conflicts:     alsa-utils < 1.0.20-3
@@ -164,9 +181,7 @@ Bibliotecas estáticas para desenvolvimento com a alsa-lib
 Summary:       ALSA Library API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki ALSA
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 API and internal documentation for ALSA Library.
@@ -188,6 +203,8 @@ Moduł wiązania Pythona dla interfejsu miksera architektury ALSA.
 
 %prep
 %setup -q
+%patch0 -p1
+cp -p %{SOURCE3} src/conf
 
 %build
 %{__libtoolize}
@@ -198,7 +215,10 @@ Moduł wiązania Pythona dla interfejsu miksera architektury ALSA.
 configure_opts="\
        --disable-silent-rules \
        %{!?with_python:--disable-python} \
-       %{?with_resmgr:--enable-resmgr}
+       %{?with_python2:--enable-python2} \
+       %{?with_resmgr:--enable-resmgr} \
+       --enable-mixer-modules \
+       --enable-mixer-pymods
 "
 
 %if %{with static_libs}
@@ -223,7 +243,7 @@ cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/alsa,/etc/modprobe.d}
+install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/alsa/conf.d,%{_datadir}/alsa/alsa.conf.d,/etc/modprobe.d}
 
 %if %{with static_libs}
 %{__make} -C build-static/src install-libLTLIBRARIES \
@@ -233,11 +253,14 @@ install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/alsa,/etc/modprobe.d}
 %{__make} -C build-shared install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_libdir}/libasound.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libasound.so.* $RPM_BUILD_ROOT/%{_lib}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libasound.so
 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libasound.so.*.*) \
        $RPM_BUILD_ROOT%{_libdir}/libasound.so
 
+tar xf %{SOURCE4} --strip-components=1 -C $RPM_BUILD_ROOT%{_datadir}/alsa alsa-topology-conf-%{topology_confver}/topology
+tar xf %{SOURCE5} --strip-components=1 -C $RPM_BUILD_ROOT%{_datadir}/alsa alsa-ucm-conf-%{ucm_confver}/ucm alsa-ucm-conf-%{ucm_confver}/ucm2
+
 install -D utils/alsa.m4 $RPM_BUILD_ROOT%{_aclocaldir}/alsa.m4
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/modprobe.d/alsa-base.conf
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/asound.conf
@@ -256,24 +279,42 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/aserver
 %attr(755,root,root) /%{_lib}/libasound.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libasound.so.2
+%attr(755,root,root) /%{_libdir}/libatopology.so.*.*.*
+%attr(755,root,root) %ghost /%{_libdir}/libatopology.so.2
 %dir %{_libdir}/alsa-lib
 %dir %{_libdir}/alsa-lib/smixer
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-ac97.so
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-hda.so
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-sbase.so
-%{_datadir}/alsa
+%dir %{_datadir}/alsa
+%{_datadir}/alsa/cards
+%{_datadir}/alsa/ctl
+%{_datadir}/alsa/pcm
+%{_datadir}/alsa/topology
+%{_datadir}/alsa/ucm
+%{_datadir}/alsa/ucm2
+%{_datadir}/alsa/alsa.conf
+# directory for "global" config files (not accessed directly, but through symlinks in %{_sysconfdir}/alsa/conf.d)
+%dir %{_datadir}/alsa/alsa.conf.d
+%{_datadir}/alsa/smixer.conf
 %dir %{_sysconfdir}/alsa
+# directory for "local" config files (loaded from %{_datadir}/alsa/alsa.conf)
+%dir %{_sysconfdir}/alsa/conf.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/asound.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/alsa-base.conf
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libasound.so
+%attr(755,root,root) %{_libdir}/libatopology.so
 %{_libdir}/libasound.la
+%{_libdir}/libatopology.la
 %{_includedir}/sys/asoundlib.h
 %{_includedir}/alsa
+%{_includedir}/asoundlib.h
 %{_aclocaldir}/alsa.m4
 %{_pkgconfigdir}/alsa.pc
+%{_pkgconfigdir}/alsa-topology.pc
 
 %if %{with static_libs}
 %files static
This page took 0.028895 seconds and 4 git commands to generate.