]> git.pld-linux.org Git - packages/alex.git/blobdiff - alex.spec
- added bootstrap bcond, release 2
[packages/alex.git] / alex.spec
index 668d244f1915741e2c733421e4088cec8be28918..74d53abd5e39e2daf5464eb19ab29434a38e3ed2 100644 (file)
--- a/alex.spec
+++ b/alex.spec
@@ -1,37 +1,61 @@
+#
+# Conditional build:
+%bcond_with    bootstrap       # use foreign (non-rpm) ghc
+#
 Summary:       A lexical analyser generator for Haskell
+Summary(pl):   Generator analizatorów sk³adniowych dla Haskella
 Name:          alex
-Version:       2.0
-Release:       1
+Version:       2.0.1
+Release:       2
 License:       BSD-like w/o adv. clause
 Group:         Development/Tools
-Source0:       http://www.haskell.org/alex/dist/%{name}-%{version}-src.tar.bz2
-# Source0-md5: 14ff6abf21d81763b15afe151add9091
+Source0:       http://www.haskell.org/alex/dist/%{name}-%{version}-src.tar.gz
+# Source0-md5: edb62560e29c8de23913c65c52adbf19
 Patch0:                %{name}-DESTDIR.patch
 URL:           http://www.haskell.org/alex/
-BuildRequires: ghc >= 5.04
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: docbook-dtd31-sgml
+BuildRequires: docbook-style-dsssl
+%{!?with_bootstrap:BuildRequires:      ghc >= 5.04}
+BuildRequires: gmp-devel
+BuildRequires: jadetex
+BuildRequires: openjade
+BuildRequires: sed >= 4.0
+BuildRequires: tetex-dvips
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Alex is a tool for generating lexical analysers in Haskell,
-given a description of the tokens to be recognised in the form
-of regular expressions.
-It is similar to the tool lex or flex for C/C++.
+Alex is a tool for generating lexical analysers in Haskell, given a
+description of the tokens to be recognised in the form of regular
+expressions. It is similar to the tool lex or flex for C/C++.
+
+%description -l pl
+Alex to narzêdzie do generowania analizatorów sk³adniowych w Haskellu
+na podstawie opisu tokenów do rozpoznawania w postaci wyra¿eñ
+regularnych. Jest podobne do narzêdzi lex lub flex dla C/C++.
 
 %prep
 %setup -q
-%patch0 -p1
+
+sed -i -e 's/alpha\*-unknown-linux/alpha*-*-linux/' configure.ac
 
 %build
+%{__aclocal}
+%{__autoconf}
+cp -f /usr/share/automake/config.sub .
 %configure
+%{__make} depend
 %{__make}
-%{__make} ps -C alex/doc
+%{__make} html -C alex/doc
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       bindir=$RPM_BUILD_ROOT%{_bindir} \
+       libdir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
 
 cp -a alex/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/
 
@@ -40,8 +64,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc alex/{ANNOUNCE,LICENSE,README} alex/doc/alex.{ps,dvi}
+%doc alex/{ANNOUNCE,LICENSE,README} alex/doc/alex
 %attr(755,root,root) %{_bindir}/*
+%dir %{_libdir}/%{name}-%{version}
 %{_libdir}/%{name}-%{version}/A*
 %attr(755,root,root) %{_libdir}/%{name}-%{version}/alex.bin
 %{_examplesdir}/%{name}-%{version}
This page took 0.076144 seconds and 4 git commands to generate.