]> git.pld-linux.org Git - packages/Zope.git/blobdiff - Zope.spec
- modification hotfix
[packages/Zope.git] / Zope.spec
index 009279361ad8ae35031e76eda1bf01afc04cc59a..6390126c162568d3a7cd74ca0a986e0dd965237a 100644 (file)
--- a/Zope.spec
+++ b/Zope.spec
@@ -1,6 +1,8 @@
 %include        /usr/lib/rpm/macros.python
 
 # TODO:
+# - check why initgroups() crashes on AMD64 and something, better than
+#   disabling initgroups() completely, with that
 # - no/more secure initial user/password settings (currently: zope/zope)
 # - ZEO support (mkzeoinstance is not tested and probably doesn't work)
 # - perl support?
@@ -10,13 +12,13 @@ Summary(es):        Un servidor de aplicaciones y un conjunto de herramientas para la c
 Summary(pl):   Serwer aplikacji i toolkit portalowy do tworzenia serwisów WWW
 Summary(pt_BR):        Um servidor de aplicações e um conjunto de ferramentas para construção de sites Web
 Name:          Zope
-Version:       2.7.0
-%define                sub_ver b3
-Release:       3.%{sub_ver}.1
+Version:       2.7.1
+# %%define             sub_ver b2
+Release:       4
 License:       Zope Public License (ZPL)
 Group:         Networking/Daemons
-Source0:       http://www.zope.org/Products/%{name}/%{version}%{sub_ver}/%{version}%{sub_ver}/%{name}-%{version}-%{sub_ver}.tgz
-# Source0-md5: 49d981bb35c33fda6d53b438fb9c9ad7
+Source0:       http://www.zope.org/Products/%{name}/%{version}/%{name}-%{version}.tgz
+# Source0-md5: ae9d4bb3f7220dfffb6e91b42503b16c
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -27,8 +29,10 @@ Source7:     %{name}-zopectl
 Source8:       %{name}-installzopeproduct
 Patch0:                %{name}-default_config.patch
 Patch1:                %{name}-instance_paths.patch
+Patch2:                %{name}-pld_makefile_fix.patch
+Patch3:                %{name}-no_initgroups.patch
 URL:           http://www.zope.org/
-BuildRequires: python-devel >= 2.2.3
+BuildRequires: python-devel >= 2.3.3
 BuildRequires: perl-base
 PreReq:                rc-scripts
 Requires(pre): /usr/bin/getgid
@@ -39,12 +43,18 @@ Requires(postun):   /usr/sbin/userdel
 Requires(postun):      /usr/sbin/groupdel
 Requires(post,preun):  /sbin/chkconfig
 Requires:      logrotate
-Requires:      python >= 2.2.3
-Requires:      python-modules >= 2.2.3
-Requires:      python-libs >= 2.2.3
+Requires:      python >= 2.3.3
+Requires:      python-modules >= 2.3.3
+Requires:      python-libs >= 2.3.3
+Requires:      expat >= 1.95.7
+Requires:      python-PyXML >= 0.8.3
+Requires:      Zope-Hotfix = 040714
 %pyrequires_eq  python
+Obsoletes:     Zope-Hotfix = 040713
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                zope_dir /usr/lib/zope
+
 %description
 The Z Object Programming Environment (Zope) is a free, Open Source
 Python-based application server for building high-performance, dynamic
@@ -78,38 +88,44 @@ eles ao inv
 
 %prep
 
-%setup -q -n %{name}-%{version}-%{sub_ver}
+%setup -q -n %{name}-%{version}-0
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%ifarch amd64 alpha
+%patch3 -p1
+%endif
 
 %build
 perl -pi -e "s|data_dir\s+=\s+.*?join\(INSTANCE_HOME, 'var'\)|data_dir=INSTANCE_HOME|" lib/python/Globals.py
 
 ./configure \
-       --prefix=/usr \
+       --prefix=%{zope_dir} \
        --optimize
+#      --with-python=/usr/bin/python
 
 %{__make}
 
 perl -pi -e "s|data_dir\s+=\s+.*?join\(INSTANCE_HOME, 'var'\)|data_dir=INSTANCE_HOME|" lib/python/Globals.py
-# python wo_pcgi.py
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT{/var/lib/zope/main,/var/run/zope,/var/log/zope/main} \
        $RPM_BUILD_ROOT{/etc/logrotate.d,/etc/sysconfig,/etc/rc.d/init.d} \
-       $RPM_BUILD_ROOT{%{_sysconfdir}/zope/main,%{_sbindir}}
+       $RPM_BUILD_ROOT{%{_sysconfdir}/zope/main,%{_sbindir}} \
+       $RPM_BUILD_ROOT%{zope_dir}/bin
+
+ln -sfn /usr/bin/python $RPM_BUILD_ROOT%{zope_dir}/bin/python
 
-%{__make} install INSTALL_FLAGS="--optimize=1 --root $RPM_BUILD_ROOT"
+%{__make} install \
+       INSTALL_FLAGS="--root $RPM_BUILD_ROOT"
 
-mv $RPM_BUILD_ROOT%{_libdir}{/python,/zope}
-mv $RPM_BUILD_ROOT%{_bindir}/zpasswd.py $RPM_BUILD_ROOT%{_sbindir}/zpasswd
-mv $RPM_BUILD_ROOT%{_bindir}/*.py $RPM_BUILD_ROOT%{_libdir}/zope
-mv $RPM_BUILD_ROOT/usr/skel $RPM_BUILD_ROOT%{_sysconfdir}/zope
-mv $RPM_BUILD_ROOT{%{_prefix}/import/*,%{_sysconfdir}/zope/skel/import}
+mv $RPM_BUILD_ROOT%{zope_dir}/bin/zpasswd.py $RPM_BUILD_ROOT%{_sbindir}/zpasswd
+mv $RPM_BUILD_ROOT%{zope_dir}/skel $RPM_BUILD_ROOT%{_sysconfdir}/zope
+mv $RPM_BUILD_ROOT{%{zope_dir}/import/*,%{_sysconfdir}/zope/skel/import}
 
-rm -rf $RPM_BUILD_ROOT/usr/doc/
+rm -rf $RPM_BUILD_ROOT%{zope_dir}/doc
 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/zope/skel/log
 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/zope/skel/bin/{runzope.bat,zopeservice.py}.in
 
@@ -144,6 +160,8 @@ if [ ! -f /etc/zope/main/zope.conf ] ; then
        echo "Creating initial 'main' instance..."
        /usr/sbin/mkzopeinstance main zope:zope
        echo "Instance created. Listening on 127.0.0.1:8080, initial user: 'zope' with password: 'zope'"
+else
+       echo "old /etc/zope/zope.conf detected - look at changes about upgrade!" >&2
 fi
 was_stopped=0
 for dir in /var/lib/zope/main /var/lib/zope ; do
@@ -192,14 +210,13 @@ fi
 %defattr(644,root,root,755)
 %doc doc/*
 %attr(754,root,root) /etc/rc.d/init.d/zope
-%attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_sbindir}/*
-%{_libdir}/zope
-%attr(771,root,root) %dir /var/run/zope
-%attr(751,root,zope) %dir /var/lib/zope
-%attr(751,root,zope) %dir /var/lib/zope/main
-%attr(771,root,root) %dir /var/log/zope
-%attr(771,root,zope) %dir /var/log/zope/main
+%{zope_dir}
+%attr(775,zope,zope) %dir /var/run/zope
+%attr(775,zope,zope) %dir /var/lib/zope
+%attr(775,zope,zope) %dir /var/lib/zope/main
+%attr(775,zope,zope) %dir /var/log/zope
+%attr(775,zope,zope) %dir /var/log/zope/main
 %attr(640,root,root) %dir /etc/zope
 %attr(640,root,root) %dir /etc/zope/skel
 %attr(640,root,root) %dir /etc/zope/main
This page took 0.078663 seconds and 4 git commands to generate.