]> git.pld-linux.org Git - packages/QtCurve.git/blobdiff - QtCurve.spec
- use shell constructs instead of subshells in mozilla mailto.sh wrapper
[packages/QtCurve.git] / QtCurve.spec
index 3208f6f7443452d3eef185a91e4b34b1c22a19bc..8c9e489dfc3bbd9fffe86a3954206e32ab388397 100644 (file)
@@ -1,38 +1,41 @@
-#
-# ToDo:
-#  - include /usr/share/themes/QtCurve/mozilla somewhere
+# TODO:
+# - kde4
+# - gtk1 no longer updated. drop?
+# - include /usr/share/themes/QtCurve/mozilla somewhere
+# - unpackaged:
 #
 # Conditional build:
 %bcond_with    gtk     # build GTK styles
 %bcond_without gtk2    # don't build GTK+2 styles
 #
-%define                kde_ver         0.52
-%define                gtk2_ver        0.52
+%define                kde_ver         0.55.1
+%define                gtk2_ver        0.55.1
 %define                gtk1_ver        0.42.2
 Summary:       A free and corrected port of Red Hat's GTK+/Qt theme
 Summary(pl.UTF-8):     Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
 Name:          QtCurve
-Version:       0.52
+Version:       0.55.1
 Release:       1
 License:       GPL
 Group:         Themes
-Source0:       http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.gz
-# Source0-md5: d5db2a64eb5b6267381d81192bceddff
-Source1:       http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.gz
-# Source1-md5: e7463be98639123cdc570040d7e37a3b
+Source0:       http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
+# Source0-md5: 1ba394626a40e8926966739500dbf87d
+Source1:       http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
+# Source1-md5: 0d5eeb45990c3ecf060daa68a2ed2e6f
 Source2:       http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
 # Source2-md5: 8219f58493ca4e65a8fe61ee76eca522
-Patch0:                %{name}-amd64.patch
-Patch1:                kde-am110.patch
-Patch2:                kde-ac260-lt.patch
+Patch0:                %{name}-Gtk2-userjs.patch
+Patch1:                %{name}-Gtk2-mailto.patch
 URL:           http://www.kde-look.org/content/show.php?content=40492
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: cmake
 %{?with_gtk:BuildRequires:     gtk+-devel}
 %{?with_gtk2:BuildRequires:    gtk+2-devel}
 BuildRequires: kdelibs-devel >= 3.1
 BuildRequires: libtool
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.293
 BuildRequires: sed > 4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -85,35 +88,34 @@ Wersja pod GTK+2.
 Summary:       A free and corrected port of Redhats GTK+/Qt theme - common
 Summary(pl.UTF-8):     Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
 Group:         Themes
-Obsoletes:     theme-bluecurve-common
-Obsoletes:     gtk2-theme-bluecurve
 Obsoletes:     gtk-theme-bluecurve
+Obsoletes:     gtk2-theme-bluecurve
 Obsoletes:     kde-style-bluecurve
 Obsoletes:     kde-theme-bluecurve
+Obsoletes:     theme-bluecurve-common
 
 %description -n theme-QtCurve-common
-A free and corrected port of Red Hat's GTK+/Qt theme.
-Documentation and common files package.
+A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
+and common files package.
 
 %description -n theme-QtCurve-common -l pl.UTF-8
 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
 Pakiet z dokumentacja i plikami współdzielonymi.
 
 %prep
-%setup -q -c -a1 -a2
-#%patch0 -p1
-cd %{name}-KDE3-%{kde_ver}
-%patch1 -p1
-%patch2 -p1
+%setup -q -c %{?with_gtk2:-a1} %{?with_gtk:-a2}
+%if %{with gtk2}
+cd %{name}-Gtk2-%{gtk2_ver}
+%patch0 -p1
+%patch1 -p0
+cd -
+%endif
 
 %build
 cd %{name}-KDE3-%{kde_ver}
-cp /usr/share/automake/config.sub admin
-
-%{__make} -f admin/Makefile.common cvs
-%configure \
-       --with-qt-libraries=%{_libdir}
-
+%cmake \
+       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       .
 %{__make}
 cd -
 
@@ -131,12 +133,9 @@ cd -
 
 %if %{with gtk2}
 cd %{name}-Gtk2-%{gtk2_ver}
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure
+%cmake \
+       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       .
 %{__make}
 cd -
 %endif
@@ -166,9 +165,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/kde3/kstyle_qtcurve_config.la
 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
-%{_libdir}/kde3/plugins/styles/*.la
+#%{_libdir}/kde3/plugins/styles/*.la
 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
+%{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
 %{_datadir}/apps/QtCurve
 
 %if %{with gtk}
@@ -183,6 +183,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
 %{_datadir}/themes/QtCurve/gtk-2.0
+%{_datadir}/themes/QtCurve/mozilla
 %endif
 
 %files -n theme-QtCurve-common
This page took 0.115078 seconds and 4 git commands to generate.