]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- tabs in preamble
[packages/OpenAL.git] / OpenAL.spec
index 5b05f2378902cbb270e52ed4bd7aabc0fcac0bc7..c8c51eaf3306217c44a58529b584a0785274086c 100644 (file)
@@ -1,40 +1,53 @@
 #
-# TODO:
-# - Build stops at:
-# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
-# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
-# arch/i386/x86_floatmul.c: In function `_alFloatMul':
-#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
-# Please submit a full bug report,
-#
-# - autoconf provides undefined macro....
-
 # Conditional build:
 #
 %bcond_without alsa    # without ALSA support
 %bcond_with    arts    # with aRts support
 %bcond_without esd     # without esd support
-%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
-
+%bcond_without mmx     # don't use MMX
+#
+%ifnarch %{ix86} %{x8664}
+%undefine      with_mmx
+%endif
+%ifarch i386 i486
+%undefine      with_mmx
+%endif
 Summary:       Open Audio Library
-Summary(pl):   Otwarta Biblioteka D¼wiêku
+Summary(pl.UTF-8):     Otwarta Biblioteka Dźwięku
 Name:          OpenAL
 Version:       0.0.8
-Release:       1
+Release:       2
 License:       LGPL
 Group:         Libraries
 Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
 # Source0-md5: 641cf53761f35ee979f3e888614797a0
 URL:           http://www.openal.org/
+Patch0:                %{name}-alc.h.patch
 BuildRequires: SDL-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
+BuildRequires: autoconf >= 2.56
+BuildRequires: automake
 %{?with_esd:BuildRequires:     esound-devel}
+%if %{with mmx}
+# MMX code triggers ICE in gcc 3.3.x
+BuildRequires: gcc >= 5:3.4.0
+%endif
+BuildRequires: libtool
 BuildRequires: libvorbis-devel
+%ifarch %{ix86}
 %{?with_mmx:BuildRequires:     nasm}
+%endif
+BuildRequires: pkgconfig
 BuildRequires: smpeg-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%if %{with mmx}
+%define                specflags_ia32  -mmmx
+%else
+%define                specflags_ia32  -U__MMX__
+%endif
+
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily
@@ -43,56 +56,65 @@ developers and desktop users that rely on portable standards like
 OpenGL, for games and other multimedia applications. OpenAL is already
 supported by a number of hardware vendors and developers.
 
-%description -l pl
-OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
-interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
-Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
-którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
-aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
-dostarczycieli sprzêtu i programistów.
+%description -l pl.UTF-8
+OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
+stworzenia otwartego, niezależnego od producentów, międzyplatformowego
+interfejsu projektowania aplikacji w części obsługi dźwięku.
+Biblioteka adresowana jest do twórców aplikacji i użytkowników,
+którzy wybierają przenośne standardy, jak OpenGL, w grach i
+aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
+dostarczycieli sprzętu i programistów.
 
 %package devel
 Summary:       Headers for OpenAL
-Summary(pl):   Pliki nag³ówkowe do OpenAL
+Summary(pl.UTF-8):     Pliki nagłówkowe do OpenAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
 
-%description devel -l pl
-Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
+%description devel -l pl.UTF-8
+Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
 OpenAL.
 
 %package static
 Summary:       OpenAL static library
-Summary(pl):   Statyczna biblioteka OpenAL
+Summary(pl.UTF-8):     Statyczna biblioteka OpenAL
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
 %setup -q -n openal-%{version}
+%patch0 -p1
 
 %build
+%{__libtoolize}
+%{__aclocal} -I admin/autotools/m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
-       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
-       %{?with_arts:--enable-arts --enable-arts-dlopen} \
-       %{?with_esd:--enable-esd --enable-esd-dlopen} \
+       --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
+       --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
+       --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
        --enable-sdl --enable-sdl-dlopen \
        --enable-capture \
        --enable-linux \
        --enable-null \
+%ifarch amd64 x86_64 athlon i686 i586
+       --enable-optim-generic \
+%endif
        --enable-waveout \
        --enable-vorbis --enable-vorbis-dlopen \
        --enable-mp3 --enable-mp3-dlopen \
-       --with-gcc=%{__cc}
+       --with-gcc="%{__cc}"
 
 %{__make}
 
@@ -111,16 +133,17 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog NOTES TODO
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*-config
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/*.la
-%{_pkgconfigdir}/*
+%doc common/specification/OpenAL1-1Spec.pdf
+%attr(755,root,root) %{_bindir}/openal-config
+%attr(755,root,root) %{_libdir}/libopenal.so
+%{_libdir}/libopenal.la
 %{_includedir}/AL
+%{_pkgconfigdir}/openal.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/libopenal.a
This page took 0.034449 seconds and 4 git commands to generate.