]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
fix nosse patch; rel 2
[packages/OpenAL.git] / OpenAL.spec
index e4271d801c60c744a9d59301f9ffbd0583780102..ab8b18e6d1ecb7689695e5fde18843c08a79eea7 100644 (file)
@@ -2,37 +2,42 @@
 # Conditional build:
 %bcond_without alsa            # ALSA backend
 %bcond_without jack            # JACK backend
+%bcond_without pipewire        # PipeWire backend
 %bcond_without portaudio       # PortAudio backend
 %bcond_without pulseaudio      # PulseAudio backend
+%bcond_without rtkit           # RTKit support
 %bcond_with    sdl             # SDL2 backend
 %bcond_with    sse2            # force use of SSE2 instructions (x86)
 %bcond_without gui             # alsoft-config GUI
 %bcond_with    qt4             # Qt 4 instead of Qt 5 for GUI
+
 %ifarch pentium4 x32 %{x8664}
 %define        with_sse2       1
 %endif
 Summary:       Open Audio Library
 Summary(pl.UTF-8):     Otwarta Biblioteka Dźwięku
 Name:          OpenAL
-Version:       1.20.1
-Release:       1
+Version:       1.22.0
+Release:       2
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
-# Source0-md5: 556695068ce8375b89986083d810fd35
+Source0:       https://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
+# Source0-md5: 40e5b29a241e1e320b5b16ed8f912257
 Patch0:                %{name}-pc.patch
 Patch1:                %{name}-nosse.patch
 URL:           http://www.openal.org/
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 BuildRequires: cmake >= 3.0.2
+%{?with_rtkit:BuildRequires:   dbus-devel}
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
 BuildRequires: libmysofa-devel
-BuildRequires: libstdc++-devel >= 6:4.8.1
+BuildRequires: libstdc++-devel >= 6:5
+%{?with_pipewire:BuildRequires:        pipewire-devel >= 0.3}
 BuildRequires: pkgconfig
 %{?with_portaudio:BuildRequires:       portaudio-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
-BuildRequires: rpmbuild(macros) >= 1.605
+BuildRequires: rpmbuild(macros) >= 1.742
 %if %{with gui}
 %if %{with qt4}
 BuildRequires: QtCore-devel >= 4.8.0
@@ -102,8 +107,10 @@ cd build
 %cmake .. \
        %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
        %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
+       %{cmake_on_off pipewire ALSOFT_BACKEND_PIPEWIRE} \
        %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
        %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
+       %{cmake_on_off rtkit ALSOFT_RTKIT} \
        %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
        %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
        -DALSOFT_EXAMPLES=OFF \
@@ -121,9 +128,6 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
 
 install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
 
-# these look not really useful
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.056868 seconds and 4 git commands to generate.