]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- include specs PDF in -devel
[packages/OpenAL.git] / OpenAL.spec
index df4dd953eee79f1782ec8544bcca6d7a4f1c21d1..7f53531101729c0b8e13417a30f33c3ee827ae28 100644 (file)
@@ -1,32 +1,48 @@
-Summary:       OpenAL - Open Audio Library
-Summary(pl):   OpenAL - Otwarta Biblioteka D¼wiêku
+#
+# Conditional build:
+#
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without esd     # without esd support
+%bcond_without mmx     # don't use MMX
+#
+%ifnarch %{ix86} %{x8664}
+%undefine      with_mmx
+%endif
+%ifarch i386 i486
+%undefine      with_mmx
+%endif
+Summary:       Open Audio Library
+Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       20011116
+Version:       0.0.8
 Release:       1
 License:       LGPL
-Group:         X11/Libraries
-Group(de):     X11/Libraries
-Group(es):     X11/Bibliotecas
-Group(fr):     X11/Librairies
-Group(pl):     X11/Biblioteki
-Group(pt_BR):  X11/Bibliotecas
-Group(ru):     X11/âÉÂÌÉÏÔÅËÉ
-Group(uk):     X11/â¦Â̦ÏÔÅËÉ
-Vendor:                Loki Entertainment Software - http://www.lokigames.com/
-Source0:       ftp://ftp.openal.com/nie-wiem-co-tu-daæ.tar.bz2/%{name}-%{version}.tar.bz2
-Source1:       ftp://ftp.openal.com/nie-wiem-co-tu-daæ.tar.bz2/%{name}-headers-%{version}.tar.bz2
-Patch0:                %{name}-stdio.patch
-Patch1:                %{name}-include_unconsequency.patch
-Patch2:                %{name}-symlinks.patch
-URL:           http://www.openal.com/
-BuildRequires: alsa-lib-devel
+Group:         Libraries
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
+URL:           http://www.openal.org/
 BuildRequires: SDL-devel
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
+%{?with_esd:BuildRequires:     esound-devel}
+%if %{with mmx}
+# MMX code triggers ICE in gcc 3.3.x
+BuildRequires: gcc >= 5:3.4.0
+%endif
 BuildRequires: libvorbis-devel
+%ifarch %{ix86}
+%{?with_mmx:BuildRequires:     nasm}
+%endif
+BuildRequires: pkgconfig
 BuildRequires: smpeg-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
+%if %{with mmx}
+%define                specflags_ia32  -mmmx
+%else
+%define                specflags_ia32  -U__MMX__
+%endif
 
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
@@ -37,70 +53,66 @@ OpenGL, for games and other multimedia applications. OpenAL is already
 supported by a number of hardware vendors and developers.
 
 %description -l pl
-OpenAL, otwarta bibliotela d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
+OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
+stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
-Biblioteka adersowana jest do twórców aplikacji i urzytkowników,
+Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
 dostarczycieli sprzêtu i programistów.
 
-
 %package devel
-Summary:       OpenAL development files
-Summary(pl):   Pakiet dla Programistów OpenAL
-Group:         Development/Building
-Group(de):     Entwicklung/Bauen
-Group(pl):     Programowanie/Budowanie
-Requires:      %{name} = %{version}
+Summary:       Headers for OpenAL
+Summary(pl):   Pliki nag³ówkowe do OpenAL
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
-OpenAL header files.
+Header files for OpenAL-based programs.
 
 %description devel -l pl
-Pliki nag³ówkowe biblioteki OpenAL.
-
+Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
+OpenAL.
 
 %package static
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
-Group:         Development/Building
-Group(de):     Entwicklung/Bauen
-Group(pl):     Programowanie/Budowanie
-Requires:      %{name} = %{version}
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
-
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n %{name} -a 1
-cp -f AL/*.h include/AL/
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
+%setup -q -n openal-%{version}
 
 %build
-./autogen.sh
-./configure \
-       --enable-prefix=%{_prefix} \
-       --enable-optimization \
-       --enable-alsa \
-       --enable-sdl \
-       --enable-vorbis \
-       --enable-smpeg \
+%configure \
+       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
+       --enable-sdl --enable-sdl-dlopen \
        --enable-capture \
-       --with-gcc=%{__cc}
+       --enable-linux \
+       --enable-null \
+%ifarch i586 i686
+       --enable-optim-generic \
+%endif
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc="%{__cc}"
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install DESTDIR=$RPM_BUILD_ROOT%{_prefix}/
-ln -sf libopenal.so.0.0.6 $RPM_BUILD_ROOT%{_libdir}/libopenal.so
-gzip -9nf TODO NOTES ChangeLog CREDITS
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -110,14 +122,18 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{_libdir}/*.so.*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
+%doc common/specification/OpenAL1-1Spec.pdf
+%attr(755,root,root) %{_bindir}/openal-config
+%attr(755,root,root) %{_libdir}/libopenal.so
+%{_libdir}/libopenal.la
 %{_includedir}/AL
-%{_libdir}/*.so
+%{_pkgconfigdir}/openal.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/libopenal.a
This page took 0.03558 seconds and 4 git commands to generate.