]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- include specs PDF in -devel
[packages/OpenAL.git] / OpenAL.spec
index 3c023e8495167a2ba54b9330a56bb5c099875508..7f53531101729c0b8e13417a30f33c3ee827ae28 100644 (file)
@@ -1,47 +1,49 @@
 #
 # Conditional build:
-# TODO:
-# - Build stops at:
-# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
-# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
-# arch/i386/x86_floatmul.c: In function `_alFloatMul':
-#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
-# Please submit a full bug report,
 #
-# - autoconf provides undefined macro....
-
 %bcond_without alsa    # without ALSA support
 %bcond_with    arts    # with aRts support
-%bcond_without doc     # don't build HTML documentation (from SGML source)
 %bcond_without esd     # without esd support
-%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
-
+%bcond_without mmx     # don't use MMX
+#
+%ifnarch %{ix86} %{x8664}
+%undefine      with_mmx
+%endif
+%ifarch i386 i486
+%undefine      with_mmx
+%endif
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
 Version:       0.0.8
-Release:       0.1
+Release:       1
 License:       LGPL
 Group:         Libraries
 Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
 # Source0-md5: 641cf53761f35ee979f3e888614797a0
-#Patch0:               %{name}-prefix.patch
-#Patch1:               %{name}-info.patch
 URL:           http://www.openal.org/
 BuildRequires: SDL-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: autoconf
-BuildRequires: automake
-%{?with_doc:BuildRequires:     docbook-utils}
 %{?with_esd:BuildRequires:     esound-devel}
-%{?with_doc:BuildRequires:     gnome-doc-tools}
+%if %{with mmx}
+# MMX code triggers ICE in gcc 3.3.x
+BuildRequires: gcc >= 5:3.4.0
+%endif
 BuildRequires: libvorbis-devel
+%ifarch %{ix86}
 %{?with_mmx:BuildRequires:     nasm}
+%endif
+BuildRequires: pkgconfig
 BuildRequires: smpeg-devel
-BuildRequires: texinfo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%if %{with mmx}
+%define                specflags_ia32  -mmmx
+%else
+%define                specflags_ia32  -U__MMX__
+%endif
+
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily
@@ -86,29 +88,28 @@ Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
 %setup -q -n openal-%{version}
-#%patch0 -p1
-#%patch1 -p1
 
 %build
-cp -f /usr/share/automake/config.sub .
-#%{__aclocal}
-#%{__autoconf}
-#%{__autoheader}
 %configure \
        %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
        %{?with_arts:--enable-arts --enable-arts-dlopen} \
        %{?with_esd:--enable-esd --enable-esd-dlopen} \
-       --enable-sdl \
-       --enable-vorbis \
-       --enable-smpeg \
+       --enable-sdl --enable-sdl-dlopen \
        --enable-capture \
-       --with-gcc=%{__cc}
+       --enable-linux \
+       --enable-null \
+%ifarch i586 i686
+       --enable-optim-generic \
+%endif
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc="%{__cc}"
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_infodir}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -119,25 +120,20 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun        devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog NOTES TODO
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*-config
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/*.la
-%{_pkgconfigdir}/*
+%doc common/specification/OpenAL1-1Spec.pdf
+%attr(755,root,root) %{_bindir}/openal-config
+%attr(755,root,root) %{_libdir}/libopenal.so
+%{_libdir}/libopenal.la
 %{_includedir}/AL
+%{_pkgconfigdir}/openal.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/libopenal.a
This page took 0.315331 seconds and 4 git commands to generate.