]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- call automake too
[packages/OpenAL.git] / OpenAL.spec
index 1de224497a8fcdbb310e906ec135fca99a79658a..5e0e33e7474523fc619f17c6790cfee6ecfa1064 100644 (file)
@@ -1,31 +1,51 @@
+#
+# Conditional build:
+#
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without esd     # without esd support
+%bcond_without mmx     # don't use MMX
+#
+%ifnarch %{ix86} %{x8664}
+%undefine      with_mmx
+%endif
+%ifarch i386 i486
+%undefine      with_mmx
+%endif
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
+Version:       0.0.8
 Release:       1
 License:       LGPL
-Group:         X11/Libraries
-Group(de):     X11/Libraries
-Group(es):     X11/Bibliotecas
-Group(fr):     X11/Librairies
-Group(pl):     X11/Biblioteki
-Group(pt_BR):  X11/Bibliotecas
-Group(ru):     X11/âÉÂÌÉÏÔÅËÉ
-Group(uk):     X11/â¦Â̦ÏÔÅËÉ
-Vendor:                Loki Entertainment Software - http://www.lokigames.com/
-# This is tarball taken directly form Mandrake Cooker .src.rpm
-Source0:       %{name}-linuxonly-20010805.tar.bz2
-# Those patches came from Mandrake Cooker (only changed names)
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-build.patch
-URL:           http://www.openal.com/
-BuildRequires:  alsa-lib-devel
-BuildRequires:  SDL-devel
-BuildRequires:  libvorbis-devel
-BuildRequires:  smpeg-devel
+Group:         Libraries
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
+URL:           http://www.openal.org/
+BuildRequires: SDL-devel
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
+BuildRequires: autoconf >= 2.56
+BuildRequires: automake
+%{?with_esd:BuildRequires:     esound-devel}
+%if %{with mmx}
+# MMX code triggers ICE in gcc 3.3.x
+BuildRequires: gcc >= 5:3.4.0
+%endif
+BuildRequires: libtool
+BuildRequires: libvorbis-devel
+%ifarch %{ix86}
+%{?with_mmx:BuildRequires:     nasm}
+%endif
+BuildRequires: pkgconfig
+BuildRequires: smpeg-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6/
+%if %{with mmx}
+%define                specflags_ia32  -mmmx
+%else
+%define                specflags_ia32  -U__MMX__
+%endif
 
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
@@ -36,24 +56,19 @@ OpenGL, for games and other multimedia applications. OpenAL is already
 supported by a number of hardware vendors and developers.
 
 %description -l pl
-OpenAL, otwarta bibliotela d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
+OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
+stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
-Biblioteka adersowana jest do twórców aplikacji i urzytkowników,
+Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
 dostarczycieli sprzêtu i programistów.
 
-
 %package devel
 Summary:       Headers for OpenAL
-Group:         Development
-Group(de):     Entwicklung
-Group(es):     Desarrollo
-Group(pl):     Programowanie
-Group(pt_BR):  Desenvolvimento
-Group(ru):     òÁÚÒÁÂÏÔËÁ
-Group(uk):     òÏÚÒÏÂËÁ
+Summary(pl):   Pliki nag³ówkowe do OpenAL
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
@@ -62,70 +77,71 @@ Header files for OpenAL-based programs.
 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
 OpenAL.
 
-
 %package static
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
-Group:         Development/Building
-Group(de):     Entwicklung/Bauen
-Group(pl):     Programowanie/Budowanie
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
-
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n tmp/openal
-%patch0 -p0
-%patch1 -p0
-
+%setup -q -n openal-%{version}
 
 %build
-cd linux
-sh ./autogen.sh
-%configure  --enable-prefix=%{_prefix} \
-            --enable-optimization \
-           --enable-alsa \
-           --enable-sdl \
-           --enable-vorbis \
-           --enable-smpeg \
-           --enable-capture \
-           --with-gcc=%{__cc}                      
+%{__libtoolize}
+%{__aclocal} -I admin/autotools/m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
+       --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
+       --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
+       --enable-sdl --enable-sdl-dlopen \
+       --enable-capture \
+       --enable-linux \
+       --enable-null \
+%ifarch amd64 x86_64 athlon i686 i586
+       --enable-optim-generic \
+%endif
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc="%{__cc}"
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-cd linux
-%makeinstall
-
-mkdir -p $RPM_BUILD_ROOT%{_infodir}
-install -c  doc/openal.info $RPM_BUILD_ROOT/%{_infodir}
-
-# This needs patch, but is it worth to waste time ?
-rm -f $RPM_BUILD_ROOT%{_libdir}/libopenal.{so,so.0}
 
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/*.so*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc %{_infodir}/openal.info.*
-%{_includedir}/AL/*.h
-
+%doc common/specification/OpenAL1-1Spec.pdf
+%attr(755,root,root) %{_bindir}/openal-config
+%attr(755,root,root) %{_libdir}/libopenal.so
+%{_libdir}/libopenal.la
+%{_includedir}/AL
+%{_pkgconfigdir}/openal.pc
 
 %files static
 %defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/*.a*
+%{_libdir}/libopenal.a
This page took 0.032624 seconds and 4 git commands to generate.