]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- call automake too
[packages/OpenAL.git] / OpenAL.spec
index 00dd11ba639626c61a50c28e1ae39a2a759504e7..5e0e33e7474523fc619f17c6790cfee6ecfa1064 100644 (file)
@@ -1,54 +1,52 @@
 #
 # Conditional build:
-# _without_alsa                - without ALSA support
-# _without_doc         - don't build HTML documentation (from SGML source)
-# _without_esd         - without esd support
-# _with_mmx            - use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
 #
-# TODO:
-# - remove zip bcond?
-# - check %{name}-acfix.patch if it's still nedded, sorry
-#   for the inconvenience, I'll do it if I can...
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without esd     # without esd support
+%bcond_without mmx     # don't use MMX
 #
-%ifarch athlon
-%define                _with_mmx       1
+%ifnarch %{ix86} %{x8664}
+%undefine      with_mmx
 %endif
-
-%ifarch sparc
-%define                _without_alsa   1
+%ifarch i386 i486
+%undefine      with_mmx
 %endif
-
-
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
-%define        snap    20030806
-Release:       1.%{snap}.0.10
+Version:       0.0.8
+Release:       1
 License:       LGPL
 Group:         Libraries
-# from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
-# (without all Win and Mac stuff and demos)
-Source0:       http://pb152.srem.sdi.tpnet.pl/pld/%{name}-linuxonly-%{snap}.tar.bz2
-# Source0-md5: 4a5202f6cba291ae0a9af59410bdda88
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-acfix.patch
-Patch2:                %{name}-info.patch
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
 URL:           http://www.openal.org/
 BuildRequires: SDL-devel
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
-BuildRequires: autoconf
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
+BuildRequires: autoconf >= 2.56
 BuildRequires: automake
-%{!?_without_doc:BuildRequires:        docbook-utils}
-%{!?_without_esd:BuildRequires:        esound-devel}
-%{!?_without_doc:BuildRequires:        gnome-doc-tools}
+%{?with_esd:BuildRequires:     esound-devel}
+%if %{with mmx}
+# MMX code triggers ICE in gcc 3.3.x
+BuildRequires: gcc >= 5:3.4.0
+%endif
+BuildRequires: libtool
 BuildRequires: libvorbis-devel
-%{?_with_mmx:BuildRequires:    nasm}
+%ifarch %{ix86}
+%{?with_mmx:BuildRequires:     nasm}
+%endif
+BuildRequires: pkgconfig
 BuildRequires: smpeg-devel
-BuildRequires: texinfo
-BuildRequires: zip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%if %{with mmx}
+%define                specflags_ia32  -mmmx
+%else
+%define                specflags_ia32  -U__MMX__
+%endif
+
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily
@@ -70,7 +68,7 @@ dostarczycieli sprz
 Summary:       Headers for OpenAL
 Summary(pl):   Pliki nag³ówkowe do OpenAL
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
@@ -83,7 +81,7 @@ OpenAL.
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
@@ -92,68 +90,58 @@ OpenAL static library.
 Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n openal
-%patch0 -p1
-#%%patch1 -p1
-%patch2 -p1
-
-echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
+%setup -q -n openal-%{version}
 
 %build
-cd linux
-%{__aclocal}
+%{__libtoolize}
+%{__aclocal} -I admin/autotools/m4
 %{__autoconf}
 %{__autoheader}
+%{__automake}
 %configure \
-       %{!?debug:--enable-optimization} \
-       %{?_with_mmx:--enable-arch-asm} \
-       %{!?_without_alsa:--enable-alsa} \
-       %{!?_without_esd:--enable-esd} \
-       --enable-sdl \
-       --enable-vorbis \
-       --enable-smpeg \
+       --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
+       --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
+       --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
+       --enable-sdl --enable-sdl-dlopen \
        --enable-capture \
-       --with-gcc=%{__cc}
+       --enable-linux \
+       --enable-null \
+%ifarch amd64 x86_64 athlon i686 i586
+       --enable-optim-generic \
+%endif
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc="%{__cc}"
 
 %{__make}
 
-cd ../docs
-%{!?_without_doc:%{__make} full-html}
-
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_infodir}
 
-cd linux
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun        devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
 %files
 %defattr(644,root,root,755)
-%doc linux/{CREDITS,ChangeLog,NOTES,TODO}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc linux/doc/LOKI* %{!?_without_doc:docs/oalspecs-full}
-%attr(755,root,root) %{_libdir}/lib*.so
+%doc common/specification/OpenAL1-1Spec.pdf
+%attr(755,root,root) %{_bindir}/openal-config
+%attr(755,root,root) %{_libdir}/libopenal.so
+%{_libdir}/libopenal.la
 %{_includedir}/AL
-%{_infodir}/openal.info*
+%{_pkgconfigdir}/openal.pc
 
 %files static
 %defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/*.a
+%{_libdir}/libopenal.a
This page took 0.062613 seconds and 4 git commands to generate.