]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- cleanups, rel 1
[packages/OpenAL.git] / OpenAL.spec
index d72102da7bf91f62e931d5d418d2ad9a0642ca98..5b05f2378902cbb270e52ed4bd7aabc0fcac0bc7 100644 (file)
@@ -1,32 +1,40 @@
+#
+# TODO:
+# - Build stops at:
+# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c: In function `_alFloatMul':
+#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
+# Please submit a full bug report,
+#
+# - autoconf provides undefined macro....
+
+# Conditional build:
+#
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without esd     # without esd support
+%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
+
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
+Version:       0.0.8
 Release:       1
 License:       LGPL
-Group:         X11/Libraries
-Group(de):     X11/Libraries
-Group(es):     X11/Bibliotecas
-Group(fr):     X11/Librairies
-Group(pl):     X11/Biblioteki
-Group(pt_BR):  X11/Bibliotecas
-Group(ru):     X11/âÉÂÌÉÏÔÅËÉ
-Group(uk):     X11/â¦Â̦ÏÔÅËÉ
-Vendor:                Loki Entertainment Software - http://www.lokigames.com/
-# This is tarball taken directly form Mandrake Cooker .src.rpm
-Source0:       %{name}-linuxonly-20010805.tar.bz2
-# Those patches came from Mandrake Cooker (only changed names)
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-build.patch
-URL:           http://www.openal.com/
-BuildRequires: alsa-lib-devel
+Group:         Libraries
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
+URL:           http://www.openal.org/
 BuildRequires: SDL-devel
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
+%{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: libvorbis-devel
+%{?with_mmx:BuildRequires:     nasm}
 BuildRequires: smpeg-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily
@@ -37,7 +45,7 @@ supported by a number of hardware vendors and developers.
 
 %description -l pl
 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
+stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
@@ -47,15 +55,8 @@ dostarczycieli sprz
 %package devel
 Summary:       Headers for OpenAL
 Summary(pl):   Pliki nag³ówkowe do OpenAL
-Group:         X11/Development/Libraries
-Group(de):     X11/Entwicklung/Libraries
-Group(es):     X11/Desarrollo/Bibliotecas
-Group(fr):     X11/Development/Librairies
-Group(pl):     X11/Programowanie/Biblioteki
-Group(pt_BR):  X11/Desenvolvimento/Bibliotecas
-Group(ru):     X11/òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     X11/òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
-Requires:      %{name} = %{version}
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
@@ -67,50 +68,39 @@ OpenAL.
 %package static
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
-Group:         X11/Development/Libraries
-Group(de):     X11/Entwicklung/Libraries
-Group(es):     X11/Desarrollo/Bibliotecas
-Group(fr):     X11/Development/Librairies
-Group(pl):     X11/Programowanie/Biblioteki
-Group(pt_BR):  X11/Desenvolvimento/Bibliotecas
-Group(ru):     X11/òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     X11/òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
-Requires:      %{name}-devel = %{version}
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n tmp/openal
-%patch0 -p0
-%patch1 -p0
+%setup -q -n openal-%{version}
 
 %build
-cd linux
-sh ./autogen.sh
-%configure  --enable-prefix=%{_prefix} \
-            --enable-optimization \
-           --enable-alsa \
-           --enable-sdl \
-           --enable-vorbis \
-           --enable-smpeg \
-           --enable-capture \
-           --with-gcc=%{__cc}                      
+%configure \
+       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
+       --enable-sdl --enable-sdl-dlopen \
+       --enable-capture \
+       --enable-linux \
+       --enable-null \
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc=%{__cc}
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-cd linux
-%makeinstall
-
-mkdir -p $RPM_BUILD_ROOT%{_infodir}
-install -c  doc/openal.info $RPM_BUILD_ROOT%{_infodir}
 
-# This needs patch, but is it worth to waste time ?
-rm -f $RPM_BUILD_ROOT%{_libdir}/libopenal.{so,so.0}
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -118,22 +108,19 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun        devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/*.so*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc %{_infodir}/openal.info.*
-%{_includedir}/AL/*.h
+%attr(755,root,root) %{_bindir}/*-config
+%attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/*.la
+%{_pkgconfigdir}/*
+%{_includedir}/AL
 
 %files static
 %defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/*.a
+%{_libdir}/*.a
This page took 0.034512 seconds and 4 git commands to generate.