]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- cleanups, rel 1
[packages/OpenAL.git] / OpenAL.spec
index 29a78ec67fac7a7d2fe175ea97172797aade88b3..5b05f2378902cbb270e52ed4bd7aabc0fcac0bc7 100644 (file)
@@ -1,41 +1,38 @@
 #
+# TODO:
+# - Build stops at:
+# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c: In function `_alFloatMul':
+#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
+# Please submit a full bug report,
+#
+# - autoconf provides undefined macro....
+
 # Conditional build:
-# _without_alsa                - without ALSA support
-# _without_doc         - don't build HTML documentation (from SGML source)
-# _with_mmx            - use MMX (won't run on non-MMX CPU)
 #
-%ifarch athlon
-%define                _with_mmx       1
-%endif
-%ifnarch i586 i686 athlon
-%define                _with_mmx       0
-%endif
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without esd     # without esd support
+%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
+
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
+Version:       0.0.8
 Release:       1
 License:       LGPL
 Group:         Libraries
-Vendor:                Loki Entertainment Software - http://www.lokigames.com/
-# This is tarball taken directly form Mandrake Cooker .src.rpm
-Source0:       %{name}-linuxonly-20010805.tar.bz2
-# Those patches came from Mandrake Cooker (only changed names)
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-build.patch
-Patch2:                %{name}-acfix.patch
-Patch3:                %{name}-info.patch
-URL:           http://www.openal.com/
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
+URL:           http://www.openal.org/
 BuildRequires: SDL-devel
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
-BuildRequires: autoconf
-BuildRequires: automake
-%{!?_without_doc:BuildRequires:        docbook-utils}
-%{!?_without_doc:BuildRequires:        gnome-doc-tools}
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
+%{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: libvorbis-devel
-%{?_with_mmx:BuildRequires:    nasm}
+%{?with_mmx:BuildRequires:     nasm}
 BuildRequires: smpeg-devel
-BuildRequires: texinfo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -48,7 +45,7 @@ supported by a number of hardware vendors and developers.
 
 %description -l pl
 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
+stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
@@ -59,7 +56,7 @@ dostarczycieli sprz
 Summary:       Headers for OpenAL
 Summary(pl):   Pliki nag³ówkowe do OpenAL
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
@@ -72,78 +69,58 @@ OpenAL.
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n tmp
-%patch0 -p1
-%patch2 -p1
-%patch3 -p1
-cd openal
-%patch1 -p0
-
-echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
+%setup -q -n openal-%{version}
 
 %build
-cd openal/linux
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
 %configure \
-       %{!?debug:--enable-optimization} \
-       %{?_with_mmx:--enable-arch-asm} \
-       %{!?_without_alsa:--enable-alsa} \
-       --enable-sdl \
-       --enable-vorbis \
-       --enable-smpeg \
+       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
+       --enable-sdl --enable-sdl-dlopen \
        --enable-capture \
-       --with-gcc=%{__cc}                          
+       --enable-linux \
+       --enable-null \
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc=%{__cc}
 
 %{__make}
 
-cd ../docs
-%{!?_without_doc:%{__make} full-html}
-
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_infodir}
 
-cd openal/linux
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun        devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
 %files
 %defattr(644,root,root,755)
-%doc openal/linux/{CREDITS,ChangeLog,NOTES,TODO}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc openal/linux/doc/LOKI* %{!?_without_doc:openal/docs/oalspecs-full}
+%attr(755,root,root) %{_bindir}/*-config
 %attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/*.la
+%{_pkgconfigdir}/*
 %{_includedir}/AL
-%{_infodir}/openal.info*
 
 %files static
 %defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/*.a
+%{_libdir}/*.a
This page took 0.091319 seconds and 4 git commands to generate.