]> git.pld-linux.org Git - packages/Atari800.git/blobdiff - Atari800.spec
- release 2.
[packages/Atari800.git] / Atari800.spec
index f9dadcc5c3427ec9dc4030a6a0fd7d94606c332c..5b05f7a5e1253c8d92922d50f68d83dc402e4219 100644 (file)
@@ -1,24 +1,25 @@
 #
 # Conditional build:
 # _with_license_agreement - with unzipped ROM files instead of xf25.zip
-
+# _without_svgalib       - without SVGA version
+#
 Summary:       Atari 800 Emulator
 Summary(pl):   Emulator Atari 800
 Name:          Atari800
 Version:       1.2.2
-Release:       1
+Release:       2
 License:       GPL (Atari800), distributable if unmodified (xf25 with ROMs)
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
-Source0:       http://prdownloads.sourceforge.new/projects/atari800/atari800-%{version}.tar.gz
+Source0:       ftp://ftp.sourceforge.net/pub/sourceforge/atari800/atari800-%{version}.tar.gz
 # NOTE: ROMs probably can be redistributed only in original XF25 archive
 Source1:       http://joy.sophics.cz/www/xf25.zip
 Source2:       %{name}-chooser
 Patch0:                %{name}-shm_fix.patch
 URL:           http://atari800.atari.org/
 BuildRequires: unzip
-BuildRequires: svgalib-devel
+%ifarch %{ix86}
+%{!?_without_svgalib:BuildRequires:    svgalib-devel}
+%endif
 BuildRequires: XFree86-devel
 BuildRequires: zlib-devel
 BuildRequires: SDL-devel
@@ -36,8 +37,6 @@ To jest emulator Atari 800, 800XL, 130XE i 5200.
 Summary:       Atari 800 Emulator - common files for svgalib and X11 versions
 Summary(pl):   Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 Obsoletes:     Atari800
 %{!?_with_license_agreement:Prereq:    unzip}
 
@@ -67,8 +66,6 @@ Summary:      Atari 800 Emulator - svgalib version
 Summary(pl):   Emulator Atari 800 - wersja pod svgalib
 License:       GPL
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 Requires:      %{name}-common = %{version}
 
 %description svga
@@ -88,8 +85,6 @@ Summary:      Atari 800 Emulator - X Window version
 Summary(pl):   Emulator Atari 800 - wersja pod X Window
 License:       GPL
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 Requires:      %{name}-common = %{version}
 
 %description x11
@@ -109,8 +104,6 @@ Summary:    Atari 800 Emulator - SDL version
 Summary(pl):   Emulator Atari 800 - wersja pod SDL
 License:       GPL
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 Requires:      %{name}-common = %{version}
 
 %description SDL
@@ -132,6 +125,9 @@ obs
 %build
 cd src
 
+%if %{?_without_svgalib:0}%{!?_without_svgalib:1}
+%ifarch %{ix86}
+
 %configure2_13 --target=svgalib \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
@@ -162,6 +158,8 @@ cd src
 mv -f atari800 atari800-svga
 
 %{__make} clean
+%endif
+%endif
 
 %configure2_13 --target=sdl \
        --disable-VERY_SLOW \
@@ -189,6 +187,8 @@ mv -f atari800 atari800-svga
        LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
 mv -f atari800 atari800-SDL
 
+%{__make} clean
+
 %configure2_13 --target=x11-shm \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
@@ -212,8 +212,6 @@ mv -f atari800 atari800-SDL
        LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
 mv -f atari800 atari800-x11
 
-%{__make} clean
-
 sed s@/usr/local/lib/atari@%{_datadir}/atari800@g atari800.man >atari800.1
 
 %install
@@ -221,7 +219,9 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_xbindir}} \
        $RPM_BUILD_ROOT{%{_datadir}/atari800,%{_mandir}/man1}
 
-install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
+%ifarch %{ix86}
+%{!?_without_svgalib:install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}}
+%endif
 install src/atari800-x11 $RPM_BUILD_ROOT%{_xbindir}
 install src/atari800-SDL $RPM_BUILD_ROOT%{_xbindir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
@@ -253,10 +253,6 @@ unzip -q -L xf25.zip
 %{_mandir}/man1/atari800.1*
 %attr(755,root,root) %{_bindir}/atari800
 
-%files svga
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/atari800-svga
-
 %files x11
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_xbindir}/atari800-x11
@@ -264,3 +260,11 @@ unzip -q -L xf25.zip
 %files SDL
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_xbindir}/atari800-SDL
+
+%ifarch %{ix86}
+%if %{?_without_svgalib:0}%{!?_without_svgalib:1}
+%files svga
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/atari800-svga
+%endif
+%endif
This page took 0.076468 seconds and 4 git commands to generate.