]> git.pld-linux.org Git - packages/ApacheJServ.git/blobdiff - ApacheJServ.spec
perl -pi -e "s/^automake -a -c -f --foreing/\%\{__automake\}/; \
[packages/ApacheJServ.git] / ApacheJServ.spec
index b258ba028d6746b294719072a493ceb96591f4cb..547798ed0e760d05cc37ab065a5198de3c83f197 100644 (file)
 %define jsdkversion 20000924
 
 Summary:       Servlet engine with support for the leading web server
+Summary(pl):   Silnik serwletów ze wsparciem dla wiod±cego serwera WWW
 Name:          ApacheJServ
 Version:       1.1
 Release:       3
 Source0:       http://java.apache.org/jserv/dist/%{name}-%{version}.tar.gz
 Source1:       http://www.euronet.nl/~pauls/java/servlet/download/classpathx_servlet-%{jsdkversion}.tar.gz
-Patch0:                ApacheJServ-enable-secret.patch
-Patch1:                ApacheJServ-DESTDIR.patch
+Patch0:                %{name}-enable-secret.patch
+Patch1:                %{name}-DESTDIR.patch
 URL:           http://java.apache.org/
-Copyright:     Freely distributable & usable
+License:       freely distributable & usable
 Group:         Networking/Daemons
-Group(pl):     Sieciowe/Serwery
 Requires:      apache >= 1.3.6
 Provides:      jserv jsdk20
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -30,7 +30,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildRequires: automake     >= 1.4
 BuildRequires: autoconf     >= 2.13
-BuildRequires: libtool      >= 1.3.3 
+BuildRequires: libtool      >= 1.3.3
 BuildRequires: apache-devel >= 1.3.9-8
 
 %description
@@ -43,13 +43,14 @@ a LGPL'ed implementation of sun's java servlet api version 2.0 by Paul
 Siegmann <http://www.euronet.nl/~pauls/java/servlet/>
 
 %description -l pl
-Apache JServ jest silnikiem serwletowym, rozwijanym przez Java Apache Project
-<http://java.apache.org/>. Silnik serwletowy Apache JServ zosta³ napisany
-od pocz±tku do koñca w Javie; nas³uchuje wywo³añ serwletu wykorzystuj±c
-protokó³ Apache Java (AJp). Zazwyczaj wywo³ania te pochodz± z modu³u
-Apache mod_jservmodule (³±cznie z DSO). Pakiet ten zawiera sunowsk±
-implementacjê api serletów w javie w wersji 2.0 (na licencji LGPL)
-napisana przez Paula Siegmanna <http://www.euronet.nl/~pauls/java/servlet/>
+Apache JServ jest silnikiem serwletowym, rozwijanym przez Java Apache
+Project <http://java.apache.org/>. Silnik serwletowy Apache JServ
+zosta³ napisany od pocz±tku do koñca w Javie; nas³uchuje wywo³añ
+serwletu wykorzystuj±c protokó³ Apache Java (AJp). Zazwyczaj wywo³ania
+te pochodz± z modu³u Apache mod_jservmodule (³±cznie z DSO). Pakiet
+ten zawiera sunowsk± implementacjê api serletów w javie w wersji 2.0
+(na licencji LGPL) napisana przez Paula Siegmanna
+<http://www.euronet.nl/~pauls/java/servlet/>
 
 %prep
 %setup -q -a 1
@@ -57,7 +58,7 @@ napisana przez Paula Siegmanna <http://www.euronet.nl/~pauls/java/servlet/>
 %patch0
 %patch1 -p1
 
-# final position of GNU JSDK-Classes 
+# final position of GNU JSDK-Classes
 sed 's|@JSDK_CLASSES@|%{classesdir}/servlet-2.0.jar|g' \
     < conf/jserv.properties.in  > conf/jserv.properties.in.new
 mv conf/jserv.properties.in.new conf/jserv.properties.in
@@ -70,8 +71,8 @@ mv conf/jserv.conf.in.new conf/jserv.conf.in
 %build
 # prepare compilation
 aclocal
-autoconf
-automake -a -c
+%{__autoconf}
+%{__automake}
 
 %{__make} -C classpathx_servlet-%{jsdkversion} jar_2_0
 %{__make} -C classpathx_servlet-%{jsdkversion}/apidoc
@@ -87,11 +88,11 @@ cp -r classpathx_servlet-%{jsdkversion}/apidoc jsdk-doc
 ### JSERV
 
 APXS_CFLAGS=`$APXS_UTIL -q CFLAGS`
-CFLAGS="$APXS_CFLAGS $RPM_OPT_FLAGS" ./configure \
-       --prefix=%{_prefix}          \
-       --disable-debugging           \
-       --with-apxs=/usr/bin/apxs \
-       --with-logdir=%{logdir}       \
+CFLAGS="$APXS_CFLAGS %{rpmcflags}" ./configure \
+       --prefix=%{_prefix} \
+       --disable-debugging \
+       --with-apxs=/usr/sbin/apxs \
+       --with-logdir=%{logdir} \
        --with-servlets=%{servletdir} \
        --with-JSDK=`pwd`/classpathx_servlet-%{jsdkversion}/servlet-2.0.jar
 %{__make}
@@ -125,7 +126,7 @@ rm -rf $RPM_BUILD_ROOT
 # guessable secret key. Use md5sum to create a hash from this, if available:
 (%{_prefix}/games/fortune 2>/dev/null ; date ; ps -eal 2>/dev/null)   \
                    | (md5sum 2>/dev/null || cat)               \
-                   > %{jservconf}/jserv.secret.key 
+                   > %{jservconf}/jserv.secret.key
 chmod 600 %{jservconf}/jserv.secret.key
 
 #
@@ -135,7 +136,7 @@ APACHEUSER=`grep "^User[     ]\+" %{httpdconf}/httpd.conf | awk '{print $2}'`
 if test ! "x$APACHEUSER" = x ; then
    USERCOMMENT="(which is '$APACHEUSER' ?)"
 else
-   # assumption:       
+   # assumption:
    APACHEUSER=nobody
 fi
 chown $APACHEUSER %{jservconf}/jserv.secret.key
@@ -168,7 +169,7 @@ if test $? -eq 0 ; then
        > %{httpdconf}/httpd.conf
 else
    # append it
-   ( 
+   (
      echo "<IfModule mod_jserv.c>"
      echo "         Include %{jservconf}/jserv.conf"
      echo "</IfModule>"
This page took 0.054731 seconds and 4 git commands to generate.