]> git.pld-linux.org Git - packages/ApacheJServ.git/blobdiff - ApacheJServ.spec
- fix improper usage of %%{_sysconfdir}
[packages/ApacheJServ.git] / ApacheJServ.spec
index aea1855eb998a02e2952132c9901ab4594b5b863..1d5398b9a1a926f2e2a1c4dc9d19a2f85ae065c5 100644 (file)
@@ -20,7 +20,7 @@ Source1:      http://www.euronet.nl/~pauls/java/servlet/download/classpathx_servlet-%
 Patch0:                %{name}-enable-secret.patch
 Patch1:                %{name}-DESTDIR.patch
 URL:           http://java.apache.org/
-License:       Freely distributable & usable
+License:       freely distributable & usable
 Group:         Networking/Daemons
 Requires:      apache >= 1.3.6
 Provides:      jserv jsdk20
@@ -30,7 +30,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildRequires: automake     >= 1.4
 BuildRequires: autoconf     >= 2.13
-BuildRequires: libtool      >= 1.3.3 
+BuildRequires: libtool      >= 1.3.3
 BuildRequires: apache-devel >= 1.3.9-8
 
 %description
@@ -58,7 +58,7 @@ ten zawiera sunowsk
 %patch0
 %patch1 -p1
 
-# final position of GNU JSDK-Classes 
+# final position of GNU JSDK-Classes
 sed 's|@JSDK_CLASSES@|%{classesdir}/servlet-2.0.jar|g' \
     < conf/jserv.properties.in  > conf/jserv.properties.in.new
 mv conf/jserv.properties.in.new conf/jserv.properties.in
@@ -70,9 +70,10 @@ mv conf/jserv.conf.in.new conf/jserv.conf.in
 
 %build
 # prepare compilation
-aclocal
-autoconf
-automake -a -c
+rm -f missing
+%{__aclocal}
+%{__autoconf}
+%{__automake}
 
 %{__make} -C classpathx_servlet-%{jsdkversion} jar_2_0
 %{__make} -C classpathx_servlet-%{jsdkversion}/apidoc
@@ -89,10 +90,10 @@ cp -r classpathx_servlet-%{jsdkversion}/apidoc jsdk-doc
 
 APXS_CFLAGS=`$APXS_UTIL -q CFLAGS`
 CFLAGS="$APXS_CFLAGS %{rpmcflags}" ./configure \
-       --prefix=%{_prefix}          \
-       --disable-debugging           \
+       --prefix=%{_prefix} \
+       --disable-debugging \
        --with-apxs=/usr/sbin/apxs \
-       --with-logdir=%{logdir}       \
+       --with-logdir=%{logdir} \
        --with-servlets=%{servletdir} \
        --with-JSDK=`pwd`/classpathx_servlet-%{jsdkversion}/servlet-2.0.jar
 %{__make}
@@ -106,10 +107,10 @@ echo "default - change on install `date`" > $RPM_BUILD_ROOT/%{jservconf}/jserv.s
 chmod 600 $RPM_BUILD_ROOT/%{jservconf}/jserv.secret.key
 
 # currently disabled
-#install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
+#install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 #install -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
 #install -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
-#install -m755 src/scripts/package/rpm/jserv.init      $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/jserv
+#install -m755 src/scripts/package/rpm/jserv.init      $RPM_BUILD_ROOT/etc/rc.d/init.d/jserv
 #install -m755 src/scripts/package/rpm/jserv.sh        $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
 #install -m644 src/scripts/package/rpm/jserv.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/jserv
 
@@ -126,7 +127,7 @@ rm -rf $RPM_BUILD_ROOT
 # guessable secret key. Use md5sum to create a hash from this, if available:
 (%{_prefix}/games/fortune 2>/dev/null ; date ; ps -eal 2>/dev/null)   \
                    | (md5sum 2>/dev/null || cat)               \
-                   > %{jservconf}/jserv.secret.key 
+                   > %{jservconf}/jserv.secret.key
 chmod 600 %{jservconf}/jserv.secret.key
 
 #
@@ -136,7 +137,7 @@ APACHEUSER=`grep "^User[     ]\+" %{httpdconf}/httpd.conf | awk '{print $2}'`
 if test ! "x$APACHEUSER" = x ; then
    USERCOMMENT="(which is '$APACHEUSER' ?)"
 else
-   # assumption:       
+   # assumption:
    APACHEUSER=nobody
 fi
 chown $APACHEUSER %{jservconf}/jserv.secret.key
@@ -169,7 +170,7 @@ if test $? -eq 0 ; then
        > %{httpdconf}/httpd.conf
 else
    # append it
-   ( 
+   (
      echo "<IfModule mod_jserv.c>"
      echo "         Include %{jservconf}/jserv.conf"
      echo "</IfModule>"
@@ -342,7 +343,7 @@ sed 's|.*\(Include.*%{jservconf}/jserv.conf\)|#\1|g' \
 #%{jservconf}/jserv.conf.default
 
 %attr(-,nobody,nobody) %{jservconf}/jserv.secret.key
-#%config %{_sysconfdir}/rc.d/init.d/jserv
+#%config /etc/rc.d/init.d/jserv
 #%config %{_sysconfdir}/logrotate.d/jserv
 #%config %{_sysconfdir}/profile.d/jserv.sh
 
This page took 0.045624 seconds and 4 git commands to generate.