]> git.pld-linux.org Git - packages/ApacheJServ.git/blobdiff - ApacheJServ.spec
- fix improper usage of %%{_sysconfdir}
[packages/ApacheJServ.git] / ApacheJServ.spec
index 8710cdc1073b63fa2aea625b3270c00d7bf1d7ea..1d5398b9a1a926f2e2a1c4dc9d19a2f85ae065c5 100644 (file)
@@ -8,20 +8,20 @@
 %define logdir    /var/log/httpd
 %define servletdir /home/httpd/servlets
 %define classesdir /home/httpd/classes
-%define jsdkversion 19991120
+%define jsdkversion 20000924
 
 Summary:       Servlet engine with support for the leading web server
+Summary(pl):   Silnik serwletów ze wsparciem dla wiod±cego serwera WWW
 Name:          ApacheJServ
 Version:       1.1
 Release:       3
 Source0:       http://java.apache.org/jserv/dist/%{name}-%{version}.tar.gz
-Source1:       http://www.euronet.nl/~pauls/java/servlet/download/%{version}%{name}classpathx_servlet-%{jsdkversion}.tar.gz
-Patch0:                ApacheJServ-enable-secret.patch
-Patch1:                ApacheJServ-DESTDIR.patch
+Source1:       http://www.euronet.nl/~pauls/java/servlet/download/classpathx_servlet-%{jsdkversion}.tar.gz
+Patch0:                %{name}-enable-secret.patch
+Patch1:                %{name}-DESTDIR.patch
 URL:           http://java.apache.org/
-Copyright:     Freely distributable & usable
+License:       freely distributable & usable
 Group:         Networking/Daemons
-Group(pl):     Sieciowe/Serwery
 Requires:      apache >= 1.3.6
 Provides:      jserv jsdk20
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -30,7 +30,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildRequires: automake     >= 1.4
 BuildRequires: autoconf     >= 2.13
-BuildRequires: libtool      >= 1.3.3 
+BuildRequires: libtool      >= 1.3.3
 BuildRequires: apache-devel >= 1.3.9-8
 
 %description
@@ -42,14 +42,23 @@ from the mod_jserv Apache module (DSO included). This package contains
 a LGPL'ed implementation of sun's java servlet api version 2.0 by Paul
 Siegmann <http://www.euronet.nl/~pauls/java/servlet/>
 
+%description -l pl
+Apache JServ jest silnikiem serwletowym, rozwijanym przez Java Apache
+Project <http://java.apache.org/>. Silnik serwletowy Apache JServ
+zosta³ napisany od pocz±tku do koñca w Javie; nas³uchuje wywo³añ
+serwletu wykorzystuj±c protokó³ Apache Java (AJp). Zazwyczaj wywo³ania
+te pochodz± z modu³u Apache mod_jservmodule (³±cznie z DSO). Pakiet
+ten zawiera sunowsk± implementacjê api serletów w javie w wersji 2.0
+(na licencji LGPL) napisana przez Paula Siegmanna
+<http://www.euronet.nl/~pauls/java/servlet/>
+
 %prep
-rm -rf $RPM_BUILD_ROOT
 %setup -q -a 1
 
 %patch0
 %patch1 -p1
 
-# final position of GNU JSDK-Classes 
+# final position of GNU JSDK-Classes
 sed 's|@JSDK_CLASSES@|%{classesdir}/servlet-2.0.jar|g' \
     < conf/jserv.properties.in  > conf/jserv.properties.in.new
 mv conf/jserv.properties.in.new conf/jserv.properties.in
@@ -59,14 +68,15 @@ sed 's|@LOAD_OR_NOT@|#|g' \
     < conf/jserv.conf.in  > conf/jserv.conf.in.new
 mv conf/jserv.conf.in.new conf/jserv.conf.in
 
+%build
 # prepare compilation
-aclocal
-autoconf
-automake
+rm -f missing
+%{__aclocal}
+%{__autoconf}
+%{__automake}
 
-%build
-make -C classpathx_servlet-%{jsdkversion} jar_2_0
-make -C classpathx_servlet-%{jsdkversion}/apidoc
+%{__make} -C classpathx_servlet-%{jsdkversion} jar_2_0
+%{__make} -C classpathx_servlet-%{jsdkversion}/apidoc
 
 # copy API-doc
 mkdir jsdk-doc
@@ -78,68 +88,29 @@ cp -r classpathx_servlet-%{jsdkversion}/apidoc jsdk-doc
 
 ### JSERV
 
-# find apxs utility ..
-# .. in PATH
-APXS_UTIL=`type -p apxs || true`
-
-# .. from RPM
-if test "x$APXS_UTIL" = x ; then
-  # mmh, is it possible to query just for
-  # the executeables  (like -qd and -qc) ?
-  APXSMATCH=`rpm -ql apache-devel apache | grep apxs`
-  for f in $APXSMATCH ; do
-    if test -x "$f"  ; then
-       APXS_UTIL=$f
-       break
-    fi
-  done
-fi
-
-# .. at usual places
-if test "x$APXS_UTIL" = x ; then
-   for loc in \
-    %{_bindir}               \
-    %{_sbindir}              \
-    %{_prefix}/local/apache/bin  \
-    %{_prefix}/local/apache/sbin \
-    %{_prefix}/local/httpd/bin   \
-    %{_prefix}/local/httpd/sbin 
-  do
-    if test -x "$loc/apxs" ; then
-       APXS_UTIL="$loc/apxs"
-       break
-    fi
-  done
-fi
-
-if test "x$APXS_UTIL" = x ; then
-   echo "Didn't find apxs .. exiting"
-   exit -1
-fi
-
 APXS_CFLAGS=`$APXS_UTIL -q CFLAGS`
-CFLAGS="$APXS_CFLAGS $RPM_OPT_FLAGS" ./configure \
-       --prefix=%{_prefix}          \
-       --disable-debugging           \
-       --with-apxs=$APXS_UTIL        \
-       --with-logdir=%{logdir}       \
+CFLAGS="$APXS_CFLAGS %{rpmcflags}" ./configure \
+       --prefix=%{_prefix} \
+       --disable-debugging \
+       --with-apxs=/usr/sbin/apxs \
+       --with-logdir=%{logdir} \
        --with-servlets=%{servletdir} \
        --with-JSDK=`pwd`/classpathx_servlet-%{jsdkversion}/servlet-2.0.jar
-make
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make DESTDIR=$RPM_BUILD_ROOT install
+%{__make} DESTDIR=$RPM_BUILD_ROOT install
 
 echo "default - change on install `date`" > $RPM_BUILD_ROOT/%{jservconf}/jserv.secret.key
 chmod 600 $RPM_BUILD_ROOT/%{jservconf}/jserv.secret.key
 
 # currently disabled
-#install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
+#install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 #install -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
 #install -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
-#install -m755 src/scripts/package/rpm/jserv.init      $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/jserv
+#install -m755 src/scripts/package/rpm/jserv.init      $RPM_BUILD_ROOT/etc/rc.d/init.d/jserv
 #install -m755 src/scripts/package/rpm/jserv.sh        $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
 #install -m644 src/scripts/package/rpm/jserv.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/jserv
 
@@ -156,7 +127,7 @@ rm -rf $RPM_BUILD_ROOT
 # guessable secret key. Use md5sum to create a hash from this, if available:
 (%{_prefix}/games/fortune 2>/dev/null ; date ; ps -eal 2>/dev/null)   \
                    | (md5sum 2>/dev/null || cat)               \
-                   > %{jservconf}/jserv.secret.key 
+                   > %{jservconf}/jserv.secret.key
 chmod 600 %{jservconf}/jserv.secret.key
 
 #
@@ -166,7 +137,7 @@ APACHEUSER=`grep "^User[     ]\+" %{httpdconf}/httpd.conf | awk '{print $2}'`
 if test ! "x$APACHEUSER" = x ; then
    USERCOMMENT="(which is '$APACHEUSER' ?)"
 else
-   # assumption:       
+   # assumption:
    APACHEUSER=nobody
 fi
 chown $APACHEUSER %{jservconf}/jserv.secret.key
@@ -199,7 +170,7 @@ if test $? -eq 0 ; then
        > %{httpdconf}/httpd.conf
 else
    # append it
-   ( 
+   (
      echo "<IfModule mod_jserv.c>"
      echo "         Include %{jservconf}/jserv.conf"
      echo "</IfModule>"
@@ -372,7 +343,7 @@ sed 's|.*\(Include.*%{jservconf}/jserv.conf\)|#\1|g' \
 #%{jservconf}/jserv.conf.default
 
 %attr(-,nobody,nobody) %{jservconf}/jserv.secret.key
-#%config %{_sysconfdir}/rc.d/init.d/jserv
+#%config /etc/rc.d/init.d/jserv
 #%config %{_sysconfdir}/logrotate.d/jserv
 #%config %{_sysconfdir}/profile.d/jserv.sh
 
This page took 0.062741 seconds and 4 git commands to generate.