]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- rebuild with icu 58.2
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  flite                   # Flite synthesizer driver
16 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
17 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
18 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
19 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
20 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
21 %bcond_with     at_spi                  # AtSpi screen driver
22 %bcond_without  at_spi2                 # AtSpi2 screen driver
23
24 %define         brlapi_ver      0.6.5
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        5.4
30 Release:        3
31 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
32 Group:          Daemons
33 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
34 # Source0-md5:  cfedd365e6237d762ad8c35b4f6fb361
35 Patch1:         %{name}-speech-dispatcher.patch
36 Patch2:         %{name}-python.patch
37 URL:            http://mielke.cc/brltty/
38 BuildRequires:  alsa-lib-devel
39 %{?with_at_spi:BuildRequires:   at-spi-devel}
40 BuildRequires:  autoconf >= 2.64
41 BuildRequires:  automake
42 BuildRequires:  bison
43 BuildRequires:  rpmbuild(macros) >= 1.710
44 # just headers
45 BuildRequires:  bluez-libs-devel
46 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
47 %{?with_apidocs:BuildRequires:  doxygen}
48 %{?with_espeak:BuildRequires:   espeak-devel}
49 %{?with_flite:BuildRequires:    flite-devel}
50 %{?with_gpm:BuildRequires:      gpm-devel}
51 %{?with_java:BuildRequires:     jdk}
52 %{?with_java:BuildRequires:     jpackage-utils}
53 %{?with_libbraille:BuildRequires:       libbraille-devel}
54 BuildRequires:  libicu-devel
55 BuildRequires:  ncurses-devel
56 %{?with_ocaml:BuildRequires:    ocaml}
57 BuildRequires:  pkgconfig
58 %{?with_python:BuildRequires:   python-Cython}
59 %{?with_python3:BuildRequires:  python3-Cython}
60 %{?with_java:BuildRequires:     rpm-javaprov}
61 %{?with_python:BuildRequires:   rpm-pythonprov}
62 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
63 BuildRequires:  tar >= 1:1.22
64 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
65 %if %{with x}
66 BuildRequires:  xorg-lib-libX11-devel
67 BuildRequires:  xorg-lib-libXaw-devel
68 BuildRequires:  xorg-lib-libXext-devel
69 BuildRequires:  xorg-lib-libXt-devel
70 BuildRequires:  xorg-lib-libXtst-devel
71 %endif
72 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
73 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
74 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
75 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
76 BuildRequires:  xz
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 BRLTTY is a background process (daemon) which provides access to the
81 Linux/Unix console (when in text mode) for a blind person using a
82 refreshable Braille display. It drives the Braille display, and
83 provides complete screen review functionality. Some speech capability
84 has also been incorporated.
85
86 %description -l pl.UTF-8
87 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
88 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
89 odświeżaniem (refreshable Braille display). BRLTTY steruje
90 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
91 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
92 mowy.
93
94 %package -n brlapi
95 Summary:        Application Programming Interface for BRLTTY
96 Summary(pl.UTF-8):      API do BRLTTY
97 License:        LGPL v2.1+
98 Group:          Libraries
99
100 %description -n brlapi
101 This package provides the run-time support for the Application
102 Programming Interface to BRLTTY.
103
104 Install this package if you have an application which directly
105 accesses a refreshable Braille display.
106
107 %description -n brlapi -l pl.UTF-8
108 Ten pakiet zawiera środowisko uruchomieniowe dla programów
109 korzystających z API BRLTTY.
110
111 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
112 wyświetlacza Braille'a z odświeżaniem.
113
114 %package -n brlapi-devel
115 Summary:        Headers and documentation for BrlAPI
116 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
117 License:        LGPL v2.1+
118 Group:          Development/Libraries
119 Requires:       brlapi = %{version}-%{release}
120
121 %description -n brlapi-devel
122 This package provides the header files, shared object linker
123 reference, and reference documentation for BrlAPI (the Application
124 Programming Interface to BRLTTY). It enables the implementation of
125 applications which take direct advantage of a refreshable Braille
126 display in order to present information in ways which are more
127 appropriate for blind users and/or to provide user interfaces which
128 are more specifically atuned to their needs.
129
130 Install this package if you're developing or maintaining an
131 application which directly accesses a refreshable Braille display.
132
133 %description -n brlapi-devel -l pl.UTF-8
134 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
135 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
136 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
137 bardziej przystosowany dla osób niewidomych.
138
139 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
140 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
141
142 %package -n brlapi-static
143 Summary:        Static BrlAPI library
144 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
145 License:        LGPL v2.1+
146 Group:          Development/Libraries
147 Requires:       brlapi-devel = %{version}-%{release}
148
149 %description -n brlapi-static
150 This is package with static BrlAPI library.
151
152 %description -n brlapi-static -l pl.UTF-8
153 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
154
155 %package -n brlapi-apidocs
156 Summary:        BrlAPI documentation
157 Summary(pl.UTF-8):      Documentacja BrlAPI
158 Group:          Documentation
159 %if "%{_rpmversion}" >= "5"
160 BuildArch:      noarch
161 %endif
162
163 %description -n brlapi-apidocs
164 Documentation for BrlAPI in HTML format generated from brltty sources
165 by doxygen.
166
167 %description -n brlapi-apidocs -l pl.UTF-8
168 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
169 doxygen.
170
171 %package -n java-brlapi
172 Summary:        BrlAPI library for Java
173 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
174 License:        LGPL v2.1+
175 Group:          Libraries
176 Requires:       brlapi = %{version}-%{release}
177
178 %description -n java-brlapi
179 BrlAPI library for Java.
180
181 %description -n java-brlapi -l pl.UTF-8
182 Biblioteka BrlAPI dla Javy.
183
184 %package -n ocaml-brlapi
185 Summary:        OCaml binding for BrlAPI
186 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
187 License:        LGPL v2.1+
188 Group:          Libraries
189 Requires:       brlapi = %{version}-%{release}
190 %requires_eq    ocaml-runtime
191
192 %description -n ocaml-brlapi
193 OCaml binding for BrlAPI.
194
195 %description -n ocaml-brlapi -l pl.UTF-8
196 Wiązania OCamla do BrlAPI.
197
198 %package -n ocaml-brlapi-devel
199 Summary:        OCaml binding for BrlAPI - development files
200 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
201 License:        LGPL v2.1+
202 Group:          Libraries
203 Requires:       ocaml-brlapi = %{version}-%{release}
204 %requires_eq    ocaml
205
206 %description -n ocaml-brlapi-devel
207 OCaml binding for BrlAPI - development files.
208
209 %description -n ocaml-brlapi-devel -l pl.UTF-8
210 Wiązania OCamla do BrlAPI - pliki programistyczne.
211
212 %package -n python-brlapi
213 Summary:        Python 2.x interface to BrlAPI
214 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
215 License:        LGPL v2.1+
216 Group:          Libraries
217 Requires:       brlapi = %{version}-%{release}
218
219 %description -n python-brlapi
220 Python 2.x interface to BrlAPI.
221
222 %description -n python-brlapi -l pl.UTF-8
223 Interfejs Pythona 2.x do BrlAPI.
224
225 %package -n python3-brlapi
226 Summary:        Python 3.x interface to BrlAPI
227 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
228 License:        LGPL v2.1+
229 Group:          Libraries
230 Requires:       brlapi = %{version}-%{release}
231
232 %description -n python3-brlapi
233 Python 3.x interface to BrlAPI.
234
235 %description -n python3-brlapi -l pl.UTF-8
236 Interfejs Pythona 3.x do BrlAPI.
237
238 %package -n brlapi-tcl
239 Summary:        BrlAPI library for Tcl
240 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
241 License:        LGPL v2.1+
242 Group:          Libraries
243 Requires:       brlapi = %{version}-%{release}
244
245 %description -n brlapi-tcl
246 BrlAPI library for Tcl.
247
248 %description -n brlapi-tcl -l pl.UTF-8
249 Biblioteka BrlAPI dla Tcl.
250
251 %prep
252 %setup -q
253 %patch1 -p1
254 %patch2 -p1
255
256 %build
257 %{__autoconf}
258 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
259 %configure \
260         %{?with_java:JAVA_HOME=%{java_home}} \
261         --with-install-root="$RPM_BUILD_ROOT" \
262         %{!?with_libbraille:--without-libbraille} \
263         %{!?with_espeak:--without-espeak} \
264         %{!?with_flite:--without-flite} \
265         %{!?with_speech_dispatcher:--without-speechd} \
266         %{!?with_ocaml:--disable-caml-bindings} \
267         %{!?with_gpm:--disable-gpm} \
268         %{!?with_java:--disable-java-bindings} \
269         %{!?with_python:--disable-python-bindings} \
270         %{!?with_tcl:--disable-tcl-bindings} \
271         %{!?with_x:--disable-x} \
272         --enable-api
273
274 %{__make} -j1
275
276 %if %{with python}
277 cd Bindings/Python
278 %py_build
279 cd ../..
280 %endif
281
282 %if %{with python3}
283 cd Bindings/Python
284 %py3_build
285 cd ../..
286 %endif
287
288 %install
289 rm -rf $RPM_BUILD_ROOT
290
291 %{__make} -j1 install \
292         OCAML_INSTALL_TARGET=install-without-findlib
293
294 # findlib-specific, useless in rpm
295 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
296
297 %if %{with python}
298 cd Bindings/Python
299 %py_install
300 cd ../..
301 %endif
302
303 %if %{with python3}
304 cd Bindings/Python
305 %py3_install
306 cd ../..
307 %endif
308
309 %if %{_lib} != "lib"
310         # Fix java plugin install path on 64-bit archs
311         install -d $RPM_BUILD_ROOT%{_libdir}/java
312         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
313 %endif
314
315 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
316
317 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
318 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
319 d /var/run/brltty 0755 root root -
320 EOF
321
322 # no sign in source wheter it is zh_CN or zh_TW so just remove it
323 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh
324
325 %find_lang %{name}
326
327 %clean
328 rm -rf $RPM_BUILD_ROOT
329
330 %pre
331 # The pre-install scriptlet.
332
333 # If a configuration file already exists then rpm installs the new one as
334 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
335 # already exists.
336
337 # There's no explicit way to tell if a configuration file has been installed
338 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
339 # erasing the .rpmnew file now so that we can see if it gets created later.
340 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
341
342 %post
343 # The post-install scriptlet.
344
345 # If BRLTTY's boot parameter has been specified then update the just installed
346 # configuration file template to reflect the options supplied thereby.
347
348 # First, we need to determine which file to update. If there's a .rpmnew file
349 # then update it since a previous configuration file must already have existed.
350 file="%{_sysconfdir}/brltty.conf"
351 new="${file}.rpmnew"
352 [ -f "${new}" ] && file="${new}"
353
354 # Update the configuration file template via the Bootdisks/bp2cf script.
355 # Include it right within this scriptlet so that it needn't be installed.
356 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
357 (
358         # First, set bp2cf's command line arguments.
359         set -- -u -f "${file}"
360
361 #!/bin/sh
362 ###############################################################################
363 # BRLTTY - A background process providing access to the Linux console (when in
364 #          text mode) for a blind person using a refreshable Braille display.
365 #
366 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
367 #
368 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
369 #
370 # This is free software, placed under the terms of the
371 # GNU General Public License, as published by the Free Software
372 # Foundation.  Please see the file COPYING for details.
373 #
374 # Web Page: http://mielke.cc/brltty/
375 #
376 # This software is maintained by Dave Mielke <dave@mielke.cc>.
377 ###############################################################################
378
379 # Convert the boot parameter to configuration file directives.
380 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
381 # If /proc is not mounted then use the brltty environment variable.
382 # Invoke with -h for usage information.
383
384 programName="${0##*/}"
385 programMessage()
386 {
387         echo 2>&1 "${programName}: ${1}"
388 }
389 syntaxError()
390 {
391         programMessage "${1}"
392         exit 2
393 }
394 internalError()
395 {
396         programMessage "${1}"
397         exit 3
398 }
399
400 configurationFile=""
401 requestedAction=create
402 deviceTranslation=none
403 requestedParameter=""
404 OPTIND=1
405 while getopts ":f:cundop:h" option
406 do
407         case "${option}" in
408             f) configurationFile="${OPTARG}";;
409             c) requestedAction=create;;
410             u) requestedAction=update;;
411             n) deviceTranslation=none;;
412             d) deviceTranslation=devfs;;
413             o) deviceTranslation=old;;
414             p) requestedParameter="${OPTARG}";;
415             h)
416                 cat <<EOF
417 Usage: ${programName} [option ...]
418 -f file  The configuration file to create/update.
419 -c       Create the configuration file (write to stdout if no -f).
420 -u       Update the configuration file (copying from stdin to stdout if no -f).
421 -n       Do not translate device paths.
422 -d       Do old-style to devfs device path translation.
423 -o       Do devfs to old-style device path translation.
424 -p [driver][,[device][,[table]]]
425          Explicitly specify the boot parameter.
426 -h       Display this usage summary.
427 EOF
428                 exit 0
429                 ;;
430             \?) syntaxError "unknown option: -${OPTARG}";;
431             :) syntaxError "missing value: -${OPTARG}";;
432             *) internalError "unimplemented option: -${option}";;
433         esac
434 done
435 shift "`expr $OPTIND - 1`"
436 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
437
438 case "${requestedAction}" in
439     create)
440         putConfigurationLine()
441         {
442                 echo "${1}" || exit 4
443         }
444         startConfigurationFile()
445         {
446                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
447                 putConfigurationLine "`makeHeaderLine Created`"
448                 putConfigurationLine "`makeParameterLine`"
449                 putConfigurationLine ""
450         }
451         putConfigurationDirective()
452         {
453                 putConfigurationLine "${1} ${2}"
454         }
455         finalizeConfigurationFile()
456         {
457                 :
458         }
459         ;;
460     update)
461         putSedCommand()
462         {
463                 sedScript="${sedScript}
464 ${1}"
465         }
466         startConfigurationFile()
467         {
468                 if [ -n "${configurationFile}" ]; then
469                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
470                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
471                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
472                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
473                         outputFile="${configurationFile}.new"
474                         exec <"${configurationFile}" >"${outputFile}"
475                 fi
476                 sedScript=""
477                 putSedCommand "1i\\
478 `makeHeaderLine Updated`\\
479 `makeParameterLine`\\
480 "
481         }
482         putConfigurationDirective()
483         {
484                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
485                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
486                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
487         }
488         finalizeConfigurationFile()
489         {
490                 sed -e "${sedScript}"
491                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
492         }
493         ;;
494     *) internalError "unimplemented action: ${requestedAction}";;
495 esac
496
497 translateDevice_none()
498 {
499         :
500 }
501 translateDevice_devfs()
502 {
503         minor="${device#ttyS}"
504         if [ "${minor}" != "${device}" ]; then
505                 device="tts/${minor}"
506                 return 0
507         fi
508         minor="${device#lp}"
509         if [ "${minor}" != "${device}" ]; then
510                 device="printers/${minor}"
511                 return 0
512         fi
513         programMessage "unsupported old-style device: ${device}"
514 }
515 translateDevice_old()
516 {
517         major="${device%%/*}"
518         if [ "${major}" != "${device}" ]; then
519                 minor="${device#*/}"
520                 case "${major}" in
521                     tts) devfs="ttyS${minor}";;
522                     printers) devfs="lp${minor}";;
523                 esac
524         fi
525         if [ -n "${devfs}" ]; then
526                 device="${devfs}"
527         else
528                 programMessage "unsupported devfs device: ${device}"
529         fi
530 }
531
532 makeHeaderLine()
533 {
534         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
535 }
536 makeParameterLine()
537 {
538         echo "# Boot Parameter:${bootParameter}"
539 }
540 putConfigurationFile()
541 {
542         startConfigurationFile
543         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
544         [ -n "${brailleDevice}" ] && {
545         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
546         if [ "${device#/}" = "${device}" ]; then
547                 translateDevice_${deviceTranslation}
548         fi
549         putConfigurationDirective "braille-device" "${device}"
550         }
551         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
552         finalizeConfigurationFile
553 }
554 parseBootParameter()
555 {
556         bootParameter="${bootParameter} ${1}"
557         number=1
558         while [ "${number}" -le 3 ]; do
559                 cut="cut -d, -f${number}"
560                 [ "${number}" -gt 1 ] && cut="${cut} -s"
561                 operand="`echo ${1} | ${cut}`"
562                 if [ -n "${operand}" ]; then
563                         case "${number}" in
564                             1) brailleDriver="${operand}";;
565                             2) brailleDevice="${operand}";;
566                             3) textTable="${operand}";;
567                         esac
568                 fi
569                 number="`expr ${number} + 1`"
570         done
571 }
572 putBootParameter()
573 {
574         parseBootParameter "${1}"
575         putConfigurationFile
576 }
577 parseBootCommand()
578 {
579         found=false
580         while [ "${#}" -gt 0 ]; do
581                 case "${1}" in
582                     "brltty="*)
583                         found=true
584                         parseBootParameter "${1#*=}"
585                         ;;
586                 esac
587                 shift
588         done
589         "${found}" && putConfigurationFile
590 }
591
592 brailleDriver=""
593 brailleDevice=""
594 textTable=""
595 bootCommandFile="/proc/cmdline"
596 if [ -n "${requestedParameter}" ]; then
597         putBootParameter "${requestedParameter}"
598 elif [ -f "${bootCommandFile}" ]; then
599         parseBootCommand `cat "${bootCommandFile}"`
600 elif [ -n "${brltty}" ]; then
601         putBootParameter "${brltty}"
602 fi
603 exit 0
604 )
605
606 %post   -n brlapi -p /sbin/ldconfig
607 %postun -n brlapi -p /sbin/ldconfig
608
609 %files -f %{name}.lang
610 %defattr(644,root,root,755)
611 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
612 %attr(755,root,root) %{_bindir}/brltty
613 %attr(755,root,root) %{_bindir}/brltty-atb
614 %attr(755,root,root) %{_bindir}/brltty-config
615 %attr(755,root,root) %{_bindir}/brltty-ctb
616 %attr(755,root,root) %{_bindir}/brltty-ktb
617 %attr(755,root,root) %{_bindir}/brltty-trtxt
618 %attr(755,root,root) %{_bindir}/brltty-ttb
619 %attr(755,root,root) %{_bindir}/brltty-tune
620 %attr(755,root,root) %{_bindir}/eutp
621 %attr(755,root,root) %{_bindir}/vstp
622 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
623 %dir %{_libdir}/brltty
624 # Braille drivers
625 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
626 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
627 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
628 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
629 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
630 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
631 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
632 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
633 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
634 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
635 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
638 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
639 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
640 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
644 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
662 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
663 # speech synthesizer drivers
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
666 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
667 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
668 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
670 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
671 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
672 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
673 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
674 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
675 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
676 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
677 # screen drivers
678 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
679 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
680 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
681 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
682 %{_sysconfdir}/brltty
683 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
684 %{systemdtmpfilesdir}/brltty.conf
685 %dir /var/lib/BrlAPI
686 %dir /var/run/brltty
687 %{_mandir}/man1/brltty.1*
688 %{_mandir}/man1/eutp.1*
689 %{_mandir}/man1/vstp.1*
690 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
691
692 %if %{with x}
693 # gdm autostart - subpackage?
694 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
695 %endif
696
697 %files -n brlapi
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
700 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
701
702 %files -n brlapi-devel
703 %defattr(644,root,root,755)
704 %doc Documents/Manual-BrlAPI/English/BrlAPI*
705 %attr(755,root,root) %{_libdir}/libbrlapi.so
706 %{_includedir}/brltty
707 %{_includedir}/brlapi*.h
708 %{_mandir}/man3/brlapi_*.3*
709
710 %files -n brlapi-static
711 %defattr(644,root,root,755)
712 %{_libdir}/libbrlapi.a
713
714 %if %{with apidocs}
715 %files -n brlapi-apidocs
716 %defattr(644,root,root,755)
717 %doc Documents/BrlAPIref/html/*
718 %endif
719
720 %if %{with java}
721 %files -n java-brlapi
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
724 %{_javadir}/brlapi.jar
725 %endif
726
727 %if %{with ocaml}
728 %files -n ocaml-brlapi
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
731
732 %files -n ocaml-brlapi-devel
733 %defattr(644,root,root,755)
734 %dir %{_libdir}/ocaml/brlapi
735 %{_libdir}/ocaml/brlapi/META
736 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
737 %{_libdir}/ocaml/brlapi/brlapi.mli
738 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
739 %endif
740
741 %if %{with python}
742 %files -n python-brlapi
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{py_sitedir}/brlapi.so
745 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
746
747 %if %{with python3}
748 %files -n python3-brlapi
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
751 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
752 %endif
753 %endif
754
755 %if %{with tcl}
756 %files -n brlapi-tcl
757 %defattr(644,root,root,755)
758 %dir %{_libdir}/brlapi-%{brlapi_ver}
759 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
760 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
761 %endif
This page took 0.079471 seconds and 4 git commands to generate.