]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- updated to 5.3.1
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  flite                   # Flite synthesizer driver
16 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
17 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
18 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
19 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
20 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
21 %bcond_with     at_spi                  # AtSpi screen driver
22 %bcond_without  at_spi2                 # AtSpi2 screen driver
23
24 %define         brlapi_ver      0.6.4
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        5.3.1
30 Release:        1
31 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
32 Group:          Daemons
33 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
34 # Source0-md5:  7835871c911effd286040225bf5355f8
35 Patch1:         %{name}-speech-dispatcher.patch
36 Patch2:         %{name}-python.patch
37 URL:            http://mielke.cc/brltty/
38 BuildRequires:  alsa-lib-devel
39 %{?with_at_spi:BuildRequires:   at-spi-devel}
40 BuildRequires:  autoconf >= 2.64
41 BuildRequires:  automake
42 BuildRequires:  bison
43 BuildRequires:  rpmbuild(macros) >= 1.710
44 # just headers
45 BuildRequires:  bluez-libs-devel
46 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
47 %{?with_apidocs:BuildRequires:  doxygen}
48 %{?with_espeak:BuildRequires:   espeak-devel}
49 %{?with_flite:BuildRequires:    flite-devel}
50 %{?with_gpm:BuildRequires:      gpm-devel}
51 %{?with_java:BuildRequires:     jdk}
52 %{?with_java:BuildRequires:     jpackage-utils}
53 %{?with_libbraille:BuildRequires:       libbraille-devel}
54 BuildRequires:  libicu-devel
55 BuildRequires:  ncurses-devel
56 %{?with_ocaml:BuildRequires:    ocaml}
57 BuildRequires:  pkgconfig
58 %{?with_python:BuildRequires:   python-Cython}
59 %{?with_python3:BuildRequires:  python3-Cython}
60 %{?with_java:BuildRequires:     rpm-javaprov}
61 %{?with_python:BuildRequires:   rpm-pythonprov}
62 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
63 BuildRequires:  tar >= 1:1.22
64 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
65 %if %{with x}
66 BuildRequires:  xorg-lib-libX11-devel
67 BuildRequires:  xorg-lib-libXaw-devel
68 BuildRequires:  xorg-lib-libXext-devel
69 BuildRequires:  xorg-lib-libXt-devel
70 BuildRequires:  xorg-lib-libXtst-devel
71 %endif
72 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
73 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
74 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
75 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
76 BuildRequires:  xz
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 BRLTTY is a background process (daemon) which provides access to the
81 Linux/Unix console (when in text mode) for a blind person using a
82 refreshable Braille display. It drives the Braille display, and
83 provides complete screen review functionality. Some speech capability
84 has also been incorporated.
85
86 %description -l pl.UTF-8
87 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
88 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
89 odświeżaniem (refreshable Braille display). BRLTTY steruje
90 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
91 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
92 mowy.
93
94 %package -n brlapi
95 Summary:        Application Programming Interface for BRLTTY
96 Summary(pl.UTF-8):      API do BRLTTY
97 License:        LGPL v2.1+
98 Group:          Libraries
99
100 %description -n brlapi
101 This package provides the run-time support for the Application
102 Programming Interface to BRLTTY.
103
104 Install this package if you have an application which directly
105 accesses a refreshable Braille display.
106
107 %description -n brlapi -l pl.UTF-8
108 Ten pakiet zawiera środowisko uruchomieniowe dla programów
109 korzystających z API BRLTTY.
110
111 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
112 wyświetlacza Braille'a z odświeżaniem.
113
114 %package -n brlapi-devel
115 Summary:        Headers and documentation for BrlAPI
116 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
117 License:        LGPL v2.1+
118 Group:          Development/Libraries
119 Requires:       brlapi = %{version}-%{release}
120
121 %description -n brlapi-devel
122 This package provides the header files, shared object linker
123 reference, and reference documentation for BrlAPI (the Application
124 Programming Interface to BRLTTY). It enables the implementation of
125 applications which take direct advantage of a refreshable Braille
126 display in order to present information in ways which are more
127 appropriate for blind users and/or to provide user interfaces which
128 are more specifically atuned to their needs.
129
130 Install this package if you're developing or maintaining an
131 application which directly accesses a refreshable Braille display.
132
133 %description -n brlapi-devel -l pl.UTF-8
134 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
135 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
136 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
137 bardziej przystosowany dla osób niewidomych.
138
139 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
140 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
141
142 %package -n brlapi-static
143 Summary:        Static BrlAPI library
144 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
145 License:        LGPL v2.1+
146 Group:          Development/Libraries
147 Requires:       brlapi-devel = %{version}-%{release}
148
149 %description -n brlapi-static
150 This is package with static BrlAPI library.
151
152 %description -n brlapi-static -l pl.UTF-8
153 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
154
155 %package -n brlapi-apidocs
156 Summary:        BrlAPI documentation
157 Summary(pl.UTF-8):      Documentacja BrlAPI
158 Group:          Documentation
159 %if "%{_rpmversion}" >= "5"
160 BuildArch:      noarch
161 %endif
162
163 %description -n brlapi-apidocs
164 Documentation for BrlAPI in HTML format generated from brltty sources
165 by doxygen.
166
167 %description -n brlapi-apidocs -l pl.UTF-8
168 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
169 doxygen.
170
171 %package -n java-brlapi
172 Summary:        BrlAPI library for Java
173 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
174 License:        LGPL v2.1+
175 Group:          Libraries
176 Requires:       brlapi = %{version}-%{release}
177
178 %description -n java-brlapi
179 BrlAPI library for Java.
180
181 %description -n java-brlapi -l pl.UTF-8
182 Biblioteka BrlAPI dla Javy.
183
184 %package -n ocaml-brlapi
185 Summary:        OCaml binding for BrlAPI
186 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
187 License:        LGPL v2.1+
188 Group:          Libraries
189 Requires:       brlapi = %{version}-%{release}
190 %requires_eq    ocaml-runtime
191
192 %description -n ocaml-brlapi
193 OCaml binding for BrlAPI.
194
195 %description -n ocaml-brlapi -l pl.UTF-8
196 Wiązania OCamla do BrlAPI.
197
198 %package -n ocaml-brlapi-devel
199 Summary:        OCaml binding for BrlAPI - development files
200 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
201 License:        LGPL v2.1+
202 Group:          Libraries
203 Requires:       ocaml-brlapi = %{version}-%{release}
204 %requires_eq    ocaml
205
206 %description -n ocaml-brlapi-devel
207 OCaml binding for BrlAPI - development files.
208
209 %description -n ocaml-brlapi-devel -l pl.UTF-8
210 Wiązania OCamla do BrlAPI - pliki programistyczne.
211
212 %package -n python-brlapi
213 Summary:        Python 2.x interface to BrlAPI
214 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
215 License:        LGPL v2.1+
216 Group:          Libraries
217 Requires:       brlapi = %{version}-%{release}
218
219 %description -n python-brlapi
220 Python 2.x interface to BrlAPI.
221
222 %description -n python-brlapi -l pl.UTF-8
223 Interfejs Pythona 2.x do BrlAPI.
224
225 %package -n python3-brlapi
226 Summary:        Python 3.x interface to BrlAPI
227 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
228 License:        LGPL v2.1+
229 Group:          Libraries
230 Requires:       brlapi = %{version}-%{release}
231
232 %description -n python3-brlapi
233 Python 3.x interface to BrlAPI.
234
235 %description -n python3-brlapi -l pl.UTF-8
236 Interfejs Pythona 3.x do BrlAPI.
237
238 %package -n brlapi-tcl
239 Summary:        BrlAPI library for Tcl
240 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
241 License:        LGPL v2.1+
242 Group:          Libraries
243 Requires:       brlapi = %{version}-%{release}
244
245 %description -n brlapi-tcl
246 BrlAPI library for Tcl.
247
248 %description -n brlapi-tcl -l pl.UTF-8
249 Biblioteka BrlAPI dla Tcl.
250
251 %prep
252 %setup -q
253 %patch1 -p1
254 %patch2 -p1
255
256 %build
257 %{__autoconf}
258 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
259 %configure \
260         %{?with_java:JAVA_HOME=%{java_home}} \
261         --with-install-root="$RPM_BUILD_ROOT" \
262         %{!?with_libbraille:--without-libbraille} \
263         %{!?with_espeak:--without-espeak} \
264         %{!?with_flite:--without-flite} \
265         %{!?with_speech_dispatcher:--without-speechd} \
266         %{!?with_ocaml:--disable-caml-bindings} \
267         %{!?with_gpm:--disable-gpm} \
268         %{!?with_java:--disable-java-bindings} \
269         %{!?with_python:--disable-python-bindings} \
270         %{!?with_tcl:--disable-tcl-bindings} \
271         %{!?with_x:--disable-x} \
272         --enable-api
273
274 %{__make} -j1
275
276 %if %{with python}
277 cd Bindings/Python
278 %py_build
279 cd ../..
280 %endif
281
282 %if %{with python3}
283 cd Bindings/Python
284 %py3_build
285 cd ../..
286 %endif
287
288 directory="doc"
289 mkdir -p "$directory"
290 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
291 do
292         mkdir -p "$directory/${file%/*}"
293         cp -rp "$file" "$directory/$file"
294 done
295
296 %install
297 rm -rf $RPM_BUILD_ROOT
298
299 %{__make} -j1 install \
300         OCAML_INSTALL_TARGET=install-without-findlib
301
302 # findlib-specific, useless in rpm
303 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
304
305 %if %{with python}
306 cd Bindings/Python
307 %py_install
308 cd ../..
309 %endif
310
311 %if %{with python3}
312 cd Bindings/Python
313 %py3_install
314 cd ../..
315 %endif
316
317 %if %{_lib} != "lib"
318         # Fix java plugin install path on 64-bit archs
319         install -d $RPM_BUILD_ROOT%{_libdir}/java
320         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
321 %endif
322
323 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
324
325 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
326 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
327 d /var/run/brltty 0755 root root -
328 EOF
329
330 # no sign in source wheter it is zh_CN or zh_TW so just remove it
331 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh
332
333 %find_lang %{name}
334
335 %clean
336 rm -rf $RPM_BUILD_ROOT
337
338 %pre
339 # The pre-install scriptlet.
340
341 # If a configuration file already exists then rpm installs the new one as
342 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
343 # already exists.
344
345 # There's no explicit way to tell if a configuration file has been installed
346 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
347 # erasing the .rpmnew file now so that we can see if it gets created later.
348 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
349
350 %post
351 # The post-install scriptlet.
352
353 # If BRLTTY's boot parameter has been specified then update the just installed
354 # configuration file template to reflect the options supplied thereby.
355
356 # First, we need to determine which file to update. If there's a .rpmnew file
357 # then update it since a previous configuration file must already have existed.
358 file="%{_sysconfdir}/brltty.conf"
359 new="${file}.rpmnew"
360 [ -f "${new}" ] && file="${new}"
361
362 # Update the configuration file template via the Bootdisks/bp2cf script.
363 # Include it right within this scriptlet so that it needn't be installed.
364 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
365 (
366         # First, set bp2cf's command line arguments.
367         set -- -u -f "${file}"
368
369 #!/bin/sh
370 ###############################################################################
371 # BRLTTY - A background process providing access to the Linux console (when in
372 #          text mode) for a blind person using a refreshable Braille display.
373 #
374 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
375 #
376 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
377 #
378 # This is free software, placed under the terms of the
379 # GNU General Public License, as published by the Free Software
380 # Foundation.  Please see the file COPYING for details.
381 #
382 # Web Page: http://mielke.cc/brltty/
383 #
384 # This software is maintained by Dave Mielke <dave@mielke.cc>.
385 ###############################################################################
386
387 # Convert the boot parameter to configuration file directives.
388 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
389 # If /proc is not mounted then use the brltty environment variable.
390 # Invoke with -h for usage information.
391
392 programName="${0##*/}"
393 programMessage()
394 {
395         echo 2>&1 "${programName}: ${1}"
396 }
397 syntaxError()
398 {
399         programMessage "${1}"
400         exit 2
401 }
402 internalError()
403 {
404         programMessage "${1}"
405         exit 3
406 }
407
408 configurationFile=""
409 requestedAction=create
410 deviceTranslation=none
411 requestedParameter=""
412 OPTIND=1
413 while getopts ":f:cundop:h" option
414 do
415         case "${option}" in
416             f) configurationFile="${OPTARG}";;
417             c) requestedAction=create;;
418             u) requestedAction=update;;
419             n) deviceTranslation=none;;
420             d) deviceTranslation=devfs;;
421             o) deviceTranslation=old;;
422             p) requestedParameter="${OPTARG}";;
423             h)
424                 cat <<EOF
425 Usage: ${programName} [option ...]
426 -f file  The configuration file to create/update.
427 -c       Create the configuration file (write to stdout if no -f).
428 -u       Update the configuration file (copying from stdin to stdout if no -f).
429 -n       Do not translate device paths.
430 -d       Do old-style to devfs device path translation.
431 -o       Do devfs to old-style device path translation.
432 -p [driver][,[device][,[table]]]
433          Explicitly specify the boot parameter.
434 -h       Display this usage summary.
435 EOF
436                 exit 0
437                 ;;
438             \?) syntaxError "unknown option: -${OPTARG}";;
439             :) syntaxError "missing value: -${OPTARG}";;
440             *) internalError "unimplemented option: -${option}";;
441         esac
442 done
443 shift "`expr $OPTIND - 1`"
444 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
445
446 case "${requestedAction}" in
447     create)
448         putConfigurationLine()
449         {
450                 echo "${1}" || exit 4
451         }
452         startConfigurationFile()
453         {
454                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
455                 putConfigurationLine "`makeHeaderLine Created`"
456                 putConfigurationLine "`makeParameterLine`"
457                 putConfigurationLine ""
458         }
459         putConfigurationDirective()
460         {
461                 putConfigurationLine "${1} ${2}"
462         }
463         finalizeConfigurationFile()
464         {
465                 :
466         }
467         ;;
468     update)
469         putSedCommand()
470         {
471                 sedScript="${sedScript}
472 ${1}"
473         }
474         startConfigurationFile()
475         {
476                 if [ -n "${configurationFile}" ]; then
477                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
478                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
479                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
480                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
481                         outputFile="${configurationFile}.new"
482                         exec <"${configurationFile}" >"${outputFile}"
483                 fi
484                 sedScript=""
485                 putSedCommand "1i\\
486 `makeHeaderLine Updated`\\
487 `makeParameterLine`\\
488 "
489         }
490         putConfigurationDirective()
491         {
492                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
493                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
494                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
495         }
496         finalizeConfigurationFile()
497         {
498                 sed -e "${sedScript}"
499                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
500         }
501         ;;
502     *) internalError "unimplemented action: ${requestedAction}";;
503 esac
504
505 translateDevice_none()
506 {
507         :
508 }
509 translateDevice_devfs()
510 {
511         minor="${device#ttyS}"
512         if [ "${minor}" != "${device}" ]; then
513                 device="tts/${minor}"
514                 return 0
515         fi
516         minor="${device#lp}"
517         if [ "${minor}" != "${device}" ]; then
518                 device="printers/${minor}"
519                 return 0
520         fi
521         programMessage "unsupported old-style device: ${device}"
522 }
523 translateDevice_old()
524 {
525         major="${device%%/*}"
526         if [ "${major}" != "${device}" ]; then
527                 minor="${device#*/}"
528                 case "${major}" in
529                     tts) devfs="ttyS${minor}";;
530                     printers) devfs="lp${minor}";;
531                 esac
532         fi
533         if [ -n "${devfs}" ]; then
534                 device="${devfs}"
535         else
536                 programMessage "unsupported devfs device: ${device}"
537         fi
538 }
539
540 makeHeaderLine()
541 {
542         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
543 }
544 makeParameterLine()
545 {
546         echo "# Boot Parameter:${bootParameter}"
547 }
548 putConfigurationFile()
549 {
550         startConfigurationFile
551         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
552         [ -n "${brailleDevice}" ] && {
553         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
554         if [ "${device#/}" = "${device}" ]; then
555                 translateDevice_${deviceTranslation}
556         fi
557         putConfigurationDirective "braille-device" "${device}"
558         }
559         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
560         finalizeConfigurationFile
561 }
562 parseBootParameter()
563 {
564         bootParameter="${bootParameter} ${1}"
565         number=1
566         while [ "${number}" -le 3 ]; do
567                 cut="cut -d, -f${number}"
568                 [ "${number}" -gt 1 ] && cut="${cut} -s"
569                 operand="`echo ${1} | ${cut}`"
570                 if [ -n "${operand}" ]; then
571                         case "${number}" in
572                             1) brailleDriver="${operand}";;
573                             2) brailleDevice="${operand}";;
574                             3) textTable="${operand}";;
575                         esac
576                 fi
577                 number="`expr ${number} + 1`"
578         done
579 }
580 putBootParameter()
581 {
582         parseBootParameter "${1}"
583         putConfigurationFile
584 }
585 parseBootCommand()
586 {
587         found=false
588         while [ "${#}" -gt 0 ]; do
589                 case "${1}" in
590                     "brltty="*)
591                         found=true
592                         parseBootParameter "${1#*=}"
593                         ;;
594                 esac
595                 shift
596         done
597         "${found}" && putConfigurationFile
598 }
599
600 brailleDriver=""
601 brailleDevice=""
602 textTable=""
603 bootCommandFile="/proc/cmdline"
604 if [ -n "${requestedParameter}" ]; then
605         putBootParameter "${requestedParameter}"
606 elif [ -f "${bootCommandFile}" ]; then
607         parseBootCommand `cat "${bootCommandFile}"`
608 elif [ -n "${brltty}" ]; then
609         putBootParameter "${brltty}"
610 fi
611 exit 0
612 )
613
614 %post   -n brlapi -p /sbin/ldconfig
615 %postun -n brlapi -p /sbin/ldconfig
616
617 %files -f %{name}.lang
618 %defattr(644,root,root,755)
619 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
620 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README}
621 %attr(755,root,root) %{_bindir}/brltty
622 %attr(755,root,root) %{_bindir}/brltty-atb
623 %attr(755,root,root) %{_bindir}/brltty-config
624 %attr(755,root,root) %{_bindir}/brltty-ctb
625 %attr(755,root,root) %{_bindir}/brltty-ktb
626 %attr(755,root,root) %{_bindir}/brltty-trtxt
627 %attr(755,root,root) %{_bindir}/brltty-ttb
628 %attr(755,root,root) %{_bindir}/brltty-tune
629 %attr(755,root,root) %{_bindir}/eutp
630 %attr(755,root,root) %{_bindir}/vstp
631 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
632 %dir %{_libdir}/brltty
633 # Braille drivers
634 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
635 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
638 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
639 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
640 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
653 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
662 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
663 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
666 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
667 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
668 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
670 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
671 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
672 # speech synthesizer drivers
673 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
674 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
676 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
677 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
678 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
679 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
680 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
681 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
682 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
683 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
684 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
685 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
686 # screen drivers
687 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
688 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
689 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
690 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
691 %{_sysconfdir}/brltty
692 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
693 %{systemdtmpfilesdir}/brltty.conf
694 %dir /var/lib/BrlAPI
695 %dir /var/run/brltty
696 %{_mandir}/man1/brltty.1*
697 %{_mandir}/man1/eutp.1*
698 %{_mandir}/man1/vstp.1*
699 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
700
701 %if %{with x}
702 # gdm autostart - subpackage?
703 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
704 %endif
705
706 %files -n brlapi
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
709 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
710
711 %files -n brlapi-devel
712 %defattr(644,root,root,755)
713 %doc Documents/Manual-BrlAPI/English/BrlAPI*
714 %attr(755,root,root) %{_libdir}/libbrlapi.so
715 %{_includedir}/brltty
716 %{_includedir}/brlapi*.h
717 %{_mandir}/man3/brlapi_*.3*
718
719 %files -n brlapi-static
720 %defattr(644,root,root,755)
721 %{_libdir}/libbrlapi.a
722
723 %if %{with apidocs}
724 %files -n brlapi-apidocs
725 %defattr(644,root,root,755)
726 %doc Documents/BrlAPIref/html/*
727 %endif
728
729 %if %{with java}
730 %files -n java-brlapi
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
733 %{_javadir}/brlapi.jar
734 %endif
735
736 %if %{with ocaml}
737 %files -n ocaml-brlapi
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
740
741 %files -n ocaml-brlapi-devel
742 %defattr(644,root,root,755)
743 %dir %{_libdir}/ocaml/brlapi
744 %{_libdir}/ocaml/brlapi/META
745 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
746 %{_libdir}/ocaml/brlapi/brlapi.mli
747 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
748 %endif
749
750 %if %{with python}
751 %files -n python-brlapi
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{py_sitedir}/brlapi.so
754 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
755
756 %if %{with python3}
757 %files -n python3-brlapi
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
760 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
761 %endif
762 %endif
763
764 %if %{with tcl}
765 %files -n brlapi-tcl
766 %defattr(644,root,root,755)
767 %dir %{_libdir}/brlapi-%{brlapi_ver}
768 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
769 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
770 %endif
This page took 0.0908 seconds and 4 git commands to generate.