]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
aa83c5d86f47dc5e7384192ddee72a1b5aea02ee
[packages/brltty.git] / brltty.spec
1 # TODO: user/group (see Autostart/Systemd/sysusers)
2 #
3 # Conditional build:
4 %bcond_without  apidocs                 # documentation generated with doxygen
5 %bcond_without  java                    # Java bindings
6 %bcond_without  lua                     # Lua bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  liblouis                # liblouis in-line contracted Braille support
15 %bcond_without  espeak                  # eSpeak synthesizer driver
16 %bcond_without  espeak_ng               # eSpeak-NG synthesizer driver
17 %bcond_without  flite                   # Flite synthesizer driver
18 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
19 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
20 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
21 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
22 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
23 %bcond_with     at_spi                  # AtSpi screen driver
24 %bcond_without  at_spi2                 # AtSpi2 screen driver
25
26 %define         brlapi_ver      0.8.4
27
28 %{?with_java:%{?use_default_jdk}}
29
30 Summary:        Braille display driver for Linux/Unix
31 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
32 Name:           brltty
33 Version:        6.5
34 Release:        4
35 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
36 Group:          Daemons
37 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
38 # Source0-md5:  d9a045a139edd179fe9d3caf088c06ad
39 Patch1:         %{name}-speech-dispatcher.patch
40 Patch4:         %{name}-glibc25.patch
41 URL:            http://mielke.cc/brltty/
42 BuildRequires:  alsa-lib-devel
43 %{?with_at_spi:BuildRequires:   at-spi-devel}
44 %{?with_at_spi2:BuildRequires:  at-spi2-core-devel >= 2.0}
45 BuildRequires:  autoconf >= 2.64
46 BuildRequires:  automake
47 BuildRequires:  bison
48 # just headers
49 BuildRequires:  bluez-libs-devel
50 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
51 %{?with_apidocs:BuildRequires:  doxygen}
52 %{?with_espeak:BuildRequires:   espeak-devel}
53 %{?with_espeak_ng:BuildRequires:        espeak-ng-devel}
54 BuildRequires:  expat-devel
55 %{?with_flite:BuildRequires:    flite-devel}
56 BuildRequires:  gettext-tools
57 %{?with_at_spi2:BuildRequires:  glib2-devel >= 2.0}
58 %{?with_gpm:BuildRequires:      gpm-devel}
59 %{?with_java:%{?use_jdk:%buildrequires_jdk}%{!?use_jdk:BuildRequires:   jdk}}
60 %{?with_java:BuildRequires:     jpackage-utils}
61 %{?with_libbraille:BuildRequires:       libbraille-devel}
62 BuildRequires:  libicu-devel
63 %{?with_liblouis:BuildRequires: liblouis-devel}
64 %{?with_lua:BuildRequires:      lua-devel}
65 BuildRequires:  ncurses-devel
66 %{?with_ocaml:BuildRequires:    ocaml}
67 BuildRequires:  pcre2-32-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  polkit-devel
70 %{?with_python:BuildRequires:   python-Cython}
71 %{?with_python3:BuildRequires:  python3-Cython}
72 BuildRequires:  rpm-build >= 4.6
73 %{?with_java:BuildRequires:     rpm-javaprov}
74 %{?with_python:BuildRequires:   rpm-pythonprov}
75 BuildRequires:  rpmbuild(macros) >= 2.021
76 BuildRequires:  sed >= 4.0
77 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
78 BuildRequires:  systemd-devel >= 1:209
79 BuildRequires:  tar >= 1:1.22
80 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
81 %if %{with x}
82 BuildRequires:  xorg-lib-libX11-devel
83 BuildRequires:  xorg-lib-libXaw-devel
84 BuildRequires:  xorg-lib-libXext-devel
85 BuildRequires:  xorg-lib-libXfixes-devel
86 BuildRequires:  xorg-lib-libXt-devel
87 BuildRequires:  xorg-lib-libXtst-devel
88 %endif
89 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
90 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
91 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
92 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
93 BuildRequires:  xz
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %description
97 BRLTTY is a background process (daemon) which provides access to the
98 Linux/Unix console (when in text mode) for a blind person using a
99 refreshable Braille display. It drives the Braille display, and
100 provides complete screen review functionality. Some speech capability
101 has also been incorporated.
102
103 %description -l pl.UTF-8
104 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
105 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
106 odświeżaniem (refreshable Braille display). BRLTTY steruje
107 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
108 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
109 mowy.
110
111 %package -n dracut-brltty
112 Summary:        Braille support for Dracut
113 Summary(pl.UTF-8):      Obsługa Braille'a dla Dracuta
114 Group:          Applications/Text
115 Requires:       %{name} = %{version}-%{release}
116 Requires:       dracut
117
118 %description -n dracut-brltty
119 Braille support for Dracut.
120
121 %description -n dracut-brltty -l pl.UTF-8
122 Obsługa Braille'a dla Dracuta.
123
124 %package -n brlapi
125 Summary:        Application Programming Interface for BRLTTY
126 Summary(pl.UTF-8):      API do BRLTTY
127 License:        LGPL v2.1+
128 Group:          Libraries
129
130 %description -n brlapi
131 This package provides the run-time support for the Application
132 Programming Interface to BRLTTY.
133
134 Install this package if you have an application which directly
135 accesses a refreshable Braille display.
136
137 %description -n brlapi -l pl.UTF-8
138 Ten pakiet zawiera środowisko uruchomieniowe dla programów
139 korzystających z API BRLTTY.
140
141 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
142 wyświetlacza Braille'a z odświeżaniem.
143
144 %package -n brlapi-devel
145 Summary:        Headers and documentation for BrlAPI
146 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
147 License:        LGPL v2.1+
148 Group:          Development/Libraries
149 Requires:       brlapi = %{version}-%{release}
150
151 %description -n brlapi-devel
152 This package provides the header files, shared object linker
153 reference, and reference documentation for BrlAPI (the Application
154 Programming Interface to BRLTTY). It enables the implementation of
155 applications which take direct advantage of a refreshable Braille
156 display in order to present information in ways which are more
157 appropriate for blind users and/or to provide user interfaces which
158 are more specifically atuned to their needs.
159
160 Install this package if you're developing or maintaining an
161 application which directly accesses a refreshable Braille display.
162
163 %description -n brlapi-devel -l pl.UTF-8
164 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
165 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
166 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
167 bardziej przystosowany dla osób niewidomych.
168
169 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
170 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
171
172 %package -n brlapi-static
173 Summary:        Static BrlAPI library
174 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
175 License:        LGPL v2.1+
176 Group:          Development/Libraries
177 Requires:       brlapi-devel = %{version}-%{release}
178
179 %description -n brlapi-static
180 This is package with static BrlAPI library.
181
182 %description -n brlapi-static -l pl.UTF-8
183 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
184
185 %package -n brlapi-apidocs
186 Summary:        BrlAPI documentation
187 Summary(pl.UTF-8):      Documentacja BrlAPI
188 Group:          Documentation
189 BuildArch:      noarch
190
191 %description -n brlapi-apidocs
192 Documentation for BrlAPI in HTML format generated from brltty sources
193 by doxygen.
194
195 %description -n brlapi-apidocs -l pl.UTF-8
196 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
197 doxygen.
198
199 %package -n java-brlapi
200 Summary:        BrlAPI library for Java
201 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
202 License:        LGPL v2.1+
203 Group:          Libraries
204 Requires:       brlapi = %{version}-%{release}
205
206 %description -n java-brlapi
207 BrlAPI library for Java.
208
209 %description -n java-brlapi -l pl.UTF-8
210 Biblioteka BrlAPI dla Javy.
211
212 %package -n lua-brlapi
213 Summary:        BrlAPI library for Lua
214 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Lua
215 License:        LGPL v2.1+
216 Group:          Libraries
217 Requires:       brlapi = %{version}-%{release}
218
219 %description -n lua-brlapi
220 BrlAPI library for Lua.
221
222 %description -n lua-brlapi -l pl.UTF-8
223 Biblioteka BrlAPI dla Lua.
224
225 %package -n ocaml-brlapi
226 Summary:        OCaml binding for BrlAPI
227 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
228 License:        LGPL v2.1+
229 Group:          Libraries
230 Requires:       brlapi = %{version}-%{release}
231 %requires_eq    ocaml-runtime
232
233 %description -n ocaml-brlapi
234 OCaml binding for BrlAPI.
235
236 %description -n ocaml-brlapi -l pl.UTF-8
237 Wiązania OCamla do BrlAPI.
238
239 %package -n ocaml-brlapi-devel
240 Summary:        OCaml binding for BrlAPI - development files
241 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
242 License:        LGPL v2.1+
243 Group:          Libraries
244 Requires:       ocaml-brlapi = %{version}-%{release}
245 %requires_eq    ocaml
246
247 %description -n ocaml-brlapi-devel
248 OCaml binding for BrlAPI - development files.
249
250 %description -n ocaml-brlapi-devel -l pl.UTF-8
251 Wiązania OCamla do BrlAPI - pliki programistyczne.
252
253 %package -n python-brlapi
254 Summary:        Python 2.x interface to BrlAPI
255 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
256 License:        LGPL v2.1+
257 Group:          Libraries
258 Requires:       brlapi = %{version}-%{release}
259
260 %description -n python-brlapi
261 Python 2.x interface to BrlAPI.
262
263 %description -n python-brlapi -l pl.UTF-8
264 Interfejs Pythona 2.x do BrlAPI.
265
266 %package -n python3-brlapi
267 Summary:        Python 3.x interface to BrlAPI
268 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
269 License:        LGPL v2.1+
270 Group:          Libraries
271 Requires:       brlapi = %{version}-%{release}
272
273 %description -n python3-brlapi
274 Python 3.x interface to BrlAPI.
275
276 %description -n python3-brlapi -l pl.UTF-8
277 Interfejs Pythona 3.x do BrlAPI.
278
279 %package -n brlapi-tcl
280 Summary:        BrlAPI library for Tcl
281 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
282 License:        LGPL v2.1+
283 Group:          Libraries
284 Requires:       brlapi = %{version}-%{release}
285
286 %description -n brlapi-tcl
287 BrlAPI library for Tcl.
288
289 %description -n brlapi-tcl -l pl.UTF-8
290 Biblioteka BrlAPI dla Tcl.
291
292 %prep
293 %setup -q
294 %patch1 -p1
295 %patch4 -p1
296
297 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' Tables/Contraction/latex-access.ctb
298
299 %build
300 %{__aclocal} -I m4
301 %{__autoconf}
302 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
303 %configure \
304         %{?with_java:JAVA_HOME=%{java_home}} \
305         --with-install-root="$RPM_BUILD_ROOT" \
306         %{!?with_libbraille:--without-libbraille} \
307         %{!?with_espeak:--without-espeak} \
308         %{!?with_espeak_ng:--without-espeak_ng} \
309         %{!?with_flite:--without-flite} \
310         %{!?with_speech_dispatcher:--without-speechd} \
311         %{!?with_ocaml:--disable-caml-bindings} \
312         %{!?with_gpm:--disable-gpm} \
313         %{!?with_java:--disable-java-bindings} \
314         %{!?with_liblouis:--disable-liblouis} \
315         --enable-lisp-bindings \
316         %{!?with_lua:--disable-lua-bindings} \
317         %{!?with_python:--disable-python-bindings} \
318         %{!?with_tcl:--disable-tcl-bindings} \
319         %{!?with_x:--disable-x} \
320         --with-speech-driver="-vv" \
321         --enable-api
322
323 %{__make} -j1
324
325 %if %{with python}
326 cd Bindings/Python
327 %py_build
328 cd ../..
329 %endif
330
331 %if %{with python3}
332 cd Bindings/Python
333 %py3_build
334 cd ../..
335 %endif
336
337 %install
338 rm -rf $RPM_BUILD_ROOT
339 install -d $RPM_BUILD_ROOT/var/lib/brltty
340
341 %{__make} -j1 install install-appstream install-dracut install-polkit install-systemd install-udev \
342         OCAML_INSTALL_TARGET=install-without-findlib \
343         UDEV_PARENT_LOCATION=/lib
344
345 # findlib-specific, useless in rpm
346 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
347
348 %if %{with python}
349 cd Bindings/Python
350 %py_install
351 cd ../..
352 %endif
353
354 %if %{with python3}
355 cd Bindings/Python
356 %py3_install
357 cd ../..
358 %endif
359
360 %if "%{_lib}" != "lib"
361         # Fix java plugin install path on 64-bit archs
362         install -d $RPM_BUILD_ROOT%{_libdir}/java
363         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
364 %endif
365
366 install Bootdisks/bp2cf $RPM_BUILD_ROOT%{_bindir}/brltty-bp2cf
367 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
368
369 # no sign in source wheter it is zh_CN or zh_TW
370 # but seems to contain Traditional Chinese characters
371 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_TW}
372
373 # packaged as %doc
374 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/dracut/modules.d/99brltty/README
375
376 %find_lang %{name}
377
378 %clean
379 rm -rf $RPM_BUILD_ROOT
380
381 %pre
382 # The pre-install scriptlet.
383
384 # If a configuration file already exists then rpm installs the new one as
385 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
386 # already exists.
387
388 # There's no explicit way to tell if a configuration file has been installed
389 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
390 # erasing the .rpmnew file now so that we can see if it gets created later.
391 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
392
393 %post
394 # If BRLTTY's boot parameter has been specified then update the just installed
395 # configuration file template to reflect the options supplied thereby.
396
397 # First, we need to determine which file to update. If there's a .rpmnew file
398 # then update it since a previous configuration file must already have existed.
399 file="%{_sysconfdir}/brltty.conf"
400 new="${file}.rpmnew"
401 [ -f "${new}" ] && file="${new}"
402
403 # Update the configuration file template via the Bootdisks/bp2cf script.
404 %{_bindir}/brltty-bp2cf -u -f "${file}" >/dev/null 2>&1 || :
405
406 %post   -n brlapi -p /sbin/ldconfig
407 %postun -n brlapi -p /sbin/ldconfig
408
409 %files -f %{name}.lang
410 %defattr(644,root,root,755)
411 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
412 %attr(755,root,root) %{_bindir}/brltty
413 %attr(755,root,root) %{_bindir}/brltty-atb
414 %attr(755,root,root) %{_bindir}/brltty-bp2cf
415 %{_bindir}/brltty-config.sh
416 %attr(755,root,root) %{_bindir}/brltty-clip
417 %attr(755,root,root) %{_bindir}/brltty-cldr
418 %attr(755,root,root) %{_bindir}/brltty-ctb
419 %attr(755,root,root) %{_bindir}/brltty-genkey
420 %attr(755,root,root) %{_bindir}/brltty-hid
421 %attr(755,root,root) %{_bindir}/brltty-ktb
422 %attr(755,root,root) %{_bindir}/brltty-lscmds
423 %attr(755,root,root) %{_bindir}/brltty-lsinc
424 %attr(755,root,root) %{_bindir}/brltty-mkuser
425 %attr(755,root,root) %{_bindir}/brltty-morse
426 %{_bindir}/brltty-prologue.bash
427 %{_bindir}/brltty-prologue.lua
428 %{_bindir}/brltty-prologue.sh
429 %{_bindir}/brltty-prologue.tcl
430 %attr(755,root,root) %{_bindir}/brltty-setcaps
431 %attr(755,root,root) %{_bindir}/brltty-trtxt
432 %attr(755,root,root) %{_bindir}/brltty-ttb
433 %attr(755,root,root) %{_bindir}/brltty-ttysize
434 %attr(755,root,root) %{_bindir}/brltty-tune
435 %attr(755,root,root) %{_bindir}/eutp
436 %attr(755,root,root) %{_bindir}/vstp
437 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
438 %dir %{_libdir}/brltty
439 # Braille drivers
440 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
441 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
442 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
443 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
444 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
445 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
446 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
447 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
448 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
449 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
450 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
451 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcn.so
452 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
453 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
454 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfa.so
455 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
456 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
457 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
458 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
459 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
460 %attr(755,root,root) %{_libdir}/brltty/libbrlttybic.so
461 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
462 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
463 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
464 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
465 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
466 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
467 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
468 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
469 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
470 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
471 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
472 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
473 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
474 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
475 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
476 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
477 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
478 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
479 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
480 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
481 # speech synthesizer drivers
482 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
483 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
484 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
485 %{?with_espeak_ng:%attr(755,root,root) %{_libdir}/brltty/libbrlttysen.so}
486 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
487 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
488 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
489 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
490 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
491 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
492 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
493 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
494 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
495 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
496 # screen drivers
497 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
498 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
499 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
500 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
501 %if "%{_libexecdir}" != "%{_libdir}"
502 %dir %{_libexecdir}/brltty
503 %endif
504 %attr(755,root,root) %{_libexecdir}/brltty/systemd-wrapper
505 %attr(755,root,root) %{_libexecdir}/brltty/udev-wrapper
506 %{_sysconfdir}/brltty
507 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
508 /lib/udev/rules.d/90-brltty-hid.rules
509 /lib/udev/rules.d/90-brltty-uinput.rules
510 /lib/udev/rules.d/90-brltty-usb-customized.rules
511 /lib/udev/rules.d/90-brltty-usb-generic.rules
512 %{systemdunitdir}/brltty.path
513 %{systemdunitdir}/brltty@.path
514 %{systemdunitdir}/brltty@.service
515 %{systemdunitdir}/brltty-device@.service
516 %{systemdtmpfilesdir}/brltty.conf
517 #%{_prefix}/lib/sysusers.d/brltty.conf
518 #%attr(3777,brltty,brltty)
519 %dir /var/lib/BrlAPI
520 #%attr(2770,brltty,brltty)
521 %dir /var/lib/brltty
522 %{_mandir}/man1/brltty.1*
523 %{_mandir}/man1/eutp.1*
524 %{_mandir}/man1/vstp.1*
525 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
526
527 %if %{with x}
528 # gdm autostart - subpackage?
529 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
530 #/etc/X11/Xsession.d/90xbrlapi
531 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
532 %endif
533 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
534 %{_datadir}/polkit-1/rules.d/org.a11y.brlapi.rules
535
536 %files -n dracut-brltty
537 %defattr(644,root,root,755)
538 %doc Initramfs/Dracut/README
539 %dir %{_prefix}/lib/dracut/modules.d/99brltty
540 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/alsa-start.sh
541 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/bluetooth-start.sh
542 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/brltty-start.sh
543 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/brltty-stop.sh
544 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/dbus-start.sh
545 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/module-setup.sh
546 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/pulse-start.sh
547 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/pulse-stop.sh
548 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/speechd-start.sh
549
550 %files -n brlapi
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
553 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.8
554
555 %files -n brlapi-devel
556 %defattr(644,root,root,755)
557 %doc Documents/Manual-BrlAPI/English/BrlAPI*
558 %attr(755,root,root) %{_libdir}/libbrlapi.so
559 %{_includedir}/brltty
560 %{_includedir}/brlapi*.h
561 %{_pkgconfigdir}/brltty.pc
562 %{_mandir}/man3/brlapi_*.3*
563
564 %files -n brlapi-static
565 %defattr(644,root,root,755)
566 %{_libdir}/libbrlapi.a
567
568 %if %{with apidocs}
569 %files -n brlapi-apidocs
570 %defattr(644,root,root,755)
571 %doc Documents/BrlAPIref/html/*
572 %endif
573
574 %if %{with java}
575 %files -n java-brlapi
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
578 %{_javadir}/brlapi.jar
579 %endif
580
581 %if %{with lua}
582 %files -n lua-brlapi
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/lua/*.*/brlapi.so
585 %endif
586
587 %if %{with ocaml}
588 %files -n ocaml-brlapi
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
591
592 %files -n ocaml-brlapi-devel
593 %defattr(644,root,root,755)
594 %dir %{_libdir}/ocaml/brlapi
595 %{_libdir}/ocaml/brlapi/META
596 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
597 %{_libdir}/ocaml/brlapi/brlapi.mli
598 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
599 %endif
600
601 %if %{with python}
602 %files -n python-brlapi
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{py_sitedir}/brlapi.so
605 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
606
607 %if %{with python3}
608 %files -n python3-brlapi
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
611 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
612 %endif
613 %endif
614
615 %if %{with tcl}
616 %files -n brlapi-tcl
617 %defattr(644,root,root,755)
618 %dir %{_libdir}/brlapi-%{brlapi_ver}
619 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
620 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
621 %endif
This page took 0.111235 seconds and 2 git commands to generate.