]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
55e169da03916c5f22f0e6a1694114620a6a8caf
[packages/bmpx.git] / bmpx.spec
1 # TODO: use browser-plugins if plugin works with something else than firefox (e.g. seamonkey)
2 #
3 # Conditional build:
4 %bcond_without  gaim    # build without D-BUS gaim support
5 %bcond_without  sid     # build without sid support
6 %bcond_without  ofa     # build without MusicIP support
7 #
8 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
9 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
10 Name:           bmpx
11 Version:        0.36.0
12 Release:        0.1
13 License:        GPL v2
14 Group:          X11/Applications/Sound
15 Source0:        http://files.beep-media-player.org/releases/0.36/%{name}-%{version}.tar.bz2
16 # Source0-md5:  4755c38432dd912dc8156ad217c2e5bf
17 Source1:        mp3license
18 Patch0:         %{name}-desktop.patch
19 URL:            http://beep-media-player.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  boost-bind-devel
24 BuildRequires:  boost-call_traits-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  boost-filesystem-devel
27 BuildRequires:  boost-regex-devel
28 BuildRequires:  cdparanoia-III-devel
29 BuildRequires:  curl-devel
30 BuildRequires:  dbus-glib-devel >= 0.62
31 BuildRequires:  esound-devel >= 0.2.8
32 BuildRequires:  fam-devel
33 BuildRequires:  flex
34 %{?with_gaim:BuildRequires:     gaim-devel}
35 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.9
36 BuildRequires:  gtkmm-devel >= 2.9.8
37 BuildRequires:  hal-devel >= 0.5.7
38 BuildRequires:  libglademm-devel >= 2.6.2
39 BuildRequires:  libnotify-devel >= 0.4.2
40 BuildRequires:  libmusicbrainz-devel >= 2.1.1
41 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
42 %{?with_sid:BuildRequires:      libsidplay-devel}
43 BuildRequires:  libtool
44 BuildRequires:  libvorbis-devel >= 1:1.0
45 BuildRequires:  libxml2-devel >= 1:2.6.26
46 BuildRequires:  mpeg4ip-devel
47 BuildRequires:  neon-devel >= 0.25.5
48 BuildRequires:  rpmbuild(macros) >= 1.311
49 BuildRequires:  rpm-pythonprov
50 BuildRequires:  startup-notification-devel >= 0.8
51 BuildRequires:  taglib-devel >= 1.4
52 BuildRequires:  unzip
53 Requires(post,postun):  desktop-file-utils
54 Requires(post,postun):  gtk+2 >= 2:2.10.0
55 Requires(post,postun):  hicolor-icon-theme
56 Requires(post,postun):  shared-mime-info
57 Requires:       gstreamer-audio-effects-base >= 0.10.9
58 Requires:       gstreamer-audio-formats >= 0.10.3
59 Requires:       gstreamer-audiosink
60 Obsoletes:      bmpx-curses
61 Obsoletes:      bmpx-libs
62 Obsoletes:      bmpx-plugin-container
63 Obsoletes:      bmpx-plugin-flow
64 Obsoletes:      bmpx-plugins-base
65 Obsoletes:      bmpx-plugin-transport
66 Obsoletes:      bmpx-remote
67 Obsoletes:      bmpx-remote-gtk
68 Obsoletes:      bmpx-static
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _firefoxdir     %{_libdir}/mozilla-firefox
72 %define         _chromedir      %{_firefoxdir}/chrome
73
74 %description
75 BMPx is the follow-up of the BMP project with a codebase rewritten
76 from scratch and aims to maintain a stable audio player foundation,
77 and to provide a player with a consistent and easy to understand usage
78 experience.
79
80 %description -l pl
81 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
82 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
83 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
84
85 %package devel
86 Summary:        Header files for BMPx media player
87 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
88 Group:          X11/Development/Libraries
89 Requires:       dbus-glib-devel >= 0.62
90 Obsoletes:      libchroma-devel
91 Obsoletes:      libhrel-devel
92
93 %description devel
94 Header files required for compiling BMPx media player plugins.
95
96 %description devel -l pl
97 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
98 multimedialnego BMPx.
99
100 %package -n mozilla-firefox-plugin-bmpx
101 Summary:        BMPx plugin for Mozilla Firefox
102 Summary(pl):    Wtyczka BMPx dla Mozilli Firefox
103 Group:          X11/Applications
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       mozilla-firefox
106
107 %description -n mozilla-firefox-plugin-bmpx
108 This plugin registers the lastfm:// protocol to BMPx.
109
110 %description -n mozilla-firefox-plugin-bmpx -l pl
111 Ta wtyczka rejestruje protokó³ lastfm:// do BMPx.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116
117 %build
118 %{__libtoolize}
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --enable-hal \
125         --enable-gamin \
126         --enable-libnotify \
127         --enable-mp4v2 \
128         %{?with_ofa:--enable-ofa} \
129         %{?with_sid:--enable-sid} \
130         --enable-shared \
131         --enable-static \
132         %{?with_gaim:--enable-gaim} \
133         --with-dbus-services-dir=%{_datadir}/dbus-1/services
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT%{_chromedir}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT \
142         m4datadir=%{_aclocaldir}
143
144 unzip xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
145 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
146         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
147
148 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
149 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
150 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.{a,la}
151 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 %update_desktop_database_post
160 %update_mime_database
161 %update_icon_cache hicolor
162
163 %banner %{name} -e << EOF
164 Remember to install appropriate GStreamer plugins for files
165 you want to play:
166 - gstreamer-cdparanoia (for Audio-CD)
167 - gstreamer-flac (for FLAC)
168 - gstreamer-mad (for MP3s)
169 - gstreamer-vorbis (for Ogg Vorbis)
170 EOF
171
172 %postun
173 %update_desktop_database_postun
174 %update_mime_database
175 %update_icon_cache hicolor
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS ChangeLog NEWS README
180 %attr(755,root,root) %{_bindir}/beep-media-player-2
181 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
182 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
183 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
184 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
185 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
186 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
187
188 %dir %{_libdir}/bmpx
189 %dir %{_libdir}/bmpx/plugins
190 %dir %{_libdir}/bmpx/plugins/taglib
191 %dir %{_libdir}/bmpx/plugins/vfs
192 %dir %{_libdir}/bmpx/plugins/vfs/container
193 %dir %{_libdir}/bmpx/plugins/vfs/transport
194 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
195 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
196 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
197
198 %{_datadir}/bmpx
199 %{_datadir}/dbus-1/services/*.service
200 %{_mandir}/man*/*
201 %{_desktopdir}/*.desktop
202 %{_iconsdir}/hicolor/*/*/*.png
203
204 %files devel
205 %defattr(644,root,root,755)
206 %{_includedir}/bmp-2.0
207 %{_pkgconfigdir}/*.pc
208
209 %files -n mozilla-firefox-plugin-bmpx
210 %defattr(644,root,root,755)
211 %{_chromedir}/bmp.jar
212 %{_chromedir}/bmp.manifest
This page took 0.075123 seconds and 3 git commands to generate.