]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- use new %%doc
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(de):    GNU Binary Utility Development Utilities
3 Summary(es):    Utilitarios para desarrollo de binarios de la GNU
4 Summary(fr):    Utilitaires de développement binaire de GNU
5 Summary(pl):    Narzêdzia GNU dla programistów
6 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU
7 Summary(tr):    GNU geliþtirme araçlarý
8 Name:           binutils
9 Version:        2.11.90.0.19
10 Release:        5
11 Epoch:          2
12 License:        GPL
13 Group:          Development/Tools
14 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
15 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-sparc_unaligned_reloc.patch
18 Patch2:         %{name}-preserve_e_flags.patch
19 Patch3:         %{name}-getopt.patch
20 URL:            http://sourceware.cygnus.com/binutils/
21 Prereq:         /sbin/ldconfig
22 BuildRequires:  flex
23 BuildRequires:  bison
24 BuildRequires:  perl-devel
25 %ifarch sparc sparc32
26 BuildRequires:  sparc32
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Binutils is a collection of binary utilities, including:
32 - ar - create, modify and extract from archives,
33 - nm - lists symbols from object files,
34 - objcopy - copy and translate object files,
35 - objdump - display information from object files,
36 - ranlib - generate an index for the contents of an archive,
37 - size - list the section sizes of an object or archive file,
38 - strings - list printable strings from files,
39 - strip - discard symbols,
40 - addr2line - convert addresses to file and line,
41 - nlmconv - convert object code into an NLM.
42
43 %description -l pl
44 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
45 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
46 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
47 programów i bibliotek.
48
49 %description -l es
50 binutils es una colectánea de utilitarios necesarios para compilar
51 programas. Incluye assembler y linker, así como varios otros programas
52 para trabajar con formatos que se puedan ejecutar.
53
54 %description -l pt_BR
55 binutils é uma coletânea de utilitários necessários para compilar
56 programas. Inclui assembler e linker, assim como vários outros
57 programas para trabalhar com formatos executáveis.
58
59 %package static
60 Summary:        GNU Binutils static libraries
61 Summary(pl):    Biblioteki statyczne do GNU Binutils
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}
64
65 %description static
66 Static libraries for GNU Binutils.
67
68 %description -l pl static
69 Biblioteki statyczne GNU Binutils.
70
71 %prep
72 %setup -q 
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p0
76 %patch3 -p1
77
78 %build
79 CFLAGS="%{rpmcflags}"
80 export CFLAGS
81 %ifarch sparc 
82 sparc32 \
83 %endif
84 ./configure %{_target_platform} \
85         --enable-shared \
86         --disable-debug \
87         --prefix=%{_prefix} \
88         --infodir=%{_infodir} \
89         --mandir=%{_mandir} \
90 %ifarch sparc
91         --enable-targets=sparc64-linux
92 %endif
93
94 %{__make} tooldir=%{_prefix} all info
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_prefix}
99
100 %{__make} install install-info \
101         prefix=$RPM_BUILD_ROOT%{_prefix} \
102         tooldir=$RPM_BUILD_ROOT%{_prefix} \
103         mandir=$RPM_BUILD_ROOT%{_mandir} \
104         infodir=$RPM_BUILD_ROOT%{_infodir} \
105         includedir=$RPM_BUILD_ROOT%{_includedir} \
106         libdir=$RPM_BUILD_ROOT%{_libdir}
107
108 # these are already in gcc-g++
109 rm -f $RPM_BUILD_ROOT%{_bindir}/c++filt $RPM_BUILD_ROOT%{_mandir}/man1/c++filt*
110
111 rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
112
113 # remove these man pages unless we cross-build for win*/netware platforms.
114 # however, this should be done in Makefiles.
115 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
116
117 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}/
118
119 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post
125 /sbin/ldconfig
126 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
127
128 %postun
129 /sbin/ldconfig
130 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
131
132 %files
133 %defattr(644,root,root,755)
134 %doc README
135 %attr(755,root,root) %{_bindir}/*
136 %attr(755,root,root) %{_libdir}/*.so
137 %{_libdir}/libiberty.a
138
139 %{_libdir}/ldscripts
140 %{_includedir}/*.h
141
142 %{_infodir}/*info*
143 %{_mandir}/man1/*
144 %lang(cs) %{_mandir}/cs/man1/*
145 %lang(de) %{_mandir}/de/man1/*
146 %lang(es) %{_mandir}/es/man1/*
147 %lang(fi) %{_mandir}/fi/man1/*
148 %lang(fr) %{_mandir}/fr/man1/*
149 %lang(hu) %{_mandir}/hu/man1/*
150 %lang(ja) %{_mandir}/ja/man1/*
151 %lang(pl) %{_mandir}/pl/man1/*
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/lib[^i]*.a
This page took 0.042211 seconds and 4 git commands to generate.