]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- fix -o in strip; release 4
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(de):    GNU Binary Utility Development Utilities
3 Summary(es):    Utilitarios para desarrollo de binarios de la GNU
4 Summary(fr):    Utilitaires de développement binaire de GNU
5 Summary(pl):    Narzêdzia GNU dla programistów
6 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU
7 Summary(tr):    GNU geliþtirme araçlarý
8 Name:           binutils
9 Version:        2.11.90.0.19
10 Release:        4
11 Epoch:          2
12 License:        GPL
13 Group:          Development/Tools
14 Group(de):      Entwicklung/Werkzeuge
15 Group(es):      Desarrollo/Herramientas
16 Group(fr):      Development/Outils
17 Group(pl):      Programowanie/Narzêdzia
18 Group(pt):      Desenvolvimento/Ferramentas
19 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
20 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
21 Patch0:         %{name}-info.patch
22 Patch1:         %{name}-sparc_unaligned_reloc.patch
23 Patch2:         %{name}-preserve_e_flags.patch
24 Patch3:         %{name}-getopt.patch
25 URL:            http://sourceware.cygnus.com/binutils/
26 Prereq:         /sbin/ldconfig
27 BuildRequires:  flex
28 BuildRequires:  bison
29 BuildRequires:  perl-devel
30 %ifarch sparc sparc32
31 BuildRequires:  sparc32
32 %endif
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Binutils is a collection of binary utilities, including:
37 - ar - create, modify and extract from archives,
38 - nm - lists symbols from object files,
39 - objcopy - copy and translate object files,
40 - objdump - display information from object files,
41 - ranlib - generate an index for the contents of an archive,
42 - size - list the section sizes of an object or archive file,
43 - strings - list printable strings from files,
44 - strip - discard symbols,
45 - addr2line - convert addresses to file and line,
46 - nlmconv - convert object code into an NLM.
47
48 %description -l pl
49 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
50 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
51 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
52 programów i bibliotek.
53
54 %description -l es
55 binutils es una colectánea de utilitarios necesarios para compilar
56 programas. Incluye assembler y linker, así como varios otros programas
57 para trabajar con formatos que se puedan ejecutar.
58
59 %description -l pt_BR
60 binutils é uma coletânea de utilitários necessários para compilar
61 programas. Inclui assembler e linker, assim como vários outros
62 programas para trabalhar com formatos executáveis.
63
64 %package static
65 Summary:        GNU Binutils static libraries
66 Summary(pl):    Biblioteki statyczne do GNU Binutils
67 Group:          Development/Libraries
68 Group(de):      Entwicklung/Bibliotheken
69 Group(es):      Desarrollo/Bibliotecas
70 Group(fr):      Development/Librairies
71 Group(pl):      Programowanie/Biblioteki
72 Group(pt_BR):   Desenvolvimento/Bibliotecas
73 Group(pt):      Desenvolvimento/Bibliotecas
74 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
75 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
76 Requires:       %{name} = %{version}
77
78 %description static
79 Static libraries for GNU Binutils.
80
81 %description -l pl static
82 Biblioteki statyczne GNU Binutils.
83
84 %prep
85 %setup -q 
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p0
89 %patch3 -p1
90
91 %build
92 CFLAGS="%{rpmcflags}"
93 export CFLAGS
94 %ifarch sparc 
95 sparc32 \
96 %endif
97 ./configure %{_target_platform} \
98         --enable-shared \
99         --disable-debug \
100         --prefix=%{_prefix} \
101         --infodir=%{_infodir} \
102         --mandir=%{_mandir} \
103 %ifarch sparc
104         --enable-targets=sparc64-linux
105 %endif
106
107 %{__make} tooldir=%{_prefix} all info
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_prefix}
112
113 %{__make} install install-info \
114         prefix=$RPM_BUILD_ROOT%{_prefix} \
115         tooldir=$RPM_BUILD_ROOT%{_prefix} \
116         mandir=$RPM_BUILD_ROOT%{_mandir} \
117         infodir=$RPM_BUILD_ROOT%{_infodir} \
118         includedir=$RPM_BUILD_ROOT%{_includedir} \
119         libdir=$RPM_BUILD_ROOT%{_libdir}
120
121 # these are already in gcc-g++
122 rm -f $RPM_BUILD_ROOT%{_bindir}/c++filt $RPM_BUILD_ROOT%{_mandir}/man1/c++filt*
123
124 rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
125
126 # remove these man pages unless we cross-build for win*/netware platforms.
127 # however, this should be done in Makefiles.
128 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
129
130 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}/
131
132 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
133
134 gzip -9nf README
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 /sbin/ldconfig
141 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
142
143 %postun
144 /sbin/ldconfig
145 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
146
147 %files
148 %defattr(644,root,root,755)
149 %doc *.gz
150 %attr(755,root,root) %{_bindir}/*
151 %attr(755,root,root) %{_libdir}/*.so
152
153 %{_libdir}/ldscripts
154 %{_includedir}/*.h
155
156 %{_infodir}/*info*
157 %{_mandir}/man1/*
158 %lang(cs) %{_mandir}/cs/man1/*
159 %lang(de) %{_mandir}/de/man1/*
160 %lang(es) %{_mandir}/es/man1/*
161 %lang(fi) %{_mandir}/fi/man1/*
162 %lang(fr) %{_mandir}/fr/man1/*
163 %lang(hu) %{_mandir}/hu/man1/*
164 %lang(ja) %{_mandir}/ja/man1/*
165 %lang(pl) %{_mandir}/pl/man1/*
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/lib*.a
This page took 0.041317 seconds and 4 git commands to generate.