]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
up to 2.40
[packages/binutils.git] / binutils.spec
1 # TODO: PR/26302 <https://sourceware.org/bugzilla/show_bug.cgi?id=26302> (breaks kernel-tools build)
2 #
3 # Conditional build:
4 %bcond_with     allarchs        # enable all targets
5 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
6                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
7 %bcond_with     pax             # without PaX flags (for upstream bugreports)
8 %bcond_without  gold            # don't build gold (no C++ dependencies)
9 %bcond_without  default_bfd     # default ld.bfd instead of gold
10 %bcond_without  debuginfod      # debuginfo lokups with debuginfod
11 %bcond_without  gprofng         # gprofng
12 %bcond_without  jansson         # Package Metadata embedding support
13 %bcond_without  msgpack         # msgpack support
14 %bcond_with     tests           # check target
15
16 %ifnarch %{ix86} %{x8664} x32 aarch64 %{arm}
17 %undefine       with_gold
18 %endif
19 %ifnarch %{ix86} %{x8664} aarch64
20 %undefine       with_gprofng    1
21 %endif
22
23 Summary:        GNU Binary Utility Development Utilities
24 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
25 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
26 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
27 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
28 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
29 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
30 Summary(tr.UTF-8):      GNU geliştirme araçları
31 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
32 Name:           binutils
33 Version:        2.40
34 Release:        1
35 Epoch:          4
36 License:        GPL v3+
37 Group:          Development/Tools
38 Source0:        https://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
39 # Source0-md5:  be3411283c27eb0984104a2fda12e102
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
42 Patch1:         %{name}-info.patch
43 Patch2:         %{name}-libtool-relink.patch
44 Patch3:         %{name}-pt_pax_flags.patch
45
46 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
47 Patch7:         %{name}-libtool-m.patch
48 Patch9:         %{name}-tooldir.patch
49 Patch10:        %{name}-sanity-check.patch
50 URL:            http://www.sourceware.org/binutils/
51 BuildRequires:  autoconf >= 2.69
52 BuildRequires:  automake >= 1:1.11
53 BuildRequires:  bison
54 %{?with_debuginfod:BuildRequires:       elfutils-debuginfod-devel >= 0.179}
55 BuildRequires:  flex
56 BuildRequires:  gettext-tools
57 %{?with_jansson:BuildRequires:  jansson-devel}
58 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
59 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
60 BuildRequires:  lzip
61 %{?with_msgpack:BuildRequires:  msgpack-devel}
62 BuildRequires:  perl-tools-pod
63 BuildRequires:  pkgconfig
64 BuildRequires:  rpmbuild(macros) >= 1.527
65 %ifarch sparc sparc32
66 BuildRequires:  sparc32
67 %endif
68 BuildRequires:  tar >= 1:1.22
69 BuildRequires:  texinfo >= 4.2
70 BuildRequires:  zlib-devel
71 %{?with_tests:BuildRequires:    zlib-static}
72 BuildRequires:  zstd-devel
73 %{?with_debuginfod:Requires:    elfutils-debuginfod-libs >= 0.179}
74 Conflicts:      gcc-c++ < 5:3.3
75 Conflicts:      modutils < 2.4.17
76 Conflicts:      rpmbuild(macros) < 1.660
77 Obsoletes:      binutils-gold
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Binutils is a collection of binary utilities, including:
82 - ar - create, modify and extract from archives,
83 - nm - lists symbols from object files,
84 - objcopy - copy and translate object files,
85 - objdump - display information from object files,
86 - ranlib - generate an index for the contents of an archive,
87 - size - list the section sizes of an object or archive file,
88 - strings - list printable strings from files,
89 - strip - discard symbols,
90 - addr2line - convert addresses to file and line.
91
92 %description -l es.UTF-8
93 Binutils es una colección de utilitarios necesarios para compilar
94 programas. Incluye assembler y linker, así como varios otros programas
95 para trabajar con formatos que se puedan ejecutar.
96
97 %description -l pl.UTF-8
98 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
99 programów. Znajdują się tutaj między innymi assembler, konsolidator
100 (linker), a także inne narzędzia do manipulowania binarnymi plikami
101 programów i bibliotek.
102
103 %description -l pt_BR.UTF-8
104 binutils é uma coletânea de utilitários necessários para compilar
105 programas. Inclui assembler e linker, assim como vários outros
106 programas para trabalhar com formatos executáveis.
107
108 %description -l ru.UTF-8
109 binutils - это набор инструментов, необходимых для компилляции
110 программ. Включает ассемблер, компоновщик и набор других программ для
111 работы с исполняемыми файлами разнообразных форматов.
112
113 %description -l uk.UTF-8
114 binutils - це набір інструментів, необхідних для компіляції програм.
115 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
116 виконуваними файлами різних форматів.
117
118 %package libs
119 Summary:        GNU binutils shared libraries
120 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
121 Group:          Libraries
122 Conflicts:      binutils < 3:2.17.50.0.8-3
123
124 %description libs
125 GNU binutils shared libraries (libbfd, libopcodes).
126
127 %description libs -l pl.UTF-8
128 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
129
130 %package devel
131 Summary:        Development files for GNU binutils libraries
132 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
133 Group:          Development/Libraries
134 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
135
136 %description devel
137 Development files for GNU binutils libraries (libbfd, libopcodes) and
138 static libiberty library.
139
140 %description devel -l pl.UTF-8
141 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
142 statyczna biblioteka libiberty.
143
144 %package static
145 Summary:        GNU binutils static libraries
146 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 #Requires:      zlib-static
150
151 %description static
152 Static GNU binutils libraries (libbfd, libopcodes).
153
154 %description static -l pl.UTF-8
155 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
156
157 %prep
158 %setup -q
159 %patch1 -p1
160 %patch2 -p1
161 %{?with_pax:%patch3 -p1}
162
163 %patch6 -p1
164 %patch7 -p1
165 %patch9 -p1
166 %patch10 -p1
167
168 %{__sed} -i -e '1s,.*env perl,#!%{__perl},' gprofng/gp-display-html/gp-display-html.in
169
170 # file contains hacks for ac 2.69 only
171 %{__rm} config/override.m4
172
173 %build
174 %{__aclocal}
175 %{__autoconf}
176
177 # non-standard regeneration
178 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
179 for dir in gas bfd; do
180         cd $dir || exit 1
181         %{__aclocal} -I .. -I ../config -I ../bfd
182         %{__automake} Makefile
183         test -f doc/Makefile.am && %{__automake} doc/Makefile
184         %{__autoconf}
185         cd ..
186 done
187
188 # More targets
189 TARGETS=
190 %ifarch ia64
191 TARGETS=i686-linux
192 %endif
193 # uhm?
194 %ifarch %{ix86}
195 TARGETS=x86_64-linux
196 %endif
197 %ifarch sparc
198 TARGETS=sparc64-linux
199 %endif
200 %ifarch %{x8664}
201 TARGETS="x86_64-pep"
202 %endif
203 %ifarch x32
204 TARGETS="x86_64-linux,x86_64-pep"
205 %endif
206 %{?addtargets:TARGETS="%{addtargets}"}
207
208 cp -f /usr/share/automake/config.* .
209 CFLAGS="%{rpmcflags}"; export CFLAGS
210 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
211 CC="%{__cc}"; export CC
212 CXX="%{__cxx}"; export CXX
213 %ifarch sparc
214 sparc32 \
215 %endif
216 ./configure %{_target_platform} \
217         --prefix=%{_prefix} \
218         --libdir=%{_libdir} \
219         --infodir=%{_infodir} \
220         --mandir=%{_mandir} \
221         --sysconfdir=%{_sysconfdir} \
222         --disable-debug \
223         --disable-silent-rules \
224         --disable-werror \
225 %ifarch sparc
226         --enable-64-bit-bfd \
227 %else
228         %{?with_allarchs:--enable-64-bit-bfd} \
229 %endif
230         --enable-build-warnings=,-Wno-missing-prototypes \
231         --enable-install-libiberty \
232         --enable-lto \
233         --enable-plugins \
234         --enable-shared \
235         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
236         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
237         --with-tooldir=%{_prefix} \
238         --with-zlib \
239 %if %{with gold}
240         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
241 %endif
242         %{__enable_disable msgpack} \
243         %{__enable_disable jansson} \
244         %{__with_without debuginfod}
245
246 %{__make}
247
248 %{?with_tests:%{__make} -j1 check}
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
253
254 %{__make} -j1 install \
255         DESTDIR=$RPM_BUILD_ROOT
256
257 # remove these man pages unless we cross-build for win*/netware platforms.
258 # however, this should be done in Makefiles.
259 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,windmc,windres}.1
260
261 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
262
263 # overwrite libiberty.a with PIC version
264 cp -pf libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
265
266 # remove evil -L pointing inside builder's home
267 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
268
269 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
270
271 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
272
273 %if %{with gold}
274 install -d gold-doc
275 cp -p gold/{README,ChangeLog,TODO} gold-doc
276 %endif
277
278 %find_lang bfd
279 %find_lang binutils
280 %find_lang gas
281 %find_lang gprof
282 touch ld.lang gold.lang
283 %find_lang ld
284 %if %{with gold}
285 %find_lang gold
286 %endif
287 %find_lang opcodes
288 cat bfd.lang opcodes.lang > %{name}-libs.lang
289 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
290
291 %clean
292 rm -rf $RPM_BUILD_ROOT
293
294 %post   -p /sbin/postshell
295 -/usr/sbin/fix-info-dir -c %{_infodir}
296
297 %postun -p /sbin/postshell
298 -/usr/sbin/fix-info-dir -c %{_infodir}
299
300 %post   libs -p /sbin/ldconfig
301 %postun libs -p /sbin/ldconfig
302
303 %post   devel -p /sbin/postshell
304 -/usr/sbin/fix-info-dir -c %{_infodir}
305
306 %postun devel -p /sbin/postshell
307 -/usr/sbin/fix-info-dir -c %{_infodir}
308
309 %files -f %{name}.lang
310 %defattr(644,root,root,755)
311 %doc README
312 %{?with_gold:%doc gold-doc}
313 %{?with_gprofng:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gprofng.rc}
314 %attr(755,root,root) %{_bindir}/addr2line
315 %attr(755,root,root) %{_bindir}/ar
316 %attr(755,root,root) %{_bindir}/as
317 %attr(755,root,root) %{_bindir}/c++filt
318 %attr(755,root,root) %{_bindir}/elfedit
319 %if %{with gprofng}
320 %attr(755,root,root) %{_bindir}/gp-archive
321 %attr(755,root,root) %{_bindir}/gp-collect-app
322 %attr(755,root,root) %{_bindir}/gp-display-html
323 %attr(755,root,root) %{_bindir}/gp-display-src
324 %attr(755,root,root) %{_bindir}/gp-display-text
325 %attr(755,root,root) %{_bindir}/gprofng
326 %endif
327 %attr(755,root,root) %{_bindir}/gprof
328 %attr(755,root,root) %{_bindir}/ld
329 %attr(755,root,root) %{_bindir}/ld.bfd
330 %if %{with gold}
331 %attr(755,root,root) %{_bindir}/ld.gold
332 %attr(755,root,root) %{_bindir}/dwp
333 %endif
334 %attr(755,root,root) %{_bindir}/nm
335 %attr(755,root,root) %{_bindir}/objcopy
336 %attr(755,root,root) %{_bindir}/objdump
337 %attr(755,root,root) %{_bindir}/ranlib
338 %attr(755,root,root) %{_bindir}/readelf
339 %attr(755,root,root) %{_bindir}/size
340 %attr(755,root,root) %{_bindir}/strings
341 %attr(755,root,root) %{_bindir}/strip
342 %if %{with gprofng}
343 %dir %{_libdir}/gprofng
344 %attr(755,root,root) %{_libdir}/gprofng/libgp-collector.so
345 %attr(755,root,root) %{_libdir}/gprofng/libgp-collectorAPI.so
346 %attr(755,root,root) %{_libdir}/gprofng/libgp-heap.so
347 %attr(755,root,root) %{_libdir}/gprofng/libgp-iotrace.so
348 %attr(755,root,root) %{_libdir}/gprofng/libgp-sync.so
349 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.*.*.*
350 %attr(755,root,root) %{_libdir}/gprofng/libgprofng.so.0
351 %endif
352 %{_prefix}/lib/ldscripts
353 %{_infodir}/as.info*
354 %{_infodir}/binutils.info*
355 %{_infodir}/ctf-spec.info*
356 %{_infodir}/gprof.info*
357 %{?with_gprofng:%{_infodir}/gprofng.info*}
358 %{_infodir}/ld.info*
359 %{_infodir}/sframe-spec.info*
360 %{_mandir}/man1/addr2line.1*
361 %{_mandir}/man1/ar.1*
362 %{_mandir}/man1/as.1*
363 %{_mandir}/man1/c++filt.1*
364 %{_mandir}/man1/elfedit.1*
365 %if %{with gprofng}
366 %{_mandir}/man1/gp-archive.*
367 %{_mandir}/man1/gp-collect-app.*
368 %{_mandir}/man1/gp-display-html.*
369 %{_mandir}/man1/gp-display-src.*
370 %{_mandir}/man1/gp-display-text.*
371 %{_mandir}/man1/gprofng.1*
372 %endif
373 %{_mandir}/man1/gprof.1*
374 %{_mandir}/man1/ld.1*
375 %{_mandir}/man1/nm.1*
376 %{_mandir}/man1/objcopy.1*
377 %{_mandir}/man1/objdump.1*
378 %{_mandir}/man1/ranlib.1*
379 %{_mandir}/man1/readelf.1*
380 %{_mandir}/man1/size.1*
381 %{_mandir}/man1/strings.1*
382 %{_mandir}/man1/strip.1*
383 %lang(cs) %{_mandir}/cs/man1/*
384 %lang(de) %{_mandir}/de/man1/*
385 %lang(es) %{_mandir}/es/man1/*
386 %lang(fi) %{_mandir}/fi/man1/*
387 %lang(fr) %{_mandir}/fr/man1/*
388 %lang(hu) %{_mandir}/hu/man1/*
389 %lang(ja) %{_mandir}/ja/man1/*
390 %lang(pl) %{_mandir}/pl/man1/*
391
392 %files libs -f %{name}-libs.lang
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_libdir}/libbfd-%{version}.so
395 %attr(755,root,root) %{_libdir}/libctf.so.*.*
396 %attr(755,root,root) %ghost %{_libdir}/libctf.so.0
397 %attr(755,root,root) %{_libdir}/libctf-nobfd.so.*.*
398 %attr(755,root,root) %ghost %{_libdir}/libctf-nobfd.so.0
399 %attr(755,root,root) %{_libdir}/libopcodes-%{version}.so
400 %attr(755,root,root) %{_libdir}/libsframe.so.*.*
401 %attr(755,root,root) %ghost %{_libdir}/libsframe.so.0
402 %dir %{_libdir}/bfd-plugins
403 %attr(755,root,root) %{_libdir}/bfd-plugins/libdep.so
404
405 %files devel
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/libbfd.so
408 %attr(755,root,root) %{_libdir}/libctf.so
409 %attr(755,root,root) %{_libdir}/libctf-nobfd.so
410 %attr(755,root,root) %{_libdir}/libopcodes.so
411 %attr(755,root,root) %{_libdir}/libsframe.so
412 %{?with_gprofng:%attr(755,root,root) %{_libdir}/gprofng/libgprofng.so}
413 %{_libdir}/libbfd.la
414 %{_libdir}/libctf.la
415 %{_libdir}/libctf-nobfd.la
416 %{_libdir}/libopcodes.la
417 %{_libdir}/libiberty.a
418 %{_libdir}/libsframe.la
419 %{_includedir}/ansidecl.h
420 %{_includedir}/bfd.h
421 %{_includedir}/bfdlink.h
422 %{_includedir}/ctf-api.h
423 %{_includedir}/ctf.h
424 %{_includedir}/diagnostics.h
425 %{_includedir}/dis-asm.h
426 %{_includedir}/plugin-api.h
427 %{_includedir}/sframe-api.h
428 %{_includedir}/sframe.h
429 %{_includedir}/symcat.h
430 %{_includedir}/libiberty
431 %if %{with gprofng}
432 %{_includedir}/collectorAPI.h
433 %{_includedir}/libcollector.h
434 %{_includedir}/libfcollector.h
435 %endif
436 %{_infodir}/bfd.info*
437
438 %files static
439 %defattr(644,root,root,755)
440 %{_libdir}/libbfd.a
441 %{_libdir}/libctf.a
442 %{_libdir}/libctf-nobfd.a
443 %{_libdir}/libopcodes.a
444 %{_libdir}/libsframe.a
This page took 0.070244 seconds and 4 git commands to generate.