]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- added man-pages tar URL
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(de):    GNU Binary Utility Development Utilities
3 Summary(es):    Utilitarios para desarrollo de binarios de la GNU
4 Summary(fr):    Utilitaires de développement binaire de GNU
5 Summary(pl):    Narzêdzia GNU dla programistów
6 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU
7 Summary(tr):    GNU geliþtirme araçlarý
8 Name:           binutils
9 Version:        2.11.90.0.19
10 Release:        3
11 Epoch:          2
12 License:        GPL
13 Group:          Development/Tools
14 Group(de):      Entwicklung/Werkzeuge
15 Group(fr):      Development/Outils
16 Group(pl):      Programowanie/Narzêdzia
17 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
18 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
19 Patch0:         %{name}-info.patch
20 Patch1:         %{name}-sparc_unaligned_reloc.patch
21 Patch2:         %{name}-preserve_e_flags.patch
22 URL:            http://sourceware.cygnus.com/binutils/
23 Prereq:         /sbin/ldconfig
24 BuildRequires:  flex
25 BuildRequires:  bison
26 BuildRequires:  perl-devel
27 %ifarch sparc sparc32
28 BuildRequires:  sparc32
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Binutils is a collection of binary utilities, including:
34 - ar - create, modify and extract from archives,
35 - nm - lists symbols from object files,
36 - objcopy - copy and translate object files,
37 - objdump - display information from object files,
38 - ranlib - generate an index for the contents of an archive,
39 - size - list the section sizes of an object or archive file,
40 - strings - list printable strings from files,
41 - strip - discard symbols,
42 - addr2line - convert addresses to file and line,
43 - nlmconv - convert object code into an NLM.
44
45 %description -l pl
46 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
47 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
48 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
49 programów i bibliotek.
50
51 %description -l es
52 binutils es una colectánea de utilitarios necesarios para compilar
53 programas. Incluye assembler y linker, así como varios otros programas
54 para trabajar con formatos que se puedan ejecutar.
55
56 %description -l pt_BR
57 binutils é uma coletânea de utilitários necessários para compilar
58 programas. Inclui assembler e linker, assim como vários outros
59 programas para trabalhar com formatos executáveis.
60
61 %package static
62 Summary:        GNU Binutils static libraries
63 Summary(pl):    Biblioteki statyczne do GNU Binutils
64 Group:          Development/Libraries
65 Group(de):      Entwicklung/Libraries
66 Group(es):      Desarrollo/Bibliotecas
67 Group(fr):      Development/Librairies
68 Group(pl):      Programowanie/Biblioteki
69 Group(pt_BR):   Desenvolvimento/Bibliotecas
70 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
71 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
72 Requires:       %{name} = %{version}
73
74 %description static
75 Static libraries for GNU Binutils.
76
77 %description -l pl static
78 Biblioteki statyczne GNU Binutils.
79
80 %prep
81 %setup -q 
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p0
85
86 %build
87 CFLAGS="%{rpmcflags}"
88 export CFLAGS
89 %ifarch sparc 
90 sparc32 \
91 %endif
92 ./configure %{_target_platform} \
93         --enable-shared \
94         --disable-debug \
95         --prefix=%{_prefix} \
96         --infodir=%{_infodir} \
97         --mandir=%{_mandir} \
98 %ifarch sparc
99         --enable-targets=sparc64-linux
100 %endif
101
102 %{__make} tooldir=%{_prefix} all info
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT%{_prefix}
107
108 %{__make} install install-info \
109         prefix=$RPM_BUILD_ROOT%{_prefix} \
110         tooldir=$RPM_BUILD_ROOT%{_prefix} \
111         mandir=$RPM_BUILD_ROOT%{_mandir} \
112         infodir=$RPM_BUILD_ROOT%{_infodir} \
113         includedir=$RPM_BUILD_ROOT%{_includedir} \
114         libdir=$RPM_BUILD_ROOT%{_libdir}
115
116 # these are already in gcc-g++
117 rm -f $RPM_BUILD_ROOT%{_bindir}/c++filt $RPM_BUILD_ROOT%{_mandir}/man1/c++filt*
118
119 rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
120
121 # remove these man pages unless we cross-build for win*/netware platforms.
122 # however, this should be done in Makefiles.
123 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
124
125 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}/
126
127 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
128
129 gzip -9nf README
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 /sbin/ldconfig
136 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
137
138 %postun
139 /sbin/ldconfig
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
141
142 %files
143 %defattr(644,root,root,755)
144 %doc *.gz
145 %attr(755,root,root) %{_bindir}/*
146 %attr(755,root,root) %{_libdir}/*.so
147
148 %{_libdir}/ldscripts
149 %{_includedir}/*.h
150
151 %{_infodir}/*info*
152 %{_mandir}/man1/*
153 %lang(cs) %{_mandir}/cs/man1/*
154 %lang(de) %{_mandir}/de/man1/*
155 %lang(es) %{_mandir}/es/man1/*
156 %lang(fi) %{_mandir}/fi/man1/*
157 %lang(fr) %{_mandir}/fr/man1/*
158 %lang(hu) %{_mandir}/hu/man1/*
159 %lang(ja) %{_mandir}/ja/man1/*
160 %lang(pl) %{_mandir}/pl/man1/*
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/lib*.a
This page took 0.120031 seconds and 4 git commands to generate.