]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- some pld.org.pl->pld-linux.org cosmetics
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(de):    GNU Binary Utility Development Utilities
3 Summary(es):    Utilitarios para desarrollo de binarios de la GNU
4 Summary(fr):    Utilitaires de développement binaire de GNU
5 Summary(pl):    Narzêdzia GNU dla programistów
6 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU
7 Summary(tr):    GNU geliþtirme araçlarý
8 Name:           binutils
9 Version:        2.13.90.0.10
10 Release:        1
11 Epoch:          2
12 License:        GPL
13 Group:          Development/Tools
14 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
15 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
16 Patch0:         %{name}-info.patch
17 URL:            http://sourceware.cygnus.com/binutils/
18 Prereq:         /sbin/ldconfig
19 BuildRequires:  automake
20 BuildRequires:  flex
21 BuildRequires:  bison
22 BuildRequires:  perl-devel
23 %ifarch sparc sparc32
24 BuildRequires:  sparc32
25 %endif
26 Conflicts:      modutils < 2.4.17
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Binutils is a collection of binary utilities, including:
31 - ar - create, modify and extract from archives,
32 - nm - lists symbols from object files,
33 - objcopy - copy and translate object files,
34 - objdump - display information from object files,
35 - ranlib - generate an index for the contents of an archive,
36 - size - list the section sizes of an object or archive file,
37 - strings - list printable strings from files,
38 - strip - discard symbols,
39 - addr2line - convert addresses to file and line,
40 - nlmconv - convert object code into an NLM.
41
42 %description -l pl
43 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
44 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
45 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
46 programów i bibliotek.
47
48 %description -l es
49 binutils es una colectánea de utilitarios necesarios para compilar
50 programas. Incluye assembler y linker, así como varios otros programas
51 para trabajar con formatos que se puedan ejecutar.
52
53 %description -l pt_BR
54 binutils é uma coletânea de utilitários necessários para compilar
55 programas. Inclui assembler e linker, assim como vários outros
56 programas para trabalhar com formatos executáveis.
57
58 %package static
59 Summary:        GNU Binutils static libraries
60 Summary(pl):    Biblioteki statyczne do GNU Binutils
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}
63
64 %description static
65 Static libraries for GNU Binutils.
66
67 %description -l pl static
68 Biblioteki statyczne GNU Binutils.
69
70 %prep
71 %setup -q 
72 %patch0 -p1
73
74 %build
75 cp -f /usr/share/automake/config.* .
76 CFLAGS="%{rpmcflags}"; export CFLAGS
77 CC="%{__cc}"; export CC
78 %ifarch sparc 
79 sparc32 \
80 %endif
81 ./configure %{_target_platform} \
82         --enable-shared \
83         --disable-debug \
84         --prefix=%{_prefix} \
85         --infodir=%{_infodir} \
86         --mandir=%{_mandir} \
87 %ifarch sparc
88         --enable-targets=sparc64-linux
89 %endif
90
91 %{__make} tooldir=%{_prefix} all info
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{_prefix}
96
97 %{__make} install install-info \
98         prefix=$RPM_BUILD_ROOT%{_prefix} \
99         tooldir=$RPM_BUILD_ROOT%{_prefix} \
100         mandir=$RPM_BUILD_ROOT%{_mandir} \
101         infodir=$RPM_BUILD_ROOT%{_infodir} \
102         includedir=$RPM_BUILD_ROOT%{_includedir} \
103         libdir=$RPM_BUILD_ROOT%{_libdir}
104
105 # these are already in gcc-g++
106 rm -f $RPM_BUILD_ROOT%{_bindir}/c++filt $RPM_BUILD_ROOT%{_mandir}/man1/c++filt*
107
108 rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
109
110 # remove these man pages unless we cross-build for win*/netware platforms.
111 # however, this should be done in Makefiles.
112 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
113
114 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
115
116 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
117
118 %find_lang %{name} --all-name
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 /sbin/ldconfig
125 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
126
127 %postun
128 /sbin/ldconfig
129 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc README
134 %attr(755,root,root) %{_bindir}/*
135 %attr(755,root,root) %{_libdir}/*.so
136 %{_libdir}/libiberty.a
137 %{_libdir}/lib*.la
138
139 %{_libdir}/ldscripts
140 %{_includedir}/*.h
141
142 %{_infodir}/*info*
143 %{_mandir}/man1/*
144 %lang(cs) %{_mandir}/cs/man1/*
145 %lang(de) %{_mandir}/de/man1/*
146 %lang(es) %{_mandir}/es/man1/*
147 %lang(fi) %{_mandir}/fi/man1/*
148 %lang(fr) %{_mandir}/fr/man1/*
149 %lang(hu) %{_mandir}/hu/man1/*
150 %lang(ja) %{_mandir}/ja/man1/*
151 %lang(pl) %{_mandir}/pl/man1/*
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/lib[^i]*.a
This page took 0.052431 seconds and 3 git commands to generate.