]> git.pld-linux.org Git - packages/beryl-core.git/blob - beryl-core.spec
- up to 0.1.99.2
[packages/beryl-core.git] / beryl-core.spec
1 #
2 # Conditional build:
3 %bcond_without  beryl_mesa      # beryl-xgl statically linked with own libGL
4 #
5 Summary:        OpenGL window and compositing manager
6 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
7 Name:           beryl-core
8 Version:        0.1.99.2
9 Release:        1
10 Epoch:          1
11 License:        MIT
12 Group:          X11
13 Source0:        http://releases.beryl-project.org/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  e439403ce19130e37f46185a65465c9b
15 Source1:        http://releases.beryl-project.org/%{version}/beryl-mesa-%{version}.tar.bz2
16 # Source1-md5:  387d068091bc5c6fa28f6d754e1296d1
17 Patch0:         %{name}-link.patch
18 URL:            http://beryl-project.org/
19 BuildRequires:  GConf2-devel >= 2.0
20 BuildRequires:  OpenGL-GLX-devel
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  glib2-devel >= 2.0
24 BuildRequires:  intltool >= 0.35.0
25 BuildRequires:  libpng-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  startup-notification-devel >= 0.7
30 BuildRequires:  xorg-lib-libSM-devel
31 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.3
32 BuildRequires:  xorg-lib-libXdamage-devel
33 BuildRequires:  xorg-lib-libXinerama-devel
34 BuildRequires:  xorg-lib-libXrandr-devel
35 BuildRequires:  xorg-proto-glproto-devel
36 BuildRequires:  xorg-util-makedepend
37 Requires:       xorg-app-xvinfo
38 Provides:       compiz
39 Obsoletes:      compiz-quinnstorm
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Beryl is an OpenGL compositing manager that use
44 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
45 to texture objects. It has a flexible plug-in system and it is
46 designed to run well on most graphics hardware.
47
48 This is an enhanced version of compiz, developed mainly by Quinnstorm.
49 Some parts were optimized for speed and there were added few
50 additional plugins and patches, delivering even more eyecandy.
51
52 %description -l pl
53 Beryl jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
54 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
55 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
56 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
57
58 To jest udoskonalona wersja compiza, tworzona g³ównie przez
59 Quinnstorma. Niektóre czê¶ci zosta³y zoptymalizowane pod wzglêdem
60 prêdko¶ci oraz dodano kilka dodatkowych wtyczek i ³atek,
61 dostarczaj±cych jeszcze wiêcej ¶wiecide³ek.
62
63 %package devel
64 Summary:        Header files for beryl
65 Summary(pl):    Pliki nag³ówkowe dla beryla
66 Group:          X11/Development/Libraries
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68 Requires:       OpenGL-GLX-devel
69 Requires:       glib2-devel >= 2.0
70 Requires:       libpng-devel
71 Requires:       startup-notification-devel >= 0.7
72 Requires:       xorg-lib-libSM-devel
73 Requires:       xorg-lib-libXcomposite-devel >= 0.3
74 Requires:       xorg-lib-libXdamage-devel
75 Requires:       xorg-lib-libXinerama-devel
76 Requires:       xorg-lib-libXrandr-devel
77 Requires:       xorg-proto-glproto-devel
78 Obsoletes:      compiz-quinnstorm-devel
79
80 %description devel
81 Header files for beryl.
82
83 %description devel -l pl
84 Pliki nag³ówkowe dla beryla.
85
86 %package gconf
87 Summary:        GConf settings plugin for beryl
88 Summary(pl):    Wtyczka ustawieñ GConf dla beryla
89 Group:          Libraries
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91
92 %description gconf
93 GConf settings plugin for beryl.
94
95 %description gconf -l pl
96 Wtyczka ustawieñ GConf dla beryla.
97
98 %prep
99 %setup -q %{?with_beryl_mesa: -a1}
100 %patch0 -p1
101
102 mv -f po/{ca_ES,ca}.po
103 mv -f po/{es_ES,es}.po
104 mv -f po/{fr_FR,fr}.po
105 mv -f po/{hu_HU,hu}.po
106 mv -f po/{it_IT,it}.po
107 mv -f po/{ja_JP,ja}.po
108 mv -f po/{ko_KR,ko}.po
109 mv -f po/{pt_PT,pt}.po
110 mv -f po/{sv_SE,sv}.po
111 # sv_FI is identical to sv_SE
112
113 # NOTE: check the list after any upgrade!
114 cat > po/LINGUAS <<EOF
115 ca
116 es
117 es_AR
118 fr
119 hu
120 it
121 ja
122 ko
123 pt_BR
124 pt
125 sv
126 zh_CN
127 zh_HK
128 zh_TW
129 EOF
130
131 %build
132 %{__glib_gettextize}
133 %{__intltoolize} --automake
134 %{__libtoolize}
135 %{__aclocal}
136 %{__autoconf}
137 %{__autoheader}
138 %{__automake}
139
140 # bashisms inside
141 sed -i -e 's@^#! /bin/sh$@#!/bin/bash@' configure
142
143 %configure \
144         %{?with_beryl_mesa:--with-berylmesadir=beryl-mesa} \
145         --disable-static \
146         --enable-gconf
147
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 rm -f $RPM_BUILD_ROOT%{_libdir}/beryl/backends/*.la
157
158 # program removed
159 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/beryl-settings-dump.1
160
161 %find_lang %{name}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %files -f %{name}.lang
170 %defattr(644,root,root,755)
171 %doc AUTHORS README TODO
172 %attr(755,root,root) %{_bindir}/beryl*
173 %attr(755,root,root) %{_libdir}/libberyl*.so*
174 %dir %{_libdir}/beryl
175 %dir %{_libdir}/beryl/backends
176 %attr(755,root,root) %{_libdir}/beryl/backends/libini.so
177 %{_datadir}/beryl
178 %{_mandir}/man1/beryl.1*
179 %{_pkgconfigdir}/libberyldecoration.pc
180 %if %{with beryl_mesa}
181 %attr(755,root,root) %{_bindir}/beryl-xgl
182 %{_mandir}/man1/beryl-xgl.1*
183 %endif
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libberylsettings.so
188 %{_libdir}/libberylsettings.la
189 %{_includedir}/beryl
190 %{_pkgconfigdir}/beryl.pc
191 %{_pkgconfigdir}/berylsettings.pc
192 %{_mandir}/man3/*.3*
193
194 %files gconf
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/beryl/backends/libgconf.so
This page took 0.146343 seconds and 4 git commands to generate.