]> git.pld-linux.org Git - packages/beanshell.git/blob - beanshell.spec
- Version: 2.0b4
[packages/beanshell.git] / beanshell.spec
1 #
2 # Conditional build:
3 %bcond_without  bsf     # without BSF support
4 #
5 Summary:        BeanShell - Lightweight Scripting for Java
6 Summary(pl):    BeanShell - lekkie skrypty dla Javy
7 Name:           beanshell
8 Version:        2.0
9 %define _beta   b4
10 Release:        0.%{_beta}.1
11 License:        Sun Public License or LGPL
12 Group:          Development/Languages/Java
13 Source0:        http://www.beanshell.org/bsh-%{version}%{_beta}-src.jar
14 # Source0-md5:  49c9cc9872f26d562bffb1e5ec8aa377
15 URL:            http://www.beanshell.org/
16 %{?with_bsf:BuildRequires:      bsf}
17 BuildRequires:  ant >= 1.3
18 BuildRequires:  jdk >= 1.3
19 BuildRequires:  jpackage-utils
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 BuildRequires:  unzip
22 BuildRequires:  servlet
23 Requires:       jre >= 1.1
24 BuildArch:      noarch
25 ExclusiveArch:  i586 i686 pentium3 pentium4 athlon %{x8664} noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 BeanShell is a small, free, embeddable Java source interpreter with
30 object scripting language features, written in Java. BeanShell
31 dynamically executes standard Java syntax and extends it with common
32 scripting conveniences such as loose types, commands, and method
33 closures like those in Perl and JavaScript.
34
35 %description -l pl
36 BeanShell to ma³y, darmowy, osadzalny interpreter kodu ¼ród³owego Javy
37 z cechami obiektowych jêzyków skryptowych, napisany w Javie. BeanShell
38 dynamicznie wykonuje standardow± sk³adniê Javy i rozszerza j± o
39 popularne wygodne elementy skryptowe, takie jak lu¼ne typy, polecenia
40 i dope³nienia metod podobnie jak Perl czy JavaScript.
41
42 %package javadoc
43 Summary:        BeanShell API documentation
44 Summary(pl):    Dokumentacja API BeanShell
45 Group:          Documentation
46
47 %description javadoc
48 BeanShell API documentation.
49
50 %description javadoc -l pl
51 Dokumentacja API BeanShell.
52
53 %prep
54 %setup -q -n BeanShell-%{version}%{_beta} 
55
56 %build
57 export CLASSPATH="`build-classpath %{?with_bsf:bsf} servlet`"
58 export JAVA_HOME="%{java_home}"
59
60 ant jarall javadoc \
61         %{!?with_bsf:-Dexclude-bsf='bsh/util/BeanShellBSFEngine.java,TestBshBSF.java'}
62
63 cp -R docs/manual/html manual
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_javadir},%{_javadocdir}/%{name}-%{version}}
68
69 install dist/bsh-%{version}%{_beta}.jar $RPM_BUILD_ROOT%{_javadir}
70 ln -sf bsh-%{version}%{_beta}.jar $RPM_BUILD_ROOT%{_javadir}/bsh.jar
71
72 cp -R javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc asm/README-asm.txt bsf/README src/{*.html,*.txt}
80 %doc docs/{faq/faq.html,images,manual}
81 %{_javadir}/*.jar
82
83 %files javadoc
84 %defattr(644,root,root,755)
85 %doc %{_javadocdir}/%{name}-%{version}
This page took 0.060724 seconds and 4 git commands to generate.