]> git.pld-linux.org Git - packages/beanshell.git/blob - beanshell.spec
- s/jakarta-ant/ant/ in BR
[packages/beanshell.git] / beanshell.spec
1 #
2 # Conditional build:
3 %bcond_without  bsf     # without BSF support
4 #
5 Summary:        BeanShell - Lightweight Scripting for Java
6 Summary(pl):    BeanShell - lekkie skrypty dla Javy
7 Name:           beanshell
8 Version:        2.0
9 %define _beta   b2
10 Release:        0.%{_beta}.2
11 License:        Sun Public License or LGPL
12 Group:          Development/Languages/Java
13 Source0:        http://www.beanshell.org/bsh-%{version}%{_beta}-src.jar
14 # Source0-md5:  f9c938446e5d97b74fd37f3bdbebf84a
15 Patch0:         %{name}-jdk1.5.patch
16 URL:            http://www.beanshell.org/
17 %{?with_bsf:BuildRequires:      bsf}
18 BuildRequires:  ant >= 1.3
19 BuildRequires:  jdk >= 1.3
20 BuildRequires:  unzip
21 Requires:       jre >= 1.1
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 BeanShell is a small, free, embeddable Java source interpreter with
27 object scripting language features, written in Java. BeanShell
28 dynamically executes standard Java syntax and extends it with common
29 scripting conveniences such as loose types, commands, and method
30 closures like those in Perl and JavaScript.
31
32 %description -l pl
33 BeanShell to ma³y, darmowy, osadzalny interpreter kodu ¼ród³owego Javy
34 z cechami obiektowych jêzyków skryptowych, napisany w Javie. BeanShell
35 dynamicznie wykonuje standardow± sk³adniê Javy i rozszerza j± o
36 popularne wygodne elementy skryptowe, takie jak lu¼ne typy, polecenia
37 i dope³nienia metod podobnie jak Perl czy JavaScript.
38
39 %prep
40 %setup -q -c
41 %patch0 -p0
42
43 %build
44 cd BeanShell
45 ant jarall \
46         %{!?with_bsf:-Dexclude-bsf='bsh/util/BeanShellBSFEngine.java,TestBshBSF.java'}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_javadir}
51
52 cd BeanShell/dist
53 install bsh-*.jar $RPM_BUILD_ROOT%{_javadir}
54 ln -sf bsh-*.jar $RPM_BUILD_ROOT%{_javadir}/bsh.jar
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc BeanShell/{asm/README-asm.txt,bsf/README,docs/faq/faq.html,docs/images,docs/manual,src/{*.html,*.txt}}
62 %{_javadir}/*.jar
This page took 0.083797 seconds and 4 git commands to generate.