]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- updated for 0.2.16.3
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - mozilla extension?
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_without  apidocs         # don't build API documentation
10 %bcond_without  evolution       # don't include evolution support
11 %bcond_without  galago          # build without galago support
12 %bcond_without  gsf             # build without libgsf support
13 %bcond_without  gui             # don't build GNOME based GUI
14 %bcond_without  python          # don't build python libraries
15 %bcond_without  epiphany        # don't build epiphany extension
16 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
17 %bcond_with     thunderbird     # use Thunderbird backend
18 #
19 %if !%{with gui}
20 %undefine       with_evolution
21 %endif
22 #
23 Summary:        Beagle - An indexing subsystem
24 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
25 Name:           beagle
26 Version:        0.2.16.2
27 Release:        1
28 License:        Various
29 Group:          Libraries
30 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
31 # Source0-md5:  4cff44be5917bfce5f1c265039a60626
32 Patch0:         %{name}-desktop.patch
33 Patch1:         %{name}-crawl.patch
34 Patch2:         %{name}-kill_exec_a.patch
35 Patch3:         %{name}-configure.patch
36 Patch4:         %{name}-epiphany-2.18.patch
37 URL:            http://beagle-project.org/Main_Page
38 BuildRequires:  autoconf >= 2.52
39 BuildRequires:  automake
40 BuildRequires:  chmlib-devel
41 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
42 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
43 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
44 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
45 #BuildRequires: dotnet-gst-sharp-devel
46 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
47 %if %{with epiphany} 
48 BuildRequires:  epiphany-devel >= 2.18.0
49 %endif
50 BuildRequires:  gtk+2-devel >= 2:2.10.10
51 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
52 BuildRequires:  libexif-devel >= 0.6.13
53 BuildRequires:  librsvg-devel >= 1:2.16.1
54 BuildRequires:  libpng-devel
55 BuildRequires:  libtool
56 BuildRequires:  libxml2-devel >= 1:2.6.27
57 BuildRequires:  mono-csharp >= 1.1.13.5
58 %{?with_python:BuildRequires:   python-pygtk-devel >= 2:2.10.4}
59 BuildRequires:  pkgconfig
60 BuildRequires:  perl-XML-Parser
61 BuildRequires:  python-devel
62 %if %{with sqlite3}
63 BuildRequires:  sqlite3-devel >= 3.3.4
64 %else
65 BuildRequires:  sqlite-devel
66 %endif
67 BuildRequires:  wv-devel >= 1.2.4
68 BuildRequires:  xorg-lib-libXScrnSaver-devel
69 BuildRequires:  zip
70 # GUI BRs
71 %if %{with gui}
72 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
73 BuildRequires:  gnome-vfs2-devel >= 2.18.0.1
74 %endif
75 Requires:       %{name}-libs = %{version}-%{release}
76 Requires:       dotnet-gmime-sharp >= 2.2.3
77 %if %{with sqlite3}
78 Requires:       sqlite3
79 %else
80 Requires:       sqlite
81 %endif
82 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
83 ExcludeArch:    i386
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 Beagle is an indexing sub-system and search aggregator built on top of
88 Lucene.Net.
89
90 %description -l pl.UTF-8
91 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
92 bazie Lucene.Net.
93
94 %package libs
95 Summary:        Beagle libraries
96 Summary(pl.UTF-8):      Bibiloteki Beagle
97 Group:          Libraries
98
99 %description libs
100 Beagle libraries.
101
102 %description libs -l pl.UTF-8
103 Bibiloteki Beagle.
104
105 %package devel
106 Summary:        Beagle development files
107 Summary(pl.UTF-8):      Pliki programistyczne Beagle
108 Group:          Development/Libraries
109 Requires:       %{name}-libs = %{version}-%{release}
110
111 %description devel
112 Beagle development files.
113
114 %description devel -l pl.UTF-8
115 Pliki programistyczne Beagle.
116
117 %package static
118 Summary:        Beagle static libraries
119 Summary(pl.UTF-8):      Statyczne biblioteki Beagle
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description static
124 Beagle static libraries.
125
126 %description static -l pl.UTF-8
127 Statyczne biblioteki Beagle.
128
129 %package apidocs
130 Summary:        libbeagle API documentation
131 Summary(pl.UTF-8):      Dokumentacja API libbeagle
132 Group:          Documentation
133 Requires:       gtk-doc-common
134
135 %description apidocs
136 libbeagle API documentation.
137
138 %description apidocs -l pl.UTF-8
139 Dokumentacja API libbeagle.
140
141 %package crawl-system
142 Summary:        Beagle crawl system
143 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
144 Group:          Applications/System
145 Requires:       crondaemon
146 Provides:       group(beagleindex)
147 Provides:       user(beagleindex)
148
149 %description crawl-system
150 Beagle crawl system.
151
152 %description crawl-system -l pl.UTF-8
153 System przeszukujący beagle-crawl.
154
155 %package evolution
156 Summary:        Beagle Evolution backend
157 Summary(pl.UTF-8):      Backend Beagle dla Evolution
158 Group:          X11/Applications/Networking
159 Requires:       %{name} = %{version}-%{release}
160 Requires:       dotnet-evolution-sharp >= 0.11.1
161 Requires:       evolution >= 2.10.0
162
163 %description evolution
164 Beagle Evolution backend.
165
166 %description evolution -l pl.UTF-8
167 Backend Beagle dla Evolution.
168
169 %package thunderbird
170 Summary:        Beagle Mozilla Thunderbird backend
171 Summary(pl.UTF-8):      Backend Beagle dla Mozilli Thunderbird
172 Group:          X11/Applications/Networking
173 Requires:       %{name} = %{version}-%{release}
174
175 %description thunderbird
176 Beagle Mozilla Thunderbird backend.
177
178 %description thunderbird -l pl.UTF-8
179 Backend Beagle dla Mozilli Thunderbird.
180
181 %package -n mozilla-firefox-extension-beagle
182 Summary:        Mozilla Firefox extension - beagle
183 Summary(pl.UTF-8):      Rozszerzenie dla Mozilla Firefox - beagle
184 Group:          X11/Applications/Networking
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       mozilla-firefox >= 2.0.0.1-2
187
188 %description -n mozilla-firefox-extension-beagle
189 Mozilla Firefox extension that allows Beagle to index every page the
190 user views.
191
192 %description -n mozilla-firefox-extension-beagle -l pl.UTF-8
193 Rozszerzenie dla Mozilla Firefox sprawiające, że Beagle indeksuje
194 każdą odwiedzaną stronę.
195
196 %package -n epiphany-extension-beagle
197 Summary:        Epiphany extension - beagle
198 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
199 Group:          X11/Applications/Networking
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       epiphany-extensions >= 2.18.0
202
203 %description -n epiphany-extension-beagle
204 Epiphany extension that allows Beagle to index every page the user
205 views.
206
207 %description -n epiphany-extension-beagle -l pl.UTF-8
208 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
209 odwiedzaną stronę.
210
211 %package -n python-%{name}
212 Summary:        Beagle Python bindings
213 Summary(pl.UTF-8):      Wiązania języka Python dla Beagle
214 Group:          Libraries/Python
215 Requires:       %{name} = %{version}-%{release}
216 %pyrequires_eq  python-libs
217
218 %description -n python-%{name}
219 Beagle Python bindings.
220
221 %description -n python-%{name} -l pl.UTF-8
222 Wiązania języka Python dla Beagle.
223
224 %package search-gui
225 Summary:        GNOME based Beagle GUI
226 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
227 Group:          Libraries/Python
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       gtk+2 >= 2:2.10.10
230
231 %description search-gui
232 GNOME based Beagle GUI.
233
234 %description search-gui -l pl.UTF-8
235 Oparty na GNOME graficzny interfejs dla Beagle.
236
237 %package startup
238 Summary:        Automatic startup integration for Beagle
239 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
240 Group:          X11/Applications
241 Requires:       %{name} = %{version}-%{release}
242 Obsoletes:      beagle-gnome
243
244 %description startup
245 Automatic session startup integration for Beagle.
246
247 %description startup -l pl.UTF-8
248 Integracja funkcji automatycznego startu Beagle.
249
250 %prep
251 %setup -q
252 %patch0 -p1
253 %patch1 -p1
254 %patch2 -p1
255 %patch3 -p1
256 %patch4 -p1
257
258 %build
259 %{__libtoolize}
260 %{__aclocal}
261 %{__autoconf}
262 %{__automake}
263 %configure \
264         --enable-static \
265         %{?with_apidocs:--enable-gtk-doc} \
266         --with-html-dir=%{_gtkdocdir} \
267         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
268         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
269         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
270         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird
271
272 %{__make} \
273         MOZILLA_HOME=%{_libdir}/mozilla \
274         pythondir=%{py_sitedir}
275
276 %install
277 rm -rf $RPM_BUILD_ROOT
278 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
279
280 %{__make} install \
281         DESTDIR=$RPM_BUILD_ROOT \
282         pythondir=%{py_sitedir}
283
284 dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
285 install -d $dest $dest/chrome
286 install mozilla-extension/{chrome.manifest,install.rdf} $dest
287 install mozilla-extension/chrome/beagle.jar $dest/chrome
288
289 # Kill useless files
290 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.18/extensions/*.{la,a} \
291         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
292
293 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
294 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
295
296 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
297
298 %find_lang %{name}
299
300 %clean
301 rm -rf $RPM_BUILD_ROOT
302
303 %pre crawl-system
304 %groupadd -g 166 -r -f beagleindex
305 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
306
307 %postun crawl-system
308 if [ "$1" = "0" ]; then
309         %userremove beagleindex
310         %groupremove beagleindex
311 fi
312
313 %post   libs -p /sbin/ldconfig
314 %postun libs -p /sbin/ldconfig
315
316 %files -f %{name}.lang
317 %defattr(644,root,root,755)
318 %doc AUTHORS COPYING ChangeLog NEWS README
319 %attr(755,root,root) %{_bindir}/beagle-config
320 %attr(755,root,root) %{_bindir}/beagled
321 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
322 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
323 %attr(755,root,root) %{_bindir}/beagle-extract-content
324 %attr(755,root,root) %{_bindir}/beagle-index-info
325 %attr(755,root,root) %{_bindir}/beagle-index-url
326 %attr(755,root,root) %{_bindir}/beagle-info
327 %attr(755,root,root) %{_bindir}/beagle-ping
328 %attr(755,root,root) %{_bindir}/beagle-query
329 %attr(755,root,root) %{_bindir}/beagle-shutdown
330 %attr(755,root,root) %{_bindir}/beagle-status
331 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
332 %attr(755,root,root) %{_libdir}/%{name}/*.exe
333 %dir %{_libdir}/%{name}
334 %dir %{_libdir}/%{name}/Backends
335 %dir %{_libdir}/%{name}/Filters
336 %{_libdir}/%{name}/*.dll
337 %{_libdir}/%{name}/*.dll.config
338 %{_libdir}/%{name}/Filters/*.dll
339 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
340 %{_mandir}/man*/*
341
342 %files libs
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
345
346 %files devel
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/*.so
349 %{_includedir}/libbeagle
350 %{_libdir}/*.la
351 %{_pkgconfigdir}/*
352
353 %files static
354 %defattr(644,root,root,755)
355 %{_libdir}/*.a
356
357 %if %{with apidocs}
358 %files apidocs
359 %defattr(644,root,root,755)
360 %{_gtkdocdir}/beagle
361 %endif
362
363 %files crawl-system
364 %defattr(644,root,root,755)
365 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
366 %dir %{_sysconfdir}/beagle
367 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
368 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
369 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
370 %attr(755,root,root) %{_sbindir}/*
371
372 %if %{with evolution}
373 %files evolution
374 %defattr(644,root,root,755)
375 %{_libdir}/%{name}/Backends/Evolution*.dll
376 %endif
377
378 %if %{with thunderbird}
379 %files thunderbird
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_bindir}/beagle-contactviewer
382 %{_libdir}/%{name}/Backends/Thunderbird*.dll
383 %endif
384
385 %files -n mozilla-firefox-extension-beagle
386 %defattr(644,root,root,755)
387 %{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
388
389 %if %{with epiphany}
390 %files -n epiphany-extension-beagle
391 %defattr(644,root,root,755)
392 %doc epiphany-extension/README
393 %attr(755,root,root) %{_libdir}/epiphany/2.18/extensions/libbeagleextension.so*
394 %{_libdir}/epiphany/2.18/extensions/*.xml
395 %endif
396
397 %if %{with python}
398 %files -n python-%{name}
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{py_sitedir}/*.so
401 %endif
402
403 %if %{with gui}
404 %files search-gui
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
407 %attr(755,root,root) %{_bindir}/beagle-search
408 %attr(755,root,root) %{_bindir}/beagle-settings
409 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
410 %{_pixmapsdir}/*.png
411 %{_desktopdir}/*.desktop
412 %endif
413
414 %files startup
415 %defattr(644,root,root,755)
416 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
417 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
This page took 0.121447 seconds and 4 git commands to generate.