]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
- R: jpackage-utils for %{_javadir}; cosmetics/cleanups
[packages/axis.git] / axis.spec
1 # TODO
2 #  - servletapi5 is needed by axis-1.2.1-0.2jpp.1.noarch
3 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
4 %define archivever %(echo %{version} | tr . _)
5 Summary:        A SOAP implementation in Java
6 Summary(pl.UTF-8):      Implementacja SOAP w Javie
7 Name:           axis
8 Version:        1.2.1
9 Release:        0.3
10 License:        Apache Software License
11 Group:          Development/Languages/Java
12 Source0:        http://ws.apache.org/axis//dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
13 # Source0-md5:  157ad070accf373565bce80de1204a4d
14 URL:            http://ws.apache.org/axis/
15 BuildRequires:  ant >= 1.6
16 #BuildRequires: ant-nodeps
17 BuildRequires:  jdk
18 # Mandatory requires
19 BuildRequires:  jaf
20 BuildRequires:  jakarta-commons-discovery
21 BuildRequires:  jakarta-commons-httpclient3
22 BuildRequires:  jakarta-commons-logging
23 BuildRequires:  javamail
24 BuildRequires:  jaxp_parser_impl
25 BuildRequires:  jpackage-utils
26 BuildRequires:  logging-log4j
27 BuildRequires:  rpmbuild(macros) >= 1.300
28 BuildRequires:  servletapi5
29 BuildRequires:  wsdl4j
30 # optional requires
31 BuildRequires:  castor
32 BuildRequires:  httpunit
33 BuildRequires:  jakarta-oro
34 BuildRequires:  jimi
35 BuildRequires:  jms
36 BuildRequires:  jsse
37 BuildRequires:  junit
38 #BuildRequires: xml-security
39 Requires:       jaf
40 Requires:       jakarta-commons-discovery
41 Requires:       jakarta-commons-httpclient3
42 Requires:       jakarta-commons-logging
43 Requires:       java
44 Requires:       javamail
45 Requires:       jaxp_parser_impl
46 Requires:       jpackage-utils
47 Requires:       log4j
48 Requires:       wsdl4j
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Apache AXIS is an implementation of the SOAP ("Simple Object Access
54 Protocol") submission to W3C.
55
56 From the draft W3C specification:
57
58 SOAP is a lightweight protocol for exchange of information in a
59 decentralized, distributed environment. It is an XML based protocol
60 that consists of three parts: an envelope that defines a framework for
61 describing what is in a message and how to process it, a set of
62 encoding rules for expressing instances of application-defined
63 datatypes, and a convention for representing remote procedure calls
64 and responses.
65
66 This project is a follow-on to the Apache SOAP project.
67
68 %description -l pl.UTF-8
69 Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
70 przekazanego do W3C.
71
72 Z projektu specyfikacji W3C:
73
74 SOAP to lekki protokół do wymiany informacji w scentralizowanym,
75 rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
76 się z trzech części: koperty definiującej szkielet do opisu zawartości
77 i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
78 wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
79 konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
80
81 Ten projekt jest następcą projektu Apache SOAP.
82
83 %package javadoc
84 Summary:        Javadoc for %{name}
85 Summary(pl.UTF-8):      Dokumentacja javadoc dla pakietu %{name}
86 Group:          Documentation
87 Requires:       jpackage-utils
88
89 %description javadoc
90 Javadoc for %{name}.
91
92 %description javadoc -l pl.UTF-8
93 Dokumentacja javadoc dla pakietu %{name}.
94
95 %package manual
96 Summary:        Manual for %{name}
97 Summary(pl.UTF-8):      Podręcznik do pakietu %{name}
98 Group:          Development/Languages/Java
99
100 %description manual
101 Documentation for %{name}.
102
103 %description manual -l pl.UTF-8
104 Podręcznik do pakietu %{name}.
105
106 %prep
107 %setup -q -n %{name}-%{archivever}
108
109 # Remove provided binaries
110 find -name '*.jar' | xargs rm -v
111 find -name '*.zip' | xargs rm -v
112 find -name '*.class' | xargs rm -v
113
114 %build
115 export JAVA_HOME=%{java_home}
116
117 CLASSPATH=$(build-classpath wsdl4j jakarta-commons-discovery jakarta-commons-httpclient3 jakarta-commons-logging log4j jaf javamail/mailapi servletapi5)
118 export CLASSPATH=$CLASSPATH:$(build-classpath oro junit jimi xml-security jsse httpunit jms castor 2>/dev/null)
119
120 export OPT_JAR_LIST="ant/ant-nodeps"
121 %ant \
122         -Dcompile.ime=true \
123         -Dwsdl4j.jar=$(find-jar wsdl4j) \
124         -Dcommons-discovery.jar=$(find-jar jakarta-commons-discovery) \
125         -Dcommons-logging.jar=$(find-jar jakarta-commons-logging) \
126         -Dcommons-httpclient.jar=$(find-jar jakarta-commons-httpclient3) \
127         -Dlog4j-core.jar=$(find-jar log4j) \
128         -Dactivation.jar=$(find-jar jaf) \
129         -Dmailapi.jar=$(find-jar javamail/mailapi) \
130         -Dxerces.jar=$(find-jar jaxp_parser_impl) \
131         -Dservlet.jar=$(find-jar servletapi5) \
132         -Dregexp.jar=$(find-jar oro) \
133         -Djunit.jar=$(find-jar junit) \
134         -Djimi.jar=$(find-jar jimi) \
135         -Djsse.jar=$(find-jar jsse/jsse) \
136         clean compile javadocs
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 ### Jar files
141 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
142
143 cd build/lib
144 install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
145         $RPM_BUILD_ROOT%{_javadir}/%{name}
146 cd -
147
148 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
149 for jar in *.jar ; do
150         vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
151         mv $jar $vjar
152         ln -fs $vjar $jar
153 done
154 cd -
155
156 ### Javadoc
157 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
158 cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
159 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post javadoc
165 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
166
167 %files
168 %defattr(644,root,root,755)
169 %doc LICENSE README release-notes.html changelog.html
170 %dir %{_javadir}/%{name}
171 %{_javadir}/%{name}/*.jar
172
173 %files javadoc
174 %defattr(644,root,root,755)
175 %{_javadocdir}/%{name}-%{version}
176 %ghost %{_javadocdir}/%{name}
177
178 %files manual
179 %defattr(644,root,root,755)
180 %doc docs/*
This page took 0.07421 seconds and 4 git commands to generate.