]> git.pld-linux.org Git - packages/autolog.git/blob - autolog.spec
- pass CC, sort verify() flags
[packages/autolog.git] / autolog.spec
1 Summary:        Terminates connections for idle users
2 Summary(pl):    Przerywa po³±czenia bezczynnych u¿ytkowników
3 Name:           autolog
4 Version:        0.40
5 Release:        3
6 License:        GPL
7 Group:          Daemons
8 Source0:        ftp://sunsite.unc.edu/pub/Linux/system/admin/idle/%{name}-%{version}.tar.gz
9 # Source0-md5:  bcca87156acfdce9171acc90b35f9d0d
10 Source1:        %{name}.init
11 Requires:       rc-scripts
12 Requires(post,preun):   /sbin/chkconfig
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Autolog is a program to automatically log off users who are idle for a
17 specified amount of time. A configuration file allows you to specify
18 different idle times and logout rules for different users, groups, tty
19 lines, etc.
20
21 %description -l pl
22 Autolog to program automatycznie wylogowuj±cy u¿ytkowników, którzy nie
23 korzystaj± przez okre¶lony czas z terminala. Plik konfiguracyjny
24 pozwala na okre¶lenie czasów oraz regu³ postêpowania dla ró¿nych
25 u¿ytkowników, grup, linii tty itp.
26
27 %prep
28 %setup -q
29
30 %build
31 # Remove stale binaries
32 %{__make} clean
33
34 %{__make} \
35         CC="%{__cc}" \
36         CFLAGS="%{rpmcflags}"
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man{5,8},/etc/rc.d/init.d,/var/log}
41
42 install autolog $RPM_BUILD_ROOT%{_sbindir}
43 install autolog.conf $RPM_BUILD_ROOT%{_sysconfdir}
44 install autolog.8.gz $RPM_BUILD_ROOT%{_mandir}/man8
45 install autolog.conf.5.gz $RPM_BUILD_ROOT%{_mandir}/man5
46 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
47
48 touch $RPM_BUILD_ROOT/var/log/autolog.log
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/chkconfig --add autolog
55 if [ -f /var/lock/subsys/autolog ]; then
56         /etc/rc.d/init.d/autolog restart >&2
57 else
58         echo "Run \"/etc/rc.d/init.d/autolog start\" to activate autolog."
59 fi
60
61 %preun
62 if [ "$1" = "0" ]; then
63         if [ -f /var/lock/subsys/autolog ]; then
64                 /etc/rc.d/init.d/autolog stop >&2
65         fi
66         /sbin/chkconfig --del autolog
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README CHANGES
72 %attr(755,root,root) %{_sbindir}/%{name}
73 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/autolog.conf
74 %attr(754,root,root) /etc/rc.d/init.d/%{name}
75 %{_mandir}/man?/*
76 %attr(640,root,root) %ghost /var/log/autolog.log
This page took 0.083038 seconds and 4 git commands to generate.