]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
40a071ff0a4f0e365a6a1b49c50d933846fdf0a7
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5 Summary:        aRts sound server
6 Summary(pl):    Serwer d¼wiêku
7 Summary(pt_BR): Servidor de sons usado pelo KDE
8 Name:           arts
9 Version:        1.1.2
10 Release:        1
11 Epoch:          12
12 License:        LGPL
13 Vendor:         The KDE Team
14 Group:          Libraries
15 Source0:        ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
16 %ifnarch sparc sparcv9 sparc64
17 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
18 %endif
19 BuildRequires:  audiofile-devel
20 BuildRequires:  glib2-devel >= 2.0.0
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libpng-devel
23 # not needed, only ./configure check for this
24 #BuildRequires: libvorbis-devel
25 #BuildRequires: mad-devel
26 %{?_with_nas:BuildRequires:     nas-devel}
27 BuildRequires:  pkgconfig
28 BuildRequires:  qt-devel >= 3.1
29 URL:            http://www.kde.org/
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _htmldir        /usr/share/doc/kde/HTML
33
34 %define         no_install_post_chrpath         1
35
36 %description
37 aRts sound server.
38
39 %description -l pl
40 Serwer d¼wiêku aRts.
41
42 %description -l pt_BR
43 O aRts é um sintetizador analógico em tempo real que é completamente
44 modular. Você pode criar sons e músicas (síntese em tempo real de
45 midi) usando pequenos módulos como oscilador para criar waveforms,
46 vários filtros, mixers, faders, etc. Você pode configurar tudo através
47 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
48 design foi escolhido para permitir que outras aplicações usem o aRts
49 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
50 outros.
51
52 %package X11
53 Summary:        X11 dependent part of aRts
54 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
55 Group:          X11/Libraries
56
57 %description X11
58 X11 dependent part of aRts.
59
60 %description X11 -l pl
61 Czê¶æ aRts wymagaj±ca X11.
62
63 %package qt
64 Summary:        QT dependend part of aRts
65 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
66 Group:          X11/Libraries
67 Requires:       %{name} >= %{version}
68 Requires:       qt >= 3.1
69
70 %description qt
71 QT dependend part of aRts.
72
73 %description qt -l pl
74 Czê¶æ aRts wymagaj±ca QT.
75
76 %package devel
77 Summary:        Sound server - header files
78 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
79 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
80 Group:          Development/Libraries
81 Requires:       qt-devel >= 3.1
82 Requires:       %{name} >= %{version}
83
84 %description devel
85 Header files required to compile programs using arts.
86
87 %description devel -l pl
88 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
89 arts.
90
91 %description devel -l pt_BR
92 Arquivos para desenvolvimento com o o aRts.
93
94 %package glib
95 Summary:        GLib dependend part of aRts
96 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
97 Group:          X11/Libraries
98 Requires:       glib >= 1.2.6
99
100 %description glib
101 GLib dependend part of aRts.
102
103 %description glib -l pl
104 Czê¶æ aRts wymagaj±ca GLib.
105
106 %prep
107 %setup -q
108
109 %build
110 kde_htmldir="%{_htmldir}"; export kde_htmldir
111 kde_icondir="%{_pixmapsdir}"; export kde_icondir
112
113 %configure \
114         --%{?debug:en}%{!?debug:dis}able-debug \
115         --disable-rpath \
116         --enable-final \
117         --with-xinerama \
118         --with%{?_without_alsa:out}-alsa
119
120 %if %{?_with_nas:0}1
121 # Cannot patch configure.in because it does not rebuild correctly on ac25
122 sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
123         < config.h \
124         > config.h.tmp
125 mv -f config.h{.tmp,}
126 %endif
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install DESTDIR=$RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %post   X11 -p /sbin/ldconfig
138 %postun X11 -p /sbin/ldconfig
139
140 %post   qt -p /sbin/ldconfig
141 %postun qt -p /sbin/ldconfig
142
143 %post   glib -p /sbin/ldconfig
144 %postun glib -p /sbin/ldconfig
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/artscat
152 %attr(755,root,root) %{_bindir}/artsd
153 %attr(755,root,root) %{_bindir}/artsdsp
154 %attr(755,root,root) %{_bindir}/artsplay
155 %attr(755,root,root) %{_bindir}/artsrec
156 %attr(755,root,root) %{_bindir}/artsshell
157 %attr(755,root,root) %{_bindir}/artswrapper
158 %attr(755,root,root) %{_bindir}/testdhandle
159 %{_libdir}/lib[!gqx]*.la
160 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*.*.*
161 %{_libdir}/mcop
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/artsc-config
166 %attr(755,root,root) %{_bindir}/mcopidl
167 %{_libdir}/*.so
168 %{_includedir}/arts
169 %{_includedir}/artsc
170
171 %files X11
172 %defattr(644,root,root,755)
173 %{_libdir}/libx11globalcomm.la
174 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
175
176 %files glib
177 %defattr(644,root,root,755)
178 %{_libdir}/libgmcop.la
179 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
180
181 %files qt
182 %defattr(644,root,root,755)
183 %{_libdir}/libqtmcop.la
184 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.031751 seconds and 3 git commands to generate.