]> git.pld-linux.org Git - packages/apache-mod_whatkilledus.git/blob - apache-mod_whatkilledus.spec
- restart apache in %postun rather in %preun as the config file, loading module
[packages/apache-mod_whatkilledus.git] / apache-mod_whatkilledus.spec
1 %define         mod_name        whatkilledus
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Knows what a thread was handling in case the thread segfaults
4 Summary(pl):    Modu³ wiedz±cy, co obs³ugiwa³ w±tek w przypadku naruszenia ochrony pamiêci
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0
7 Release:        1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://people.apache.org/~trawick/mod_whatkilledus.c
11 # Source0-md5:  e59c5d56e294a31e5b158ad5e4553001
12 URL:            http://people.apache.org/~trawick/exception_hook.html
13 BuildRequires:  apache-devel >= 2.0.43
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 Requires:       apache(modules-api) = %apache_modules_api
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
19 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
20
21 %description
22 Keeps a little bit of state on each active connection, which allows it
23 to know what a thread was handling in case the thread segfaults.
24
25 %description -l pl
26 Modu³ przechowuj±cy wybrane informacje o stanie ka¿dego aktywnego
27 po³±czenia, pozwalaj±ce dowiedzieæ siê, co obs³ugiwa³ w±tek w
28 sytuacji, kiedy spowodowa³ naruszenie ochrony pamiêci.
29
30 %prep
31 %setup -q -c -T
32
33 %build
34 %{apxs} -c %{SOURCE0}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
39
40 libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
41
42 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' \
43         > $RPM_BUILD_ROOT/etc/httpd/httpd.conf/68_mod_%{mod_name}.conf
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 %service -q httpd restart
50
51 %postun
52 if [ "$1" = "0" ]; then
53         %service -q httpd restart
54 fi
55
56 %files
57 %defattr(644,root,root,755)
58 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*mod_*.conf
59 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.124581 seconds and 4 git commands to generate.