]> git.pld-linux.org Git - packages/apache-mod_vhost_mysql.git/blob - apache-mod_vhost_mysql.spec
- Rel 1,
[packages/apache-mod_vhost_mysql.git] / apache-mod_vhost_mysql.spec
1 #
2 # TODO:
3 # Summary clean +pl, description,
4
5 %define         mod_name        vhost_mysql
6 %define         apxs            /usr/sbin/apxs
7 Summary:        Apache vhost in mysql
8 Name:           apache-mod_%{mod_name}
9 Version:        0.10
10 Release:        1
11 License:        GPL
12 Group:          Networking/Daemons
13 Source0:        http://fabienne.tc2.utelisys.net/~skinkie/mod_%{mod_name}2/mod_%{mod_name}2-%{version}.tar.gz
14 # Source0-md5:  c47c8dc4ac41e9ed2c91a239c876d272
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel
17 BuildRequires:  db-devel >= 4.2.52
18 BuildRequires:  mysql-devel
19 Requires(post,preun):   %{apxs}
20 Requires:       apache
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24
25 %description
26
27 %prep
28 %setup -q -n mod_%{mod_name}2-%{version}
29
30 %build
31 %{__make} APXS=apxs
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{_pkglibdir}
36
37 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
44 if [ -f /var/lock/subsys/httpd ]; then
45         /etc/rc.d/init.d/httpd restart 1>&2
46 fi
47
48 %preun
49 if [ "$1" = "0" ]; then
50         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51         if [ -f /var/lock/subsys/httpd ]; then
52                 /etc/rc.d/init.d/httpd restart 1>&2
53         fi
54 fi
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README
59 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.057581 seconds and 4 git commands to generate.