]> git.pld-linux.org Git - packages/apache-mod_transform.git/blob - apache-mod_transform.spec
- BR: ac,am,lt
[packages/apache-mod_transform.git] / apache-mod_transform.spec
1 %define         mod_name        transform
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl):    Modu³ do udostêpniania dokumentów XML
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4.0
7 Release:        2
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://www.outoforder.cc/downloads/mod_transform/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  a41ea16eeefb9b798186153b154a1219
12 Source1:        %{name}.conf
13 URL:            http://www.outoforder.cc/projects/apache/mod_transform/
14 BuildRequires:  %{apxs}
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRequires:  libxml2-devel
19 BuildRequires:  libxslt-devel
20 Requires(post,preun):   %{apxs}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
25
26 %description
27 mod_transform is a filter module that allows Apache 2.0 to do dynamic
28 XSL Transformations on either static XML documents, or XML documents
29 generated from another Apache module or CGI program.
30
31 %description -l pl
32 mod_transform to modu³ filtra umo¿liwiaj±cy serwerowi Apache 2.0
33 wykonywaæ dynamiczne przekszta³cenia XML na statycznych dokumentach
34 XML lub dokumentach XML generowanych przez inny modu³ Apache'a lub
35 program CGI.
36
37 %prep
38 %setup -q -n mod_%{mod_name}-%{version}
39
40 %build
41 %{__libtoolize}
42 %{__aclocal} -I m4
43 %{__autoconf}
44 %{__autoheader}
45 %{__automake}
46 %configure
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
52
53 install src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
54 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_transform.conf
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 if [ -f /var/lock/subsys/httpd ]; then
61         /etc/rc.d/init.d/httpd restart 1>&2
62 fi
63
64 %preun
65 if [ "$1" = "0" ]; then
66         if [ -f /var/lock/subsys/httpd ]; then
67                 /etc/rc.d/init.d/httpd restart 1>&2
68         fi
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc TODO
74 %attr(755,root,root) %{_pkglibdir}/*
75 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
This page took 0.064602 seconds and 3 git commands to generate.