]> git.pld-linux.org Git - packages/apache-mod_transform.git/blob - apache-mod_transform.spec
- rel 4 (rebuild with new apache)
[packages/apache-mod_transform.git] / apache-mod_transform.spec
1 %define         mod_name        transform
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl):    Modu³ do udostêpniania dokumentów XML
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4.0
7 Release:        4
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://www.outoforder.cc/downloads/mod_transform/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  a41ea16eeefb9b798186153b154a1219
12 Source1:        %{name}.conf
13 URL:            http://www.outoforder.cc/projects/apache/mod_transform/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apr-devel >= 1:1.0.0
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  libxml2-devel
20 BuildRequires:  libxslt-devel
21 BuildRequires:  sed >= 4.0
22 Requires:       apache(modules-api) = %apache_modules_api
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 mod_transform is a filter module that allows Apache 2.0 to do dynamic
30 XSL Transformations on either static XML documents, or XML documents
31 generated from another Apache module or CGI program.
32
33 %description -l pl
34 mod_transform to modu³ filtra umo¿liwiaj±cy serwerowi Apache 2.0
35 wykonywaæ dynamiczne przekszta³cenia XML na statycznych dokumentach
36 XML lub dokumentach XML generowanych przez inny modu³ Apache'a lub
37 program CGI.
38
39 %prep
40 %setup -q -n mod_%{mod_name}-%{version}
41 sed -i -e "s:apr-config:apr-1-config:g" aclocal.m4 m4/apache.m4
42 sed -i -e "s:apu-config:apu-1-config:g" aclocal.m4 m4/apache.m4
43
44 %build
45 %{__libtoolize}
46 %{__aclocal} -I m4
47 %{__autoconf}
48 %{__autoheader}
49 %{__automake}
50 %configure
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
56
57 install src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
58 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_transform.conf
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 if [ -f /var/lock/subsys/httpd ]; then
65         /etc/rc.d/init.d/httpd restart 1>&2
66 fi
67
68 %preun
69 if [ "$1" = "0" ]; then
70         if [ -f /var/lock/subsys/httpd ]; then
71                 /etc/rc.d/init.d/httpd restart 1>&2
72         fi
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc TODO
78 %attr(755,root,root) %{_pkglibdir}/*
79 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*.conf
This page took 0.067464 seconds and 3 git commands to generate.