]> git.pld-linux.org Git - packages/apache-mod_transform.git/blob - apache-mod_transform.spec
40b9eef3e99224ef3d35dcb6eeb72db5f975c35e
[packages/apache-mod_transform.git] / apache-mod_transform.spec
1 %define         mod_name        transform
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl):    Modu³ do udostêpniania dokumentów XML
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4.0
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://www.outoforder.cc/downloads/mod_transform/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  a41ea16eeefb9b798186153b154a1219
12 Source1:        mod_%{mod_name}.conf
13 URL:    http://www.outoforder.cc/projects/apache/mod_transform/
14 BuildRequires:  %{apxs}
15 BuildRequires:  libxml2-devel
16 BuildRequires:  libxslt-devel
17 Requires(post,preun):   %{apxs}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
22
23 %description
24 mod_transform is a filter module that allows Apache 2.0 to do dynamic
25 XSL Transformations on either static XML documents, or XML documents
26 generated from another Apache module or CGI program.
27
28 %description -l pl
29 mod_transform to modu³ filtra umo¿liwiaj±cy serwerowi Apache 2.0
30 wykonywaæ dynamiczne przekszta³cenia XML na statycznych dokumentach
31 XML lub dokumentach XML generowanych przez inny modu³ Apache'a lub
32 program CGI.
33
34 %prep
35 %setup -q -n mod_%{mod_name}-%{version}
36
37 %build
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
44
45 install src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_transform.conf
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 if [ -f /var/lock/subsys/httpd ]; then
53         /etc/rc.d/init.d/httpd restart 1>&2
54 fi
55
56 %preun
57 if [ "$1" = "0" ]; then
58         if [ -f /var/lock/subsys/httpd ]; then
59                 /etc/rc.d/init.d/httpd restart 1>&2
60         fi
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc TODO
66 %attr(755,root,root) %{_pkglibdir}/*
67 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
This page took 0.024114 seconds and 2 git commands to generate.