]> git.pld-linux.org Git - packages/apache-mod_transform.git/blob - apache-mod_transform.spec
- BR: apr-devel >= 1:1.0.0
[packages/apache-mod_transform.git] / apache-mod_transform.spec
1 %define         mod_name        transform
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl):    Modu³ do udostêpniania dokumentów XML
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4.0
7 Release:        3
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://www.outoforder.cc/downloads/mod_transform/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  a41ea16eeefb9b798186153b154a1219
12 Source1:        %{name}.conf
13 URL:            http://www.outoforder.cc/projects/apache/mod_transform/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apr-devel >= 1:1.0.0
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  libxml2-devel
20 BuildRequires:  libxslt-devel
21 Requires(post,preun):   %{apxs}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
26
27 %description
28 mod_transform is a filter module that allows Apache 2.0 to do dynamic
29 XSL Transformations on either static XML documents, or XML documents
30 generated from another Apache module or CGI program.
31
32 %description -l pl
33 mod_transform to modu³ filtra umo¿liwiaj±cy serwerowi Apache 2.0
34 wykonywaæ dynamiczne przekszta³cenia XML na statycznych dokumentach
35 XML lub dokumentach XML generowanych przez inny modu³ Apache'a lub
36 program CGI.
37
38 %prep
39 %setup -q -n mod_%{mod_name}-%{version}
40
41 %build
42 %{__perl} -pi -e "s:apr-config:apr-1-config:g" aclocal.m4 m4/apache.m4
43 %{__perl} -pi -e "s:apu-config:apu-1-config:g" aclocal.m4 m4/apache.m4
44 %{__libtoolize}
45 %{__aclocal} -I m4
46 %{__autoconf}
47 %{__autoheader}
48 %{__automake}
49 %configure
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
55
56 install src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
57 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_transform.conf
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 if [ -f /var/lock/subsys/httpd ]; then
64         /etc/rc.d/init.d/httpd restart 1>&2
65 fi
66
67 %preun
68 if [ "$1" = "0" ]; then
69         if [ -f /var/lock/subsys/httpd ]; then
70                 /etc/rc.d/init.d/httpd restart 1>&2
71         fi
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc TODO
77 %attr(755,root,root) %{_pkglibdir}/*
78 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
This page took 0.158812 seconds and 3 git commands to generate.