]> git.pld-linux.org Git - packages/apache-mod_gnutls.git/blob - apache-mod_gnutls.spec
86d6ca4ca55651df9d18b0ee059d103cc68ccf4c
[packages/apache-mod_gnutls.git] / apache-mod_gnutls.spec
1 %define         mod_name        gnutls
2 %define         apxs            /usr/sbin/apxs
3 Summary:        SSL v3, TLS 1.0 and TLS 1.1 encryption for Apache HTTPD
4 Summary(pl.UTF-8):      Szyfrowanie SSL v3, TLS 1.0 i TLS 1.1 dla serwera HTTP Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.5.3
7 Release:        0.1
8 License:        Apache Group License
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://www.outoforder.cc/downloads/mod_gnutls/mod_gnutls-%{version}.tar.bz2
11 # Source0-md5:  ef60af1f2763a7a2c3fdba952b7d25e0
12 Source1:        %{name}.conf
13 Source2:        %{name}-dhfile
14 Source3:        %{name}-rsafile
15 Patch0:         %{name}-libtool.patch
16 Patch1:         %{name}-paths.patch
17 URL:            http://www.outoforder.cc/projects/apache/mod_gnutls/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0.42
20 BuildRequires:  apr_memcache-devel >= 0.7.0
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gnutls-devel >= 2.4.0
24 BuildRequires:  libtool
25 Requires:       apache(modules-api) = %apache_modules_api
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
29 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
30
31 %description
32 mod_gnutls uses the GnuTLS library to provide SSL v3, TLS 1.0 and TLS
33 1.1 encryption for Apache HTTPD. It is similar to mod_ssl in purpose,
34 but does not use OpenSSL.
35
36 Features:
37  - Support for SSL v3, TLS 1.0 and TLS 1.1.
38  - Support for Server Name Indication
39  - Distributed SSL Session Cache via Memcached
40  - Local SSL Session Cache using DBM
41
42 %description -l pl.UTF-8
43 mod_gnutls używa biblioteki GnuTLS do obsługi szyfrowania SSL v3, TLS
44 1.0 i TLS 1.1 dla serwera HTTP Apache. Pod względem przeznaczenia jest
45 podobny do mod_ssl, ale nie używa biblioteki OpenSSL.
46
47 Możliwości:
48  - obsługa SSL v3, TLS 1.0 i TLS 1.1
49  - obsługa identyfikacji nazwy serwera (Server Name Indication)
50  - rozproszona pamięć podręczna sesji SSL poprzez Memcached
51  - lokalna pamięć podręczna sesji SSL korzystająca z DBM
52
53 %prep
54 %setup -q -n mod_%{mod_name}-%{version}
55 %patch0 -p1
56 %patch1 -p1
57
58 %build
59 %{__libtoolize}
60 %{__aclocal} -I m4
61 %{__autoheader}
62 %{__automake}
63 %{__autoconf}
64 %configure \
65         --with-apxs=%{apxs} 
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/{conf.d,tls}}
72 install src/.libs/libmod_gnutls.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_gnutls.so
73 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/40_mod_gnutls.conf
74 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/tls/dhfile
75 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/tls/rsafile
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 if [ "$1" = "1" ]; then
82         echo "Generating dhfile/rsafile - this may take some time..."
83         d=/etc/httpd/tls
84         [ -f "$d/dhfile" ] || /usr/bin/certtool --generate-dh-params --bits 1024 --outfile $d/dhfile
85         [ -f "$d/rsafile" ] || /usr/bin/certtool --generate-privkey --bits 512 --outfile $d/rsafile
86 fi
87 %service -q httpd restart
88
89 %postun
90 if [ "$1" = "0" ]; then
91         %service -q httpd restart
92         rm -f /etc/httpd/tls/{dhfile,rsafile}
93 fi
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(750,root,root) %dir %{_sysconfdir}/tls
98 %dir %{_sysconfdir}/tls
99 %attr(640,root,root) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_gnutls.conf
100 %attr(755,root,root) %{_pkglibdir}/mod_gnutls.so
This page took 0.048186 seconds and 3 git commands to generate.