]> git.pld-linux.org Git - packages/apache-mod_bw.git/blob - apache-mod_bw.spec
3cc0bdc023ea0085141706503ed3f82affac898c
[packages/apache-mod_bw.git] / apache-mod_bw.spec
1 # TODO:
2 # - cron?
3 %define         mod_name        bw
4 %define         apxs            /usr/sbin/apxs
5 Summary:        Apache module: bandwidth limits
6 Summary(pl):    Modu³ do Apache: limity pasma
7 Name:           apache-mod_%{mod_name}
8 Version:        0.6
9 Release:        2
10 License:        Apache
11 Group:          Networking/Daemons
12 Source0:        http://www.ivn.cl/apache/bw_mod-%{version}.tgz
13 # Source0-md5:  0c92fa6344f487321291a592dbb49856
14 Source1:        %{name}.conf
15 Patch0:         %{name}-apr_1.0.patch
16 URL:            http://www.ivn.cl/apache/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel >= 2.0.0
19 BuildRequires:  sed >= 4.0
20 Requires:       apache(modules-api) = %apache_modules_api
21 Requires:       crondaemon
22 Requires:       procps
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 "Mod_bandwidth" is a module for the Apache webserver that enable the
30 setting of server-wide or per connection bandwidth limits, based on
31 the directory, size of files and remote IP/domain.
32
33 %description -l pl
34 Modu³ pozwalaj±cy na ograniczanie pasma serwera Apache bazuj±c na
35 katalogu, wielko¶ci plików lub zdalnym IP/domenie.
36
37 %prep
38 %setup -q -n bw_mod-%{version}
39 %patch0 -p1
40 sed -i -e 's@include "apr@include "apr/apr@g' bw_mod-%{version}.c
41 sed -i -e 's@^.*apr_buckets.h.*$@@' bw_mod-%{version}.c
42
43 %build
44 %{apxs} -c bw_mod-%{version}.c
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf} \
49         $RPM_BUILD_ROOT%{_var}/run/%{name}/{link,master} \
50         $RPM_BUILD_ROOT{/etc/cron.d,%{_sbindir}}
51
52 install .libs/bw_mod-%{version}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
53 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/97_mod_%{mod_name}.conf
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 if [ -f /var/lock/subsys/httpd ]; then
60         /etc/rc.d/init.d/httpd restart 1>&2
61 fi
62
63 %preun
64 if [ "$1" = "0" ]; then
65         if [ -f /var/lock/subsys/httpd ]; then
66                 /etc/rc.d/init.d/httpd restart 1>&2
67         fi
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc bw_mod-%{version}.txt LICENSE
73 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
74 %attr(755,root,root) %{_pkglibdir}/*.so
75 #%config(noreplace) %verify(not size mtime md5) %attr(640,root,root) /etc/cron.d/%{name}
76 #%attr(755,root,root) %{_sbindir}/*
77 %attr(750,http,root) %dir %{_var}/run/%{name}
78 %attr(750,http,root) %dir %{_var}/run/%{name}/link
79 %attr(750,http,root) %dir %{_var}/run/%{name}/master
This page took 0.077019 seconds and 3 git commands to generate.